cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

4573
Views
0
Helpful
8
Replies
Highlighted
Beginner

RV220w port forwarding notworking

I want to forward a few port in the 8000-8100 series.

Goal is to reach the web interfaces for secondary routes true HTTPS protocol.

Port forwarding seems not to be working.

Someone experience / solution for this. i realy can use some help.

for current settings see below

For exaple 1 router IP wan = 192.168.0.17 protocol Https port 8007 open for external.

This is an static IP adres configured in the RV220W

RV220 settings

WAN IP automaitc configuration -> external DHCP 192.168.0.100

Network LAN IP 191.168.0.1

submask 255.255.255.0

DHCP mode : DHCP server.

start 191.168.0.2

end 191.168.0.10

static adresses

191.168.0.15 port forward 8005

191.168.0.17 port forward 8007.

firewall settings

Connection type inbound

action always allow

service Https

source Ip any

send to local server Dnat ip 191.168.0.17

rule status enabled

Port forwarding

Action always allow

service Https

source Ip any

destination 191.168.0.17

internalport 8007

Remote acces true webbrowser : Https://192.168.0.100:8007

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
8 REPLIES 8
Highlighted
Advocate

Hi Jhon, what is the WAN Ip address of the router?

Also, you may want to delete the port forwarding rules and try to make an access rule instead. Also make sure you're on the 1.0.4.17 firmware.

If you need to upgrade to the 1.0.4.17 firmware, factory default the router, it fixed A LOT of bugs.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Highlighted

frimware is 1.0.4.17.

WAN adress is 192.168.0.100  there is a ISP router before firewall at testlocation

firewall creater a  access rule with te creation  of the forward rule.

Highlighted

Hi Jhon, I understand the RV220W creates an access rule when creating a port forwarding rule. Instead of creating a port forward, create an access rule instead (which will create the port forward). The port forwarding section of the router doesn't work well for whatever reason.

Does the ISP router have all services forwarding to the RV220W or a DMZ set up or anything? If there is nothing configured on the ISP router the RV220W won't work no matter what configuration is done there.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Highlighted

Hi Tom,

With the use of a access rule tis no solution, only result is that firewall interface has become unreachable from wan port side.

ISP access is not a problem I’m testing  on local site of the ISP router.
Through  the same access point without the firewall it works ok.

Maybe is the Cisco RV220W not suitable for mass usage in this project.

Highlighted

Hi Jhon, the RV220W port forwarding is very stable through access rules on the 1.0.4.17 firmware. There is no reason for the RV220W interface to become unreachable because you made an access rule unless it overlaps with your remote management port, which would have the same result using a port forward.

I would recommend you test TCP sockets locally (behind the router) and over the WAN IP of the router from the subnet of the upstream router.

If I were testing this at your location I would do the following-

-Connect a computer to the LAN subnet of the RV220W and obtain an IP address on the same subnet as the resource you want to access

-Telnet the IP address of the resource and the port number, example-  telnet 192.168.0.150 8007

-The telnet screen should change, if it times out, the resource is not accepting inbound connections

-Connect a computer to the LAN subnet of your upstream router and obtain an IP address on the same subnet as the WAN interface of the RV220W

-Try to telnet the WAN IP address of the RV220W using the port you have forwarded to the resource, example telnet RV220W wan:8007

If you can't make TCP sockets this way, either the access rules/forwarding is not configured correctly or the resource is not configured correctly.

This also may be a fundamental networking issue. I am having a hard time to decipher the IP addresses you're using but it almost seems like the IP addresses on the RV220W LAN correspond to IP addresses on the subnet. You said 1 router is 192.168.0.17 while the RV220W is 192.168.0.100. This is fine but you also said you have some devices 192.168.0.15 port 8007. This is not fine. This IP won't work if the LAN subnet of the RV220W is the same as the WAN subnet.  That won't work with any router unless it were a transparent port... and if it were a transparent port you wouldn't need any forwarding.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Highlighted

I don’t see a option for configuring port numbers in access rules.
When I use the access rule option 1 interface is reable on port 443 , why I don’t know.

Interface from the RV220W is not reachable any more then.

The telnet test is good also is secondary router which I want to reach available in the Lan subnet from the RV220W

I have the RV220 on an open internet connection , you are welcome to take a look,

But Ip adres an Login on open forum not a option.

Also current config in attachment.

Highlighted
Highlighted

Sina thanx

That works as a workaround for me.


As long as the device where you want to forward to  has a configurable port number.
If it is a static port number is , as with many web interfaces port 80 or 8080,  the port forwarding is a  really needed option.

Cisco when you come with a new firmware release where this bug is resolved?