cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest Cisco news in this December issue of the Cisco Small Business Monthly Newsletter

14114
Views
15
Helpful
12
Replies
Beginner

RV220W: Very slow wifi connection???!!!

I'm an IT professional with more than 10 years experience. I have spent last 5 days trying to figure out why the wifi connection to this router is so slow, but still no luck. I'm getting only 13Mbps even if my laptop is next to the router! (wired connection worked ok)

I have tried all sort of setting combinations, 2.4GHz/5GHz; N only/ G,N Mixed;  Auto/20MHz bandwidth; different channels; WPA2 encrypted vs open; disable firewall; wmm enabled/disabled; 1.0.0.26/1.0.1.0 firmware... no matter what I try, I always get only 10 - 15Mbps speed.

Once I replace this router with my old router, it worked perfectly --- getting 70 - 80Mbps with exactly the same testing environment and configuration.

I really expect this router to offer much faster wireless speed according to this review:

http://www.smallnetbuilder.com/wireless/wireless-reviews/31427-new-to-the-charts-cisco-rv-220w-wireless-n-vpn-firewall

Could anyone help me out? This is driving me crazy!

Much appreciated!

Kelvin

Everyone's tags (4)
12 REPLIES 12
Rising star

RV220W: Very slow wifi connection???!!!

Hi, My name is Eric Moyers. I am a Network Support Engineer in the Cisco Small Business Support Center.

The issue that your describing here may be too complex to quickly resolve through e-mail and postings. I would highly recommend that you call the customer support center nearest you and let one of our answering agents assist you with this issue.

You can find a listing here: http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

If you are in the US please call 1-866-606-1866. We are open 24 hours a day 7 days a week.

Eric Moyers
Cisco Network Support Engineer
CCNA, CCNA-Wireless
1-866-606-1866

RV220W: Very slow wifi connection???!!!

FYI I have experienced a similar problem. It was solved by this, but this may not apply to your case.

Changing the channel from 6 to 5 raised the speed to the LAN speed (also when the channel was changed back to 6)

Beginner

RV220W: Very slow wifi connection???!!!

Thanks for sugguestion, but I have tried every single channel of both 5Ghz and 2.4GHz, the highest speed i got is 18Mbps.

Another issue, the pptp vpn server doesn't work! 1.0.0.26 allow me to connect, but can't ping or access others behind the router. 1.0.1.0 doesn't even allow me to connect!

I have called this #: 1-866-606-1866 twice this morning and this afternoon,waited more than 15 minutes each time, NO one pick up the phone!!

This is cisco???!!!

Enthusiast

RV220W: Very slow wifi connection???!!!

you need to contact Cisco support they should be able to offer you 1.0.2.4 which has plenty of fixes including pptp.

Regards Simon
Highlighted

RV220W: Very slow wifi connection???!!!

If version 1.0.2.4 fixes many of the problems with this router why don't they make it available for download? I don't want to spend hours on the phone.

RV220W: Very slow wifi connection???!!!

It probably still is a beta version.

I have the 1.0.2.1 beta version and although the basic functions are working, I discover new bugs every time I use a new feature.

Currently I have compiled a list of about 15 problems.

Enthusiast

Re: RV220W: Very slow wifi connection???!!!

I hope my contacts dont mind me posting this.

Latest Firmware- 1.0.2.4 (was 1.0.2.3)

Please check out the attachment and download for latest firmware.

Bugs Fixed:

22032             Guest user is able to execute print secure settings link and email system summary link

22206             Configuration file name field in Advanced DHCP Configuration page is not having limit for maximum characters

23100             If SLA ID is set to "0", router is not forwarding IPv6 packets to "sit0" interface.

23245             Device not accepting ASCII Characters After F (G to Z) in WEP Key.

24313             Critical error observed when trying to delete the default vlan and clicking on save button for the second time

24565             PPTP server is not running in the backend, for specific of ip addresses.

24651             Unable to activate the protectlink license

24843              Request to have RA managed flag Enabled by default

24890             When PPTP Server is enabled, WAN-> LAN traffic running over Inbound firewall rules is source natted to RV220W lan ip

24975             Use the attached photo for the Setup Wizard of RV220W

25096             Need to include delete and display options in ssl certificates page

have you contacted Cisco with your list of issues?

Regards Simon

Re: RV220W: Very slow wifi connection???!!!

have you contacted Cisco with your list of issues?

Oh, sure. They know me !  Waiting for them to reopen the prematurely closed cases and return.

Enthusiast

RV220W: Very slow wifi connection???!!!

Just sent you a private message.  Check it!

Regards Simon
Enthusiast

RV220W: Very slow wifi connection???!!!

it is only a Beta firmware.  releasing Firmware which is under GPL software licencing laws is not just as easy as allowing you "joe public" to download and fix your issues.

That would be easy. 

unfortunately people like the  gpl-violations crowd just love threating companies, including my own website with closure due to violations that allow users to just download the firmware.  If firmware is under GPL, then the source code has to be made readily available as well. this is not an easy thing to do. code has to be trawled through and any copyright/private code removed before making it available. this does not happen overnight.

I personally thing the GPL Laws need to be overhauled as these restrict users who only want a fixed firmware from actually obtaining it quickly.

Excuse my rant. its over

Regards Simon
Enthusiast

Re: RV220W: Very slow wifi connection???!!!

contacts for Cisco are listed here:

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

Live Support

Support is free for products under service contract or warranty. Support for out-of-warranty products may incur a fee. To simplify your call or chat:
  1. Have your product serial number and Cisco.com user name ready. (Register if needed.)
  2. Update your profile with your service contract information, if applicable.
Live Chat
Online Chat with a technical support engineer.
Regards Simon
Beginner

RV220W: Very slow wifi connection???!!!

SOLVED..

Under Wireless.. Go TO

1- "Basic Settings"

2- "Wireless Basic Setting Table"

3- Select your wireless SSID

4- Click on "Edit WMM" button

5- Disable

6- SAVE

The wireless will diconnect on your device for few seconds and it will connect back. Voila!

Now do a speed test, the results will show like ethernet results.