cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1811
Views
5
Helpful
24
Replies
Pandabrain
Beginner

RV320 Bug - Service Management Table (Port Forwarding)

I'm unable to add more than 16 entries for port forwarding.

It's a RV320 on v1.1.1.06 (newest to date) and it doesn't accept more than 16 entries in the "Service Management Table" required for port forwarding. As soon as I try to enter number 17 and hit save the window closes like it always does but you can see for a short time it says "Critical failure. Please contact support." Everything else works, except for the entry in the Service Management Table. I'm also unable to use it in the port forwarding section, it just doesn't save the entry. I'm unable to add any services to the list unless I delete others but it only works again until number 16.

Actually the "limit" is 37 because it comes with 21 services entered out of the box.

I couldn't find any bug reporting website that I could use without a contract. So I seek for help here.
Anybody else having this issue or is it just my device?

24 REPLIES 24

Hi ,

 

Changing it to view fewer rows on a single page works - at least I now have managed to add a 17th entry. Didn't need compatibility mode. This is still a bug though, as it indicates an inability to deal with a fairly small number of form items in the code on the unit processing the data. Pretty sloppy not to have tested it with more than 16 rows worth of fields in the form.

 

I'd already opened a ticket with support, I sent a copy of my config and it has been passed it up to next level support for investigation, so it looks like they're still taking it as a bug and another Cisco employee had already posted that there was a firmware that fixes this in beta test.

 

If the SSL VPN ActiveX issues can be sorted out, most (if not all) of which require just a change to the user agent checks to deal with the changes in IE10/11, and replacing the controls with ones that don't have an expired certificate, I might be able to roll this RV320 out into production.

 

Dan

Given the reply I've had from Cisco support regarding the SSL VPN issue it looks like I'll be returning the RV320 for a refund and probably looking at a Netgear router instead. This is a copy from the email I received:

 

"Engineering has no plans to support SSL VPN on RV32x due to chipset limitations. Pretty much, it will work for old XP and Win7 32-bits."

 

So Cisco are falsely advertising that the RV320 has SSL VPN capabilities when there are no plans to update it so that it works with 64-bit Windows (which is now the major install base for Windows as most new systems are 64-bit based), and as the certificates have expired in the SSL VPN components they are not even useable on 32-bit systems without overriding a number of security settings.

 

Clearly Cisco are not the company they once were.

 

Dan

The RV320 has turned out to be a sour lemon - the worst router I have ever owned.

And now they're downright saying they won't fix an advertised, but broken, feature? That's not even just bad customer service. That's borderline fraud.

Unfortunately, mine is a bit old now, as I was naive enough to wait for bugs to be fixed. Pretty much none of the selling points works as advertised :(.

I've had another reply from Cisco support overnight in response to a post I sent telling how to fix the SSL issue (change the user agent check for IE, replace the ActiveX controls), and the reply I got was unexpected but somewhat encouraging:

 

"Engineering have decided to add SSL VPN for RV320 in the roadmap for next MR (MR3) - tentatively scheduled for April. Thanks for your patience and cooperation."

 

I won't hold my breath, but it if they do fix this then there might be hope yet.

 

Dan

Well my previous reply was premature, changing the number of rows did allow me to add another service but today when  I needed to add another it's not possible to change the number of rows - changing the value in the drop down menu results in the "Critical failure" message from the router operating system. Have tried every combination of compatibility mode and document rendering versions in IE11 to no avail, also tried IE9 (both normal and compatibility) on another PC and has the same issue. The service management part is definitely bugged, and renders the router unusable when you need more than 16 additional services entered.

 

I'm still waiting for a follow up on my Cisco support ticket, it was passed to "next level" on the 26th November and haven't had a response since. Chasing this up again by email to support as I have an expensive piece of junk on my desk that can't be put into production on my network.

 

Dan

Hi 

 

Does anyone have info on this upgrade, having the same issue here with RV320 :( now 37 lines, cannot edit, delete, add.... terrible

Contact Cisco support, explain the problem, ask for the 1.1.1.19 beta firmware, this issue is fixed for me using this version.

 

Dan

Hi, no luck, first level support has no access to beta firmwares... it was passed to next level and they promised to send an update soon. Havent got any so far.... :(

Took me a few days to get it, but so far it seems to be stable.

Same here, beta firmware installed and seems to be stable so far.