cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

2060
Views
40
Helpful
9
Replies
Highlighted
Beginner

RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

We updated successfully an RV320 to 1.4.2.22 via a browser (Chrome) and immediately lost the ability to reach the log-in page from a browser.  We tried a factory reset and all the above browsers without a good result. Either there is no response at all or we get a certificate/dangerous site warning and the log-in page won't display even when clicking advance.  I then set up a tftp server (Tftpd64 on Windows 7) and successfully downgraded to (the insecure) 1.3.2.03 version.  It works perfectly.

We repeated the upgrade using tftpd64 to 1.4.2.22 after a fresh firmware download from Cisco and the upgrade proceeded without errors but has the same problem with no ability to reach the log-in page from any browser. Now we are back on a functioning insecure 1.3.2.03.

After the upgrade to 1.4.2.22, we can ping 192.168.1.1 successfully.  We just have no way to reach the log-in page from any browser!

This looks like a firmware bug.

Any ideas?

9 REPLIES 9
Highlighted
Beginner

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

To eat my own dog food, I enabled SSH login in the working version 1.3.x.xx, ran the 1.4.2.22 update from the tftd server and found (as usual) that login GUI page was dead.  However, I could now SSH in and a check of the 1.4.2.22 settings showed the unit date was set to 6-6-2024(!) for some reason.  I reset the date and time correctly via SSH and rebooted and the GUI came good—and I was able to complete setup of the VPN as normal.

My guess is that that the date error was somehow blocking the certificate check and hanging the GUI.   I hope this description helps If this happens to others when running the 1.4.2.22 update.

Highlighted
Beginner

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

I am having the same issue with an RV320.  I checked the login page HTML that is coming back, and there is a missing JS reference to "language.js" which causes the page to not render and therefore I cannot login to it.

 

I also cannot get SSH into it, because my password will not work

Highlighted
Beginner

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

Set back to factory defaults (cisco/cisco), setup Tftpd server (https://www.cisco.com/c/en/us/support/docs/smb/routers/cisco-rv-series-small-business-routers/smb4890-workaround-for-inaccessibility-of-gui-after-firmware-version.html ) to flash new firmware to it using Tftpd64 application (free on net), log-in to GUI and set SSH access to ON, and then setup your settings again.
I’m using FF 68.1 to access without problems now,
Highlighted
Beginner

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

I have a similar issue.  I updated the firmware on my RV320 a few weeks ago to 1.4.2.22 as I was getting random network latency and the router began becoming unresponsive.  I also have a Linksys EA7500 as a wireless AP on my network.  Yesterday, BOTH the RV320 and EA7500 became completely unresponsive, and unable to be accessed by a web interface, and unable to be reset to default config.

I imagine I will have to tftp into it and roll back, but just thought it was kinda strange for both units to brick at the same time?  Any thoughts?

Note:  I am not sure, but it is possible I was being UDP DDoSed for a while (logs would indicate that multipul random UDP ports were being probed, by a huge variety of hundreds of IP addresses, all at the same time log)...  So maybe this was done on purpose?  Also note, the MAC of the Cisco RV320 is displaying 00:DE:AD:20:75:02  >.>

Highlighted
Beginner

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

Hello,

I managed to solve this issue by proxy the cisco access throw a nginx server. The script language.js was not found so i find a demo portal offered by Cisco from where i proxied the file.

 

The config for nginx can be found bellow:

 

server {
listen 20080;
server_name localhost;


location / {

# for https access
proxy_pass https://router_Ip:router_port;

# for http access

#proxy_pass http://router_Ip:router_port;
}

 

location /language.js {
proxy_pass https://www.cisco.com/assets/sol/sb/RV320_Emulators/RV320_Emulator_v1.1.0.09/language.js;
}

}

 

After this i have accessed the nginx on port 20080 and try to login by changing the language to french which triggered the access to become functional again.

I would say a nice solution to obtain access to the router and perform backup.

Hope it helps others.

 

Enjoy,

Daniel

 

Highlighted

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

I have fixed it with pure javascript.

Since the dom is just invisible due to missing "language.js" file - some do elements have incorrect state.

So, the easy way is to "set programmatically" the language combobox value AND execute POST request to the sever (rv320)

Here is the steps:

1. Open you routers login page

2. Open dev tools in your browser -> select Console and be ready to type 3 commands.

[I got the html source from page and found this code in it, Software Engineers may find this here: "function LanguageChange()"]

3. Print and hit enter: document.form_contents.changelanguage.value = "ENGLISH"

4. Print and hit enter: document.form_contents.submitStatus.value=1

5. Print and hit enter: document.form_contents.submit()

6. POST request must be sent to webserver of rv320 and page reload must occur.

Now your router is usable.

In case of any mistakes pls feel free to contact me by email: GothicSecret@gmail.com

Thanks, Max.

Everyone's tags (6)
Highlighted
Beginner

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

I have four routers (one RV082, three RV325s) with the same issue.  For one RV325, using the browser Console worked.  For the RV082, a simple reboot got my sign-on screen to display and I have full access again.  For the other two RV325s, I need to do a reboot, but they are remotely located and I will get reboots done first, then hopefully all will be well, or I can do the Console fix.

Thanks for posting this, it saved the day for me.

Highlighted
Beginner

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

I have a three RV325's.  One of them has now had this issue for the third time.  Are there any suggestions for how to prevent this from happening again? 

 

Thanks,

Sam

 

Highlighted

Re: RV320 firmware 1.4.2.22 refuses to display login page with Safari, Chrome, Firefox and Edge

Hmmm. It has happened to me only once.
But I have this router less than a year for now.
I have firmware version 1.5.1.05
Does you problem with UNDEFINED block you to log in?