cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

6018
Views
16
Helpful
49
Replies
thekeatons
Beginner

RV320 limits IP & MAC Binding to 30 entries

I have a new RV320 with firmware 1.1.1.19 installed. I have a small business network with about 45-50 devices on it all configured for DHCP from the router. I want to reserve all the MAC addresses to DHCP provided IP address and be able to enable the Block Mac Address features for unknown and wrong IPs.

Firmware .19 is working fine for this but is limiting me to 30 entries as the attached screen snip shows. The documentation for the RV320 states it should be up to 100. Limiting it to 30 is not allowing me to enable the Block Mac Address features like I would like.

The router came with an earlier firmware out of the box but I updated to 1.1.1.19 before doing any configuration other than plugging it in. I do not know if the previous firmware limited the IP & Mac Binding to 30 as well or not.

Has anyone else run into this issue or is it a known bug and I didn't find it in the forum?

 

49 REPLIES 49

HI, do you have a case opened with the Support Center? If so please provide it as I cannot see the status. I will follow up.

Thanks

Glenn

 

Yes, I opened it. They already closed the ticket and answer me on 04/05/2015:

This fix didn't make it into the upcoming May release.  It is now targeted for the next release after that, which will be a ways out.  
I am working on firmware version 1.1.1.06 with more than 90 entries, check note below.

Thanks Daniel, Thanks for the update. I assume you're talking about 1.2.1.13 that this fix didn't get implemented in. Glad they know about it and are preparing to respond to it in the next release.

southerndoc
Beginner

I purchased an RV320 and received it yesterday.  I immediately updated to the latest firmware (1.2.1.13).

I cannot enter more than 30 IP addresses for binding.  I have 48 that need to be entered.

I've factory reset the router without any luck.

Any other suggestions?  Was this actually fixed so users could enter more than 30, or does this limit still remain?

This issue isn't in the Resolved Issues list in the release notes, so that explains why it still doesn't work for you.

The issues I was waiting for to be fixed, which the release notes claimed are fixed, don't work either so I'm now at the point of dumping this router, waiting for a response from an email I sent to support on Friday.

 

Dan

Please let us know when you get any information from support. 

We also have to throw away this router when we cannnot use at least 60 IP addresses for binding.

stuartprice99
Beginner

Has anyone tried this workaround?

If you make a Backup of your sys config, in the 'config.exp' file there is a [STATIC_IP] list which contains plain text of your static IP assignments.

If you edit this (not forgetting to update the NUMBER=xx at the bottom of the list) and then restore from it i wonder if it would get around the issue this until the firmware is released.

Worth a try, making sure to keep a copy of the original config.exp

 

I'm confirming the above workaround works.

 

I've successfully added over 50 records on an RV320 that was previously showing the maximum limit of 30 error.

 

Export the config file, edit in notepad/textedit adding new entires, make sure to change the total number at the end (NUMBER=xx) to reflect your additions and then restore from this file.

Thanks to rvatalaro and stuartprice99 for this flurry of activity on this useful thread. Certainly seems like Stuart's fix can be made to deliver then! TBH, the steps spelled out by Stuart are exactly what I did AFAIK. I gave up when I got the file errors described, and moved on to another phase of my network development planning. However, I am close to a final config session on this RV325 before swapping it in place of my RVS4000, so your words of encouragement are well timed. I'll try again ASAP and report back.

I just tried this workaround.  It seemed to work -- added a 31'st entry.  I am running 1.2.1.14, but did not reset the RV325 to factory defaults first.  I just restored from the updated config.exp file.  Indeed, I never bothered to look at these config.exp (exported) files before, and I was very pleased to see they are text!  (This seems to open up possibilities for text configuration of the device.  The CLI does not give us a whole lot.)  Anyway, I added a new line (in IP Address order -- not sure if that matters on input), and changed NUMBER=31.  The MAC address in question was offline, so I made one up, and then I went back and changed it (after the import), so that's good that that worked.  Because the list is sorted by IP address, the line was not the 31'st entry in the list.  Finally, I was able to edit the 31'st entry in the list also.

UPDATE:
I re-exported the config, and then diff'd my changed config (that I just imported and had changed that MAC address) with the new exported config.  Everything was as expected except for this: there was a SUM=xxx difference in the [CHECKSUM] section.  I'm not sure what to make of this on import or export.  I do know that, so far, this import of a changed config.exp file seems to be working OK.  I'll report back here if something happens to make me think the import messed things up.

Glad to hear you got this workaround to come good rvatalaro. I have no idea where I have been going wrong to get the "Bad configuration file!" error message I explain in some detail in my posts in this thread https://supportforums.cisco.com/discussion/12734176/rv325-cant-add-more-30-ip-and-mac-binding-entries.

FWIW a UK Cisco Support representative told me recently that a firmware fix for this bug is scheduled for March.

Meantime, can you please be a little bit more specific as to the sequence you worked through, especially in relation to export and import of the config.exp file? I am also running FW 1.2.1.14 BTW.

EDIT: Re your UPDATE... what exactly do you mean by Quote: "then diff'd my changed config" Unquote? Don't understand!

Correct - this DOESN'T require a factory default reset.

Go to system management>backup and restore and select 'backup configuration file to PC', then 'Backup Startup Configuration'. Save this file to the Desktop.

Open the file in any text editor, scroll about a third through the file until you find the title [STATIC_IP]

In this list, simply duplicate any entry and edit it to represent the mac address, ip address and name of the new device(s) you wish to add.

At the bottom of the list, change 'NUMBER=' to reflect the new amount of devices you have.

Save the file.

Back in system management>backup and restore, select 'choose file' at the top and select the config.exp file you just edited to upload it back to the router. It will restart and your IP binding list will be as long you just made it.

FYI you can edit the entire routers configuration via the text file, sometimes its more straightforward than using the GUI which seems to throw off many unusual errors from time to time.

For your info,  the engineers have more or less settled on 80 entries as the upper limit through the user interface,  as anything higher would have introduced stability issue on this piece of hardware. You can do anything through the backdoor, import or whatever, at the expense of quality control  but this is what the engineers informed me late last year.

>>> 80 is the maximum number of bindings that can be supported; it was evaluated by development since we got some instability issues which was finally identified because of this. Subsequently, we have to lower the number to improve stability.

Norrie603, I wasn't aware of that other thread (only ran into this problem today when I went to add the 31'st IP&Mac Binding), and I haven't looked at it yet.  I wanted to respond to your questions.

The sequence I went through is as follows.  I did System Management ==> Backup and Restore ==> Backup Startup Configuration.  This created the file config (12).exp.  (I have a number of other files saved, hence the (12).)  I used the Notepad++ program to edit this file.  I did a SAVE AS to file config12.exp.  I then did Restore Startup Configuration from PC using this new file as input (Choose File).  The edit was the addition of a 31'st binding and a change to NUMBER=.  I did not change SUM=.  It just worked.  I hope for the long term.  I did not get any error messages.

I am using Windows for this.  diff is a Unix utility.  You can get diff by installing cygwin under Windows.  diff can do more than the following, but in the way I used it, diff compares two text files, and on a line-by-line basis, tells you where the changes are.  There were thousands of lines in the before and after files, and the only significant change was the SUM= line.

Hi Norrie603

I have received that error only when i had made a typo in my config file which once corrected uploaded fine. I don't know that's your problem but its certainly a good place to start.

Perhaps try opening your config file in notepad, then saving it without changes and reupload just to confirm notepad isn't corrupting the file. If that is ok, try changing just one entry, again try to upload and see if that goes ok.

At that point it would probably be safe to assume there was some kind of typo error in your earlier troubles and you could go on with the rebuild from here.