cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Please be advised, the GuideMe Wizard is no longer available on the Small Business Support Community. For search capability please use the community search field to find content related to Cisco Small Business documents, videos, and discussions.
2726
Views
0
Helpful
7
Replies
Beginner

RV320 - SSL Certificate Issue / Admin lock-out

I have a RV320 that apparently has an invalid SSL certificate installed on it.  I have attempted to "factory reset" the device with pushing the reset button for 10+ seconds.  This has had no effect and the device admin page continues to be locked out.  Does anyone know another method that can be used to get this certificate cleared off so we can get a proper one installed.  Also does anyone know if there is any limits or requirements for the SSL certificates for this device.

Scott

7 REPLIES 7
dan Beginner
Beginner

Unfortunately, like for other

Unfortunately, like for other known problems, seems that passed years and they are still here.

Beginner

Re: RV320 - SSL Certificate Issue / Admin lock-out

I had this issue and solved it by doing the following:

1. Reset it to factory defaults by holding in Reset button for 10 seconds

2. Followed the instructions here to flash it with an older firmware. I used 1.3.2.02. But when I tried to flash it the TFTP command timed out so I did the following:

a. Turned off Windows Firewall

b. Renamed the firmware file to just "v13202.bin"

c. Turned off all protocols etc on the NIC except IPv4, Client for Microsoft Networks and File and Printer Sharing.

After this I could successfully TFTP the firmware and the unit rebooted several times.

3. Accessed the admin page of the RV325 and did a "factory default including certificates" reset. (Do it with Chrome, Edge just refused to connect for some reason)

4. Upgraded to the latest firmware.

Beginner

Re: RV320 - SSL Certificate Issue / Admin lock-out

Thank you very much for this solution !
After trying almost everything (and lost 10 hours) this solution worked. By the way, on the PC with IP 192.168.1.100 it worked with win7 (maybe this causes also some errors).
Bye ...
Beginner

Re: RV320 - SSL Certificate Issue / Admin lock-out

Hi there.
I have the same problem. But I can't connect with TFTP (10054). So I have scanned router with nmap and can't found open ports (ssh or ftp). 

Highlighted
Cisco Employee

Re: RV320 - SSL Certificate Issue / Admin lock-out

Hi lenar,

Please call our support line to open a support ticket, we may be able to arrange a hardware replacement for your unit if you are unable to recover it using the procedure described by wahlstam

Link for Small Business contacts: https://www.cisco.com/c/en/us/support/web/tsd-cisco-small-business-support-center-contacts.html

Re: RV320 - SSL Certificate Issue / Admin lock-out

I can connect using SSH but it is useless because it only shows access-rules and vlans.

This certificate issue is a trap.

I´m locked out too.

I´m figuring out a way to disable certificate check trough web.

 

Beginner

Re: RV320 - SSL Certificate Issue / Admin lock-out

Already a solution for the corrupt certificate?

Can you lockout de cert check in the browser?

 

In EDGE I am getting:

DLG_FLAGS_INVALID_CA
DLG_FLAGS_SEC_CERT_CN_INVALID
DLG_FLAGS_WEAK_SIGNATURE

 

In Opera: The pop-up box for going to secure page , but nothing happens.