cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1602
Views
0
Helpful
8
Replies
smartwombat
Beginner

RV320 - using one WAN port

What is the correct configuration for using one WAN port so that the router doesn't crash several times a day?

Should WAN2 be left as address from IP ?

Shoudl WAN2 be configured as static IP ?

Should WAN2 interface be disabled?

Should WAN2 be configured as DMZ and left as default 192.168.1.0?

Should WAN2 be configured as DMZ and then disabled?

 

It's definitely the router which is at fault, power cycling the fibre to copper converter dosen't fix the issue.
Nor does swapping the FTC for a brand new one.

Only a power cycle on the RV320, or a remote web interface reset if I'm unside the LAN, makes it work.

Temporarily, then it crashes next day.

8 REPLIES 8
Michiel Beenen
Participant

What firmware is your router running? The latest? 1.1.1.19 that is.

If you are running an older version, please upgrade that first.

Next to that with one WAN connection i have it set to: Smart Link Backup, Primary WAN (WAN1).
Under System Management > Dual WAN.

This has been stable and working fine for many months.

You do not have to do anything with WAN2 if you dont use it.

I have the same settings, and the same up-to-date firmware.

I see in the logs that the router incorrectly reports WAN2 as Up, then can't sync rate with it.

Most of the time that failure is around the same time as the users report failure.
But nothing is logged for WAN1 so it doesn't seem to be a physical failure in cabling, or the FTC converter feeding the router.

2015-04-27, 10:33:35Kernelkernel: WAN [2] UP
2015-04-27, 10:33:35Kernelkernel: [eth0] lanip=192.168.1.1, mask=255.255.255.0
2015-04-27, 10:33:35Kernelkernel: ip[xxx.xxx.xx.xxx] mask[0.0.0.0]
2015-04-27, 10:33:35Kernelkernel: ip[0.0.0.0] mask[0.0.0.0]
2015-04-27, 10:33:36Kernelkernel: WAN [2] DOWN
2015-04-27, 10:42:10Kernelkernel: WARNING: cant get external phy status
2015-04-27, 10:42:11Kernelkernel: WARNING: no highest common denominator or auto-negotiation not complete
2015-04-27, 10:42:11Kernelkernel: WARNING: no highest common denominator or auto-negotiation not complete
2015-04-27, 10:58:01Kernelkernel: WARNING: no highest common denominator or auto-negotiation not complete
2015-04-27, 10:58:02Kernellast message repeated 2 times
2015-04-27, 10:58:02Kernelkernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[0], duplex[0]
2015-04-27, 10:58:03Kernelkernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[2]

I'm having a similar problem with my RV320's. I did not know that there was a problem until I installed a new network monitor. All of a sudden, alarms started popping up. When I look at the logs, this is what I found:

  • 2015-08-24, 05:38:10 Kernel kernel: WARNING: cant get external phy status
  • 2015-08-24, 05:46:17 Kernel kernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[2]
  • 2015-08-24, 05:46:18 Kernel kernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[1]
  • 2015-08-24, 05:46:18 Kernel kernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[2]
  • 2015-08-24, 05:46:19 Kernel kernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[1]
  • 2015-08-24, 05:46:20 Kernel kernel: WAN [2] UP
  • 2015-08-24, 05:46:20 Kernel kernel: [eth0] lanip=192.168.118.1, mask=255.255.255.0
  • 2015-08-24, 05:46:20 Kernel kernel: ip[64.144.70.141] mask[0.0.0.0]
  • 2015-08-24, 05:46:20 Kernel kernel: ip[0.0.0.0] mask[0.0.0.0]
  • 2015-08-24, 05:46:22 Kernel kernel: WAN [2] DOWN
  • 2015-08-24, 05:54:51 Kernel kernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[2]
  • 2015-08-24, 05:54:51 Kernel kernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[1]
  • 2015-08-24, 05:54:52 Kernel kernel: WAN [2] UP
  • 2015-08-24, 05:54:52 Kernel kernel: [eth0] lanip=192.168.118.1, mask=255.255.255.0
  • 2015-08-24, 05:54:52 Kernel kernel: ip[64.144.70.141] mask[0.0.0.0]
  • 2015-08-24, 05:54:52 Kernel kernel: ip[0.0.0.0] mask[0.0.0.0]
  • 2015-08-24, 05:54:53 Kernel kernel: WAN [2] DOWN
  • 2015-08-24, 06:03:11 Kernel kernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[2]
  • 2015-08-24, 06:03:12 Kernel kernel: nk_bcm53115_sync_speeds_phy_to_mac(): sport[5], speed[1], duplex[1]
 
WAN 2 is disabled and Smart Link Backup is set to Primary WAN = WAN1. These sites are setup for failover only with the plan to add a secondary WAN connection in the future. Network Service Detection (NSD) is unchecked. 
 
Anyone have any ideas on what is causing this? Are the RV320's just junk? (see any post about the RV042 and you will know what I am referring to). I'm stuck with about 8 of these units that I need to make work. Any help would be appreciated.

I suggest you escalate a support case ...

I've been using a test release obtained through support, and on one router the problem has disappeared.

The other router, the users claim that the internet keeps failing and they switch it off/on and that fixes it.  But that always happens when I'm not in the office, so I can't troubleshoot the issue.
It may be nothing more than impatience.

However with an uptime of 47 days one one and 16 days on the other, this problem may be well on the way to being fixed.
The question is, how do you decide when an intermittent problem really has been solved?

@smartwombat

I agree. Intermittent problems drive me up a wall. Having said that, you mentioned uptime. Are you looking at uptime on the router or through some other method? My routers show their actual hardware uptime, but that does not reflect the WAN dropouts. My network monitor server shows the uptime as something completely different. I will escalate the case and call Cisco since I have more than a few that this is affecting.

Thanks for the advice!

We have an RV320 at one of our sites running firmware release 1.2.1.13.  The router runs good for about 24 hours after a reboot and then displays the same WAN 1 disconnection issues noted in the thread.  We are also seeing the same log messages.

 

In addition, we are seeing a Wan1 (Connected Inactive) notice on the status page.

So after talking with Cisco, they suggested that I disable SNMP. For whatever reason, they believed that having SNMP turned on causes this problem. I said "That makes as much sense as having a car with an engine problem and disabling the check engine light." I disabled SNMP out of protest and I will keep track of things with logs and a standard PING monitor. I will keep you posted.

Instead of reboot, I have been logging and navigating to "port management" then changing the wan port from auto negotiation to 100mbs.  Network traffic will now flow fine for awhile.  When it fails again I'll reset it to auto negotiation.