cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest Cisco news in this February issue of the Cisco Small Business Monthly Newsletter

3879
Views
5
Helpful
24
Replies
Highlighted
Beginner

Having the same issue

Having the same issue:

firmware:

v1.2.1.13 (2015-05-04, 18:40:51)


2016-02-02, 10:44:54    Kernel    kernel: [eth0] lanip=192.168.0.1, mask=255.255.255.0
2016-02-02, 10:44:54    Kernel    kernel: ip[0.0.0.0] mask[0.0.0.0]
2016-02-02, 10:44:54    Kernel    kernel: ip[x.x.x.218] mask[0.0.0.0]  **edited ip
2016-02-02, 10:44:54    Kernel    kernel: wrong ip[0],not_list[0]
2016-02-02, 10:44:56    Kernel    kernel: add new: cnt[13] learn mac[44-8a-5b-b7-bd-c8], ip[192.168.0.116], idx[c8]
2016-02-02, 10:44:57    Kernel    kernel: Start Check Reg ( 0, 16, 0 )
2016-02-02, 10:44:58    Kernel    kernel: add new: cnt[14] learn mac[c4-2f-90-7f-c9-42], ip[192.168.0.212], idx[42]
2016-02-02, 10:44:58    Kernel    kernel: add new: cnt[15] learn mac[c4-2f-90-bb-0-11], ip[192.168.0.210], idx[11]
2016-02-02, 10:44:58    Kernel    kernel: add new: cnt[16] learn mac[0-11-32-42-6b-8c], ip[192.168.0.140], idx[8c]


Router was stable until opting for a new ISP. During changeover I set to dual wan. One static one dhcp. Immediately or within three hours I had to take away load balance as it was constantly crashing with a "no highest common denominator" error. On the backup link setting I was still failing with the above verbosity in logs. Now I am on one wan port, WAN1, and toggling back and forth between auto ip and static. If I use static the logs wont show the network mask that I have set within the static ip connection parameters. Oddly the same thing occurs if I leave to auto.


Somehow trying out the load balance feature or trying dual wan took out the stability and now creates a situation where the wan ports go inactive. This happens in such a condition that the logs report that there is no netmask associated with the IP address.


2016-02-04, 07:32:15    Kernel    kernel: [eth0] lanip=192.168.0.1, mask=255.255.255.0
2016-02-04, 07:32:15    Kernel    kernel: ip[69.85.66.218] mask[0.0.0.0]
2016-02-04, 07:32:15    Kernel    

kernel: ip[0.0.0.0] mask[0.0.0.0]




Then again sometimes it gets it:


2016-02-04, 06:30:20    Kernel    kernel: [eth0] lanip=192.168.0.1, mask=255.255.255.0
2016-02-04, 06:30:20    Kernel    kernel: ip[69.85.66.218] mask[0.0.0.0]
2016-02-04, 06:30:20    Kernel    kernel: ip[0.0.0.0] mask[0.0.0.0]
2016-02-04, 06:30:21    Kernel    kernel: wrong ip[0],not_list[0]
2016-02-04, 06:30:30    Kernel    kernel: [eth0] lanip=192.168.0.1, mask=255.255.255.0
2016-02-04, 06:30:30    Kernel    kernel: ip[69.85.66.218] mask[0.0.0.0]
2016-02-04, 06:30:30    Kernel    kernel: ip[0.0.0.0] mask[0.0.0.0]
2016-02-04, 06:30:53    User Log    edit_network.htm is changed.
2016-02-04, 06:30:55    Kernel    kernel: [eth0] lanip=192.168.0.1, mask=255.255.255.0
2016-02-04, 06:30:55    Kernel    kernel: ip[0.0.0.0] mask[0.0.0.0]
2016-02-04, 06:30:56    Kernel    kernel: ip[0.0.0.0] mask[0.0.0.0]
2016-02-04, 06:30:56    Kernel    kernel: wrong ip[0],not_list[0]
2016-02-04, 06:30:57    Network Log    WAN connection is down
2016-02-04, 06:31:01    Kernel    kernel: [eth0] lanip=192.168.0.1, mask=255.255.255.0
2016-02-04, 06:31:01    Kernel    kernel: ip[x.x.x.198] mask[0.0.0.0]
2016-02-04, 06:31:01    Kernel    kernel: ip[0.0.0.0] mask[0.0.0.0]
2016-02-04, 06:31:01    Network Log    WAN connection is down
2016-02-04, 06:31:06    Network Log    WAN connection is up : x.x.x.198/255.255.255.224 gw 69.85.66.193 on eth1


While posting this I played with enabling upnp but:


2016-02-04, 11:12:08    Kernel    

upnpd[1362]: Failure obtaining ip address of interface eth1


caused me to revert to disabled.

After reading how long this has been going on (through several firmware releases) and across multiple posts this should have been a priority item and solved long ago.

Highlighted
Beginner

Problem solved with a 60

Problem solved with a 60 dollar milkrotik router. Enjoying a 3x speed increase as well. Thanks for the help cisco. 

Highlighted
Contributor

There may not be a solution

There may not be a solution to this other than regularly rebooting it.  I have several older rv016s that started exhibiting similar problems once my Internet provider changed their backbone carrier equipment.  I noticed 100 packets/sec of what someone on the Internet has deteremined is ipv6 packets sent by an Arris C4 carrier-end equipment.  Unfortunately, a reboot seems to be the only option as the sheer amount of packets makes the router think its under attack or eventually brings it to a hault.

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com
Highlighted
Beginner

Hello anthonya1,     Sorry

Hello

James

Highlighted
Beginner

I have a successful

I have a successful workaround.  There appear to be two interacting issues.  First, I only have a cable connected to WAN 1.  There is nothing connected to WAN 2.  Second, I have SNMP enabled.

There was a comment in this chain or another where Cisco informed a user to disable SNMP.  Based upon that comment, I made two changes:

A.  give WAN 2 a static IP address ... still no cable attached, but no longer DHCP default

B.  disable SNMP

Poof!  Problem went away.  Waited several days.  My guess is that SNMP is somehow forcing the second WAN port to attempt a DHCP request.  The second WAN port is disconnected and eventually this leads to total WAN side death.

I recently enabled SNMP again.  For last 24 hours I do get messages about failure to find proper port speed match, but WAN 2 does not go offline and WAN traffic across WAN 1 is solid.

Therefore I suspect workaround only requires WAN 2 having a static IP address, even though it is not connected to the network.

Highlighted
Contributor

Awesome that you found a

Awesome that you found a workaround!  These bugs really suck, but when a workaround comes around and works, you put it into place and then forget it and get back to work. :)

Huntsville's Premiere Car and Bike e-magazine: www.huntsvillecarscene.com
Highlighted
Beginner

Re: I have a successful

Hi. Can you recommend stable firmware version for RV320?

Highlighted

Re: I have a successful

I have the same exact issue and it doesn't look like anybody has found a proper solution?

I use the two WAN connections with two different ISP (both of them being gigabyte speed). Once in a while (usually by night, so when the system is pretty idle), the internet connection drops. We have to hard reboot the router every morning.

Sometimes it happens even as we're using it in the middle of the day.

 

Just to give you a bit of context, we're a small office of around 30 members, we have a NAS connected on this and as stated above two Gigabyte ISP running on this router. We're into image business so we download/upload pretty big amounts of data everyday.

I'm the director of this company and I handle all the IT part by myself even if I don't have much experience on this. So I didn't configure anything special on the router except the two ISP access. I was pretty excited by the load-balance feature of this router but I'm quite disappointed to see it can't handle the basics of a router... keeping up with being online!

Thanks for your help if any (as it looks like it's been a pretty old topic here). I also opened a TAC so I'll let you know if anything new/good comes out of it.

Highlighted

Re: I have a successful

Ok, so spending some time with the support from CISCO, we found a turnaround... which is not the best but it works. The problem for us seems to be coming from the fact that we use one WAN connected in PPPoE and the other one is in Static IP. Apparently, that could create a conflict when we use "load balance". If we use finally in "Smart Link Backup", so using only one WAN at a time, we don't have this drop of connection anymore. And we can change if necessary from one to the other manually. It means we lose the "load balance" feature which seemed interesting but at least we get something steady....

Re: RV320 WAN port drops connection

I had the same issues, plus issues with the certificates and VPN. I've returned it as 'not fit for purpose'.

 

Its an awful product and the support from Cisco is woeful.