cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

1443
Views
0
Helpful
6
Replies
Highlighted
Beginner

RV325 Upgraded to Firmware 1.4.2.17, Cannot Use GUI Now

I just upgraded the Cisco RV325WF to the latest firmware 1.4.2.17, but now I cannot use the GUI. I get to the login screen and login, but then I get an error that says:

 

Forbidden

You don't have permission to access /cgi-bin/ssi.cgi on this server.

 

It appears that I can get to the router via SSH, but I'm not sure what commands I can use as any of the traditional Cisco commands don't appear to do anything.

 

Any help is appreciated.

6 REPLIES 6
Highlighted
Beginner

Re: RV325 Upgraded to Firmware 1.4.2.17, Cannot Use GUI Now

I have experienced this issue as well.

 

After uploading Firmware 1.4.2.17, everything appeared normal until I entered the correct login details to access the admin interface. I receive the same forbidden error message as described by the OP. I tried reverting to factory settings which does technically resolve the issue. I am able to access the admin interface with the default credentials. However when I upload a backup of my configuration and try to login, I receive the forbidden error message.

 

I was able to rollback to Firmware 1.3.2.02 and restore my configuration to bring the router back online.

 

Grateful for any advice to address this bug.

Highlighted
Beginner

Re: RV325 Upgraded to Firmware 1.4.2.17, Cannot Use GUI Now

I eventually got back to dealing with this. In the meantime, everything worked just fine on the network, but I wanted GUI access back.

 

Yesterday reset the router, which defaulted the settings but kept the same firmware 1.4.2.17, and I could get into the GUI. I then tried to restore to my backup configuration and this recreated the same forbidden access to the GUI problem. This is odd, because I don't know how my configuration would interfere with this firmware to cause said issue...

 

Anyway, I reset the router again, got in long enough to roll back the firmware to the 1.3.2.02 version, and ran into a different error. It would let me login to the system, but then proper menus would display on the sidebar or main part of the screen. Reset the router again and the problem was resolved, firmware maintained at 1.3.2.02. Restored my config and all is well.

 

This has all been a bit odd... but everything is working fine currently... on the older 1.3.2.02 firmware.

Highlighted
Cisco Employee

Re: RV325 Upgraded to Firmware 1.4.2.17, Cannot Use GUI Now

Hi,

It is recommended to factory reset the device after upgrading the firmware. You can find this in the release notes for 1.4.2.17:

"NOTE The configuration will be lost if you downgrade the firmware from this version to an earlier version, and the configuration files of this version can not be imported to the previous release. We recommend that you reset your device to use default settings when you upgrade to version 1.4.2.17 and reconfigure your settings to include these new features."

 

Highlighted
Beginner

Re: RV325 Upgraded to Firmware 1.4.2.17, Cannot Use GUI Now

No, the factory reset doesn't work. I even tried to upload old firmware by TFTP as mentioned in release notes for 1.4.2.17:
STEP 1 Power off the router.
STEP 2 Press down the reset button, then power on the router. Holding the reset button for
10 seconds and release the button until the DIAG LED light turn red, and PWR LED
light keep flashing.
STEP 3 Connect the PC to the LAN1 port. Configure the PC static address as
192.168.1.100.
STEP 4 Upload the firmware to the router with TFTP tools. For example, you can enter the
command "tftp -i 192.168.1.1 put RV32X_v1.1.1.06_20131206-code.bin” in
Windows command line.
STEP 5 After finishing uploading, the device will reboot by itself.
STEP 6 After the router startup, the PWR LED light is on, and the DIAG LED light is off.

Step 4 failed. tftp client showed "Connect request failed". Ping 192.168.1.1 is ok.

Any advise? Thank you.
Beginner

Re: RV325 Upgraded to Firmware 1.4.2.17, Cannot Use GUI Now

Hi Marknhl, I got exact same problem. Can you please tell me how to roll back firmware when you were unable to login by GUI? I tried to reset to factory default but firmware didn't changed (keep 1.4.2.17). Any assistance are appreciated!
Highlighted

Re: RV325 Upgraded to Firmware 1.4.2.17, Cannot Use GUI Now

Even after upgrading to version 1.5.1.05, same error. I noticed the issue only occurred when I disabled the default VLAN 1, as a best practice. looks like it will only let me manage it from that LAN subnet, but yet to test it. All I know at this point is I was able to login and make all the previous config changes and access fine. That is until I rebooted and the router took on a different IP address.
 
Please see attached screenshot.
 
all vlans are enabled for management, at this point.