cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

439
Views
0
Helpful
6
Replies

RV340 NAT problem

I have a cisco RV340, I setup to work like a simple router, WAN port with a IP address external and LAN internal IP, but the computers from my LAN can ping on my external subnet IP, but I can't use internet.

 

RV340

FIREWALL -> Network Address Translation-> WAN (enable)

 

Computer (IP 172.16.1.2) -> MODEM (IP LAN 172.16.1.1) - ping to 8.8.8.8 ok

Computer (IP 192.168.50.2) -> CISCO RV340 (IP LAN 192.168.50.1, IP WAN 172.16.1.2) -> MODEM (IP LAN 172.16.1.1) - ping to 8.8.8.8 no reply

1 ACCEPTED SOLUTION

Accepted Solutions

I found the problem.

I am using just WAN1, no cable in WAN2.

Menu --> WAN--> Multi-WAN--> select WAN1 --> Edit --> Then I uncheck "Enable Network Service Detection"

 

I don't why, but when I enable this function, the NAT it wasn't working properly

View solution in original post

6 REPLIES 6
balaji.bandi
VIP Master

The rv340 equipment does not have the Policy NAT menu

About the ping, from RV to 8.8.8.8 does not reply

 

But if I setup the WAN IP of the RV in my notebook and connect the cable from the ISP to test the connection, it works fine, the ping to 8.8.8.8 reply correct

 

The rv340 equipment does not have the Policy NAT menu

what cable modem is this, you can enable simple NAT is that works ? ( Firewall--NAT)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

I found the problem.

I am using just WAN1, no cable in WAN2.

Menu --> WAN--> Multi-WAN--> select WAN1 --> Edit --> Then I uncheck "Enable Network Service Detection"

 

I don't why, but when I enable this function, the NAT it wasn't working properly

View solution in original post

nagrajk1969
Participant

Hi AndreSalomao,

 

Yes you have correctly solved the issue by disabling "Enable Network Service Detection" for WAN1 in the "Multi-WAN" page...

 

For completeness of the info:

1. Becos RV340 is a Dual-WAN router with support for Fail-Over of traffic from WAN1 to WAN2 (or Load-Balancing of traffic between WAN1 and WAN2), It uses the "Multi-WAN" service and related features for supporting this FailOver/LoadBalancing...

 

2. So in order to know when to switch over from WAN1 to WAN2...in case the internet is unreachable from wan1, the default Multi-WAN setting for each wan interfaces is enabled by default "Enable Network Service Detection"

 

- If you check, the default is always pointing to the Default-Gateway of WAN1....which is the ISP-Modem ipaddr 172.16.1.1

 

- And this is a kind of keepalive setting for checking whether the wan1 link is active and routing...and therefore the keepalive traffic that is used here is PINGs...3-4 pings sent to 172.16.1.1 every 5 seconds interval...or something like that...

 

- And in case there is NO ping-replies recieved from 172.16.1.1...the MULTI-WAN service will automatically bring-down the WAN1 interface and Failover to WAN2 internet link....which in this case there is NONE...so there is NO traffic that is getting forwarded via WAN1 interface...becos its down by the Multi-WAN service

 

3. So what was happening was that for some reason (it must be the default behavior/setting of the Modem), the Modem is NOT REPLYING TO PING-REQUESTS ON 172.16.1.1 at all......hence the WAN1 interface is being brought-down by the MultiWAN service that is running on the RV340

 

4 So there are 2 things you could do to solve this issue/behavior...its NOT a BUG....its a behavior in this scenario becos the Modem is NOT replying to the Ping Keepalives sent by RV340 on WAN1...

 

a) You have correctly applied the step of disabling/unchecking "Enable Network Service detection" (default setting to Default-Gateway)

 

b) Alternatively in case you want to use failover to WAN2 internet link...then you can still check/Enable the "Network Service Detection"...BUT instead of Default-Gw...point to say 8.8,8.8 the google-server......and i think it will work...without any issues

 

Thats the complete reason for the behavior you have observed...