cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

RV340 VPN Issues

dst_u
Beginner
Beginner

Hi,

 

I managed to define a SSL VPN connection from my android device to my RV340, but I can't access any of my servers in the LAN once the connection is established.

 

I watched the video that guides how to do that, which is exactly what I did, but it doesn't help:

https://www.youtube.com/watch?v=uYhnukvNghM

 

I'd appreciate your help.

 

Thanks

11 REPLIES 11

balaji.bandi
VIP Guru VIP Guru
VIP Guru

Do you have ACL to allow VPN pool to Access Internal LAN,. also check what Firmeware you have, there were some discussion they have old firmware, after upgrade all fixed by it self

 

best is test with ACL is ok before upgrade,

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

A D'Auria
Beginner
Beginner

Do you have for your server VLAN the option Inter-VLAN routing enabled?

I have the SSL VPN configured and no ACL was required.

 

I do have a device that is not accessible directly via the SSL-VPN - to reach it from remote, I have to do it via another device within the same VLAN - but that says more about the device itself and not the SSL-VPN as I have no trouble accessing anything else in my network. 

 

Just to make sure that all the simple things are correct, I am assuming that you can reach the internet from the servers in your network - that the default gateway on them is configured and no firewall rules are in the way. Also the SSL-VPN client address pool must not overlap another address pool in your network. I think the router will not let you even create an overlap.

 

HTH

 

 

Hi A D'Auria and balaji.bandi

 

I believe that your suggestions are exactly to the point.

 

I do not have such rules. I have the default VLAN1 where all my servers are and another one for guests that is irrelevant in that case, but I'm sure I'm missing some ACL or Inter-VLAN rules.

 

How do I set these up? I have this rule (10.0.10.0/24 is the range of the SSL VPN clients), but it doesn't seem to be helpful:

vpn-rule.PNG

 

 

 

BTW, I'm using the latest firmware

 

Thanks

Take a look in your VLAN set-up.

 

LAN->VLAN Settings:

Look at the 3rd/4th column "Inter-VLAN routing" - make sure that it is turned on/checked for your server VLAN.

image.png

 

Hi

 

My "Inter-VLAN routing" is indeed enabled on all my VLANs:

inter-vlan-routing.png

 

 

 

 

What I find strange on the android side is the routes that are declared in the AnyConnect screen. Why 0.0.0.0? My "Split Tunneling" checkbox in the Group policy isn't checked

Screenshot_20201106-103342_AnyConnect.jpg