Showing results for 
Search instead for 
Did you mean: 

RV340W - 5G wireless no connection.


My router is now about two weeks in operation. It's running with multiple vlans, one AnyConnect VPN tunnel and multiple SSIDs. From the beginning it seemed to work fine after i realised that all devices were connected over the 2.4 GHz band.

I created a new SSID with only 5 GHz and tried to connect some devices without success. None of my devices (Samrtphones, Windows Laptops) can connect to the 5G band even it is visible. Windows just tells me "Can't connect to this network." and the Android phones "Connecting...".

I tried different chanels, bandwidths, passwords and encryptions also without succsess.

Thank You





I have the same issue connecting to the 5G Wifi, both for the initial unit bought, and the replacement unit from Cisco. The 5G is active, LED indicator on the router shows it's working, the network can be detected by my Mac and all the iOS and Android devices, using NetSpot on my Mac shows very satisfactory signal strength of the 5G network, yet no matter from which device I try connecting to the 5G, it just prompts back the password is not correct and connection failed. 


Same issue here. 2.4Ghz works fine 5Ghz works for a few minutes and then none of the devices can transmit.  Devices show it is connected but no traffic comes in and out.


My name is Iliya Gatsev from Cisco Technical Support Team.

I think it would be best if you could call our support line and open a support case.


Iliya Gatsev
Cisco STAC Network Engineer
Together we are the human network .:|:.:|:. CISCO


Could you please let me know how can I get online assistance, without phoning UK from Serbia? Or just point me out where can I find online insutructions how to handle trouble with 5G WiFi of RV340w,m or a contact email.


Hi nenadv,
We have several options:
1. e-mail ( English):
2. chat support (English):
3. Toll free line for Russia ( Russian ):
8 1080 022 721 044
8 800 700 9981


(+7 495) 961 13 82 (Moscow), (+7 812) 363-3328 (St. Petersburg) or
(8 800) 700 05 22 (All-Russia)

Same issue here. Newest firmware installed. 

Every time device tries to connect to 5g then Log shows:

2019-03-16T22:47:35+00:00 <warning>kernel: [3026521.461566] wl1: wlc_dotxstatus: status indicates too many retries before failure
2019-03-16T22:47:35+00:00 <warning>kernel: [3026521.461582] tx_rts = 0 tx_rts_count = 0 tx_frame_count = 15 -> srl=7 lrl=6


System Information 
Host Name:router347Fxx
Serial Number:PSZ2252xxxx
System Up Time:35 Days 2 Hours 18 Minutes 32 Seconds
Current Time:2019-Mar-17, 00:23:48 UTC
Firmware Information 
Firmware Version:
Firmware MD5 Checksum:3b295aa8b7ca701303299ddb05bdc76f
WAN1 MAC Address:04:eb:40:34:xx:xx
WAN2 MAC Address:04:eb:40:34: xx:xx
LAN MAC Address:04:eb:40:34:Xx:xx

I have noticed this issue too; if I restart the router, it will work for a day or two then stop again. Did anyone ever figure this out? I would open a TAC case, but I do not think I have service on mine.
Justin Ferello

Hi JFerello,

All RV340W still have software warranty, so you should not have any issues opening a case.

This issue should be fixed in the recent releases, so please try to upgrade and test.
If you still face issues, please feel free to open a support case.



Sorry, I was not clear. I have a new RV160W and I believe it is on the latest version, I will look again.
Justin Ferello

Hello Again,

RV160W is a new model. Also under software support warranty.

For the RV340W the known wireless issue is fixed in the newer releases.
For the RV160W we don't have reports regarding such issues.
Therefor it would be best to open a case, so we can research further.


Hi, I am having the exact same problem with an RV340. Even bought a brand new one, same problem. Low 5ghz signal, and sudden disconnects until the radio is enabled and disabled. Its really disappointing for a small business router to have such low 5ghz signal and unreliable connection. Yes, using the latest firmware. Please help!


I had the ticket open with Cisco regarding the WiFi connectivity problems in the 5Ghz band. That was about 18 month ago or so. All the problems were with 5GHz band, and the biggest problem I had was that WiFi connection would be established on my devices (Windows laptops and Apple cell phones), but no data would go through. I can confirm that this problem has been fixed in the recent firmware releases. Another issue that I raised at the time was WiFi calling on older Apple iPhones (e.g., version 6), where no sound can be heard on the iPhone used for WiFi calling. I never finished the testing (my fault), but later I came across this article, which may explain my difficulties with WiFi calling on older Apple devices. So, one word of advice - set your DTIM period to 3 in advanced WiFi settings on 5GHz band. By default that setting is 1.

Low WiFi signal was not my experience. The signal was definitely strong. In fact I even lowered transmission power to 50%. If your signal is weak, you may be dealing with a hardware issue (i.e. a faulty device).


Thanks for this. I will give it a try with the DTIM and see what happens.


Regarding the signal strength, yeah it is really weak. Even with a brand new RV340, and even with my laptop right above the router, (with a signal/site survey), the signal is really weak. Maybe I was unlucky twice? I will open a ticket and report back, unless anyone has a suggestion (any suggestion is appreciated).




Hi All,

Since almost an year I own RV340, 5G wireless is not working at all whatever I do. Read whole thread above and tried everything explained but with no stable success. I'm waiting for openwrt or dd-wrt firmware to be released for this router as my last hope. This router is nothing more but a piece of crap! It is appropriate for very very small business with only 2.4G clients