Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RV345 Firmware update issue

Hi to all, 

I just update my RV345 router to the latest firmware. After that, the firmware update icon continue blinking with a warning message "Download firmware fail. Please try it again later."

I checked the firmware version and all is fine, but the signature file is wrong. I've tried to update, but an alert popup "


 it is right here on the same page ;-).

The misspelled link to Regional Support Options






Same issue as the others: the signature was apparently auto-updated to a bad/unreleased version. Since then:

  1. The update check fails
  2. I cannot manually rollback the signature
  3. The wifi fails frequently (must reboot router to have it working again).

Is Cisco aware of the problem?

Cisco RV340W.png

I had all of the above as well with my RV340W. Blinking warning, image version higher than what is on the website. Could not downgrade, wanted to have the bundle image and so on. Got tired of rebooting the unit once or twice every other days because the WiFi was very unstable as well even since the upgrade. I decided to download the same firmware from Cisco using my PC. No need to login. Upgraded the RV340W from my PC. After the unit rebooted on its own, the warning disappeared. I tried to check the MD5 checksum on the old file, but could not find it. All of my smart home devices using the 5GHz reconnected almost right away. It was taken them almost 30 minutes before this last trial. I'll know better over the weekend, I am sure. But just thought I share this with you guys as I have felt the pain.

Yes, it´s the same case for me, the blink does not desapear until I upgrade manually from my computer.


In addition, there no real problema with this isssue, but freak me out...

As an update to this post where the WiFi on my RV340W keeps having forwarding issues.

I have had to reset / power cycled the unit multiple times a week still.

I have 4 cameras (3 wiFi + 1 wired), 9 WiFi smart devices (light switches, power outlets, Google Mini, Tvs), 4 wired devices, 4 Vlans extending wired and wireless and 3 SSIDs to those Vlans.

The wired devices seems to be staying connected. The WiFi devices seems to loose their IP Address for some time and others not forwarding at all. Signal strength has been checked and is better than -65dB all around, using 2.4GHZ and 5GHz band as some device only support the 2.4GHz. While some device cannot communicate, other wired devices has good speed doing a speedtest using Ookla app/website. 

I have changed the DHCP lease time with no difference. I have change DNS server with no difference. Again, the wireless devices seems to be affected more than the wired ones on the same Vlans.

There is not enough details in the statistic to find out if the IP NAT Translations have issues or TCP number of connections or what. 

I am starting to think some Multicast stream or hello/controls are not being forwarded properly on the WiFi of the router from of for the smart device discovery. (doing research on that but not alot of info that way so far).

I have tried to power cycled the devices intead of the router and have no real success, until I power cycle the router.

The design calls for the Vlan separation.

I am thinking at this point to use an AP wired to a switch, than to the router.

Using different SSIDs to bypass the WiFi on the router or simply disable the WiFi on the router.

And move the Wireless devices to the new AP to see if the issue persist.

Will let you know!



As an update to my post with the idea of using a separate WiFi and disable the RV340W wifi, here some findings.

Before going to the extreme of using another WiFi incurring more cost. I decided to play with the router settings.


With the suspicion that my "Smart" devices were using some sort of multicast to be discovered and Keep alive when launching the App on my iPhone. I verified the setting on the router for the IGMP.

Found under "Routing"- "IGMP Proxy", I found that there is an upstream and Dowstream setting for the interfaces and Vlans.

IGMP Proxy was enabled.

For the Upstream, "WAN-Auto" with only WAN1 was enabled. I did not change that.

The Downstream only had Vlan 1 enabled. I enabled it on Vlan 3,4 and 5 as I do have smart devices on those Vlans.

I left the WAN interface disabled for the dowstream for now.


I also found where to see how many TCP connections were currently active.

Under "Firewall-Session timeout" at the bottom of the page "Current Connections:"

It was well within the default of 40000.


So I looked at the wireless settings since this is where I have most of the issues from.

Under "Wireless-Basic Settings" for the 2.4GHz, I selected "G/N-Mixed" , changed from "B/G/N-Mixed".

I was amazed and disappointed to find out my Sono Player1 is using 2.4GHz G only technology.

I could not used "N-Only".

For the 5GHZ band, I selected "N/AC-Mixed" with a channel width of 40Mhz, from a "A/N/AC-Mixed" setting.

I had no devices working with 802.11A technology.


Under the "Advanced Settings" of the wireless, for both 2.4GHZ and 5GHZ, I disabled all of the "Basic Rate" except for the 12 and 24.

Under the "Transmission Rate" for the 2.4GHz, I disabled the 1,2,5.5 and 11 and kept all of the other ones.

Under the 5GHZ band, I kept all of the transmission rate from 6 and above. 

Did not have to change any of the HT or VHT settings.

I also verified I had no priority, policing or bandwidth limitation on the WAN under "QoS" settings.

I actually made sure the Downstream and Upstream settings of the WAN under, "WAN Bandwidth Management" were set to their maximum of 1Gbps (1000000kb/s). (Does not matter, as long as it does not limit below what you are supposed to be getting from your ISP).


This, so far, as reduce considerably the number of "Warning" Kernel about "AMPDU" and other of these nature, in the LOGs.

The devices have been lot more responsive, and so far after 3 days, I have not had to reboot my RV340W.

Weekends are the worse for my network.

I'll give it few more days to see how it is behaving.

Next step, if it is still giving me issues, is the replace the wireless with a separate unit.

The wired devices were always very responsive.




Update on the wifi changes 4-5 days ago. 

The wifi has remained very responsive and none of my wireless devices had to be rebooted including the router. 

Will give it another weekend of stress to see. 



I am having this issue also - and it's frustrating.

Otherwise the product is working flawlessly - just that after the last software update (to this flashing warning it quite annoying, considering it stops one noticing any OTHER warnings.

*** RESOLVED ***

This resolved itself after downloading the firmware from Cisco manually, and then doing a file-update of the firmware, and once complete/rebooted the warning has disappeared. finally.

This is the way I did the update, yet I have this problem

See three problems:



Yes, you will see those mismatches after the first upgrade.
Doing the first upgrade using the automatic or manual upgrade will result the same.
Doing the upgrade again for the second time BEST TO USE THE MANUAL option. This will take care of the warning alert, and the version differentials.


I have the same issues and have upgraded manually 3 times and each time no difference.  It seems like the signature and dongle driver just wont update, staying at and respectively. Tried to apply the signature file manually on its own however the router reports compatibility issues. 

Anyone got any other suggestions to get these two versions corrected?

There is a SW bug where after upgrading the firmware system file, the running version is compared and is locked in the router so the new SW version cannot be written to this file.

As per Jo Kern (Cisco Employee);

The new software is runnning but the version checking tool believes it is still running the old one. This has been recognized by Cisco as a Software bug and will be fixed. Just don't know when yet.

The upgrade of the software on the second time was to address the warning triangle flashing at the top of the screen hiding other possible alerts.