Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RV345 Port Forwarding not working when Inter-VLAN Routing Disabled

I feel like I must be missing something, maybe you can show me the light.

I have two VLANs. I have  port forwarding rule setup to forward to an IP on VLAN2. If I disable Inter-VLAN Routing on VLAN2 the port forwarding does not work. If I enable Inter-VLAN Routing on VLAN2 then it does work.

I am attempting to segregate my two VLANs so they cannot talk to each other, but configure port forwarding to various IPs inside both VLANs. When I disable the Inter-VLAN Routing is where I run into problems with port forwarding no longer working (connections just timeout - it's not being forwarded).

No firewall access rules beyond the defaults are configured.

Can anyone shed some light on this? Is this expected behavior? If so, how can I achieve what I'm after?

Thanks for your time.


are you disabling inter-VLAN routing on both VLANs?   Most of my configurations have guest VLAN as the secondary, so I'm not forwarding any ports there.   The one office that does have a secondary internal VLAN with ports forwarded to both VLANs has the inter-VLAN routing enabled.   I will see if I can test that one and get back, although that is an RV32x not RV34x, so it may not be any help unless it suffers the same issue.


I have one RV345 in service, and it was not forwarding ports, which is how I came upon your thread.  My issue turned out to be the cable modem wasn't fully in bridge mode, so I finally figured that out after beating my head against a wall for an hour.  Put it in bridged mode and disabled the firewall completely, now my incoming ports forward correctly.  Again - I don't think this is your issue, but thought I'd mention it.   I'll also see if I can hook something up to the guest VLAN on this guy and forward a port to test your scenario.

Thank you!!! had the same problem on my rv325 even had a cisco engineer screen share with me and confirm my configuration was correct; RMA'd the 325, upgraded to a rv345 - still the same problem - read this checked my fibre modem settings, and it turned out that the fibre modem assigned the router a new ip & thus new settings..  2 weeks of head banging (not in a death metal way either).


I am using RV340 and i have similar issue. I setup VLAN1 & VLAN2 with inter-VLAN routing disabled. i also setup port forwarding - HTTP to VLAN1 IPs & FTP to VLAN2 IPs. It works fine if i access the services from external. However, i cannot access the HTTP servers from VLAN1 if i access using my FQDN. The problem only can be fixed if i re-enabled the inter-VLAN routing on the 2 VLANs.  Any idea what is missing?