Showing results for 
Search instead for 
Did you mean: 

RV345P issues after upgrade to

A D'Auria

Router upgraded from to 

Under 3.22 everything was working fine and stable.

What is 'everything', you may ask?

- IPSec site-2-site VPN, GRE and RIP
- Anyconnect - auth against local DB
- Traffic direct to internet or, if in the VPN network, over the VPN


Since the upgrade, the VPN, GRE and RIP routing work fine.

Anyconnect cannot authenticate a user against the local DB. (radius and AD not tried)

No traffic can pass to the regular internet from a client - only through the VPN.


I've tried adding/removing firewall rules. I see nothing being blocked in the logs.

The router diags can ping to the outside just fine (www google com) for example.

The client can ping the router gateway address but not further. Yes, the gateway address is set on the client by DHCP properly.

I have the idea that NAT is not working. I've tried turning NAT off on the WAN interface, testing, and back on. No change.

I've even disabled the site-2-site VPN and rebooted the router. No traffic could pass from the client to the internet.

I have reset the router to factory defaults. Rebooted and reloaded the config and rebooted again, Still no traffic to the internet.


I downgraded back to and everything works properly again.


I have 8 routers that I need to upgrade immediately due to the security alerts yet dare not until these issues are resolved.


Are others also having these issues with either or 


Does anyone have a solution or suggestions?


Thanks in advance.








What is Cisco doing? OMG. two firmware released that are unusable.


I upgraded from to, reset all settings to factory default and after a reboot I could still access the internet. Once I start to configure my settings manually and add firewall Access Rules then the problems start. Whenever I add a rule then internet access is blocked and my router becomes useless. The only way to solve this is to remove the access rule (or make it inactive). So, was a useless firmware version and now as well. Releasing an firmware update for a router which makes the firewall useless is quiet amateurish!


Please Cisco SOLVE this issue a.s.a.p. as this is a core functionality of the router with firewall!!!



A D'Auria

Update: I had opened up a TAC case with Cisco about this. After trying a bunch of things, collecting logs, different upgrade procedures, etc. etc. My case was passed up the line to a 2nd line engineer. After confirming a few things, I was informed that a new firmware will be coming out soon - perhaps by the end of May 2022. The new firmware should provide the stability of, I was told.  


Waiting is.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: