Showing results for 
Search instead for 
Did you mean: 

RV34x, RV340 FATAL Static IP WAN setting !!

     RV34x FW: v1.0.01.18  2018-01-11

WAN static IP:
   gateway IP:


I couldn't believe my eyes!


When I attempted to connect a customer's RV340 to a new fiber ISP using a Static IP assignment (above), the router blocked all Internet traffic in a matter of a few minutes.  All Internet connectivity shutdown completely; nothing got through anymore, not IPsec, DNS, HTTP, ICMP - nothing!  Rebooting the router reproduced the exact same symptom, initially Internet starts working and then dies.  When I restore the old DSL PPPoE connection on either WAN port, Internet traffic resumes but only on that port.


I tried everything I could think of, cloning the old router's MAC, disabling all IPsec and other traffic, etc.  All other configuration settings is at default, which ordinarily allows basic router functions out of the box.  But no matter what, pings to external sites, whether by IP or resolved DNS, go dead after a few minutes with this particular static WAN setting, during which browser pages freeze up and "no Internet" pops up on every LAN PC.  All the while, the RV340 US summary says the WAN is "up".


I could not reproduce this symptom on any other WAN connection I had available, not on PPPoE or DHCP.  The router works fine bench-testing with either or both WAN's plugged into another router's LAN, even when making WAN DHCP assignment static.  It's only with this particular ISP and static assignment does the RV340 react this way.  I don't know if it has something to do with the larger '' mask, as I am more used to seeing '' masks from other providers.  In either case, there is no way to deploy the RV340 with this new provider.  Needless to say, my customer is pissed.


After wasting hours on end, I had no choice but to stick back in the old RV042.  All of the RV0xx routers run flawlessly and never once let me down.  I already regret upgrading to the RV34x.  I never expected this of Cisco SMB.  Who does?  Guess I'm a sucker.


There is next to no diagnostic clues to go on.  After all Internet traffic died off, the only indication the RV340 logs is "<error>Webfilter: Error reading from socket: Resource temporarily unavailable".  (see sample log attached).  Once this entry appears, it logs the typical time-out errors from IPsec and other traffic unable to reach their destination.  As you would expect of any dead ISP connection.


Is there some new setting in the RV34x for this type of connection??  I somehow doubt it.  Please fix this issue Cisco.  I'd like to someday take this router out of mothballs to get my money's worth.

Cisco Employee


My name is Iliya Gatsev from Cisco Technical Support Team.

I was not able to reproduce this issue. It will be good to call our support line and open a support case so you can provide us with the specific network settings.


Iliya Gatsev
Cisco STAC Network Engineer
Together we are the human network .:|:.:|:. CISCO


I have the same problem. Mask The operator gives the Huawei USG6330AC, I connect to WAN1 or WAN2 in RV340. After about 15 seconds, the Internet is disappearing. Port still visible as UP.


Having the same problem.

Firmware version

Reboot the  RV340 to faculty default, 

WAN connection OK at the beginning.

After assigning the static IP for WAN 

IP: ***.***.***.212


Gateway: ***.***.***.209


The WAN connection is gone.  Can't ping any external host

and the clients will lose internet connection.


WAN Port still visible as UP.









Cisco Employee

Hi, sorry to hear. As @Iliya Gatsev is saying. If you want you can share the XML config file with him.

Our engineering will test this setup in particular.

We do have setups working just like the one you are describing, we cannot reproduce your issue at the moment.

I also would be interested to understand which ISP you are using.

Thx a lot



This issue has nothing to do with the ISP.  In my case, it was traced to an incompatibility between the RV340 and a Cisco ME-3400.  I opened a case with Cisco Support, but the ordeal of capturing packets on a customer's site in an attempt to diagnose it, proved unfeasible.  So the case lapsed without finding a solution.  As a workaround, I swapped out the RV340 with a RV042G which worked fine.

Judging from recent posts, apparently this issue is also evident with other ISP modem devices and remains persistent in the latest RV340 firmware.  The Cisco tech who worked on my case admitted they have seen similar incompatibilities between other Cisco devices and in my case, which he witnessed for himself the loss of WAN traffic when connecting remotely, seemed to resurface in the RV340's newly designed firmware.  The ability to reproduce it by bench-testing the right combination of boxes seems to be where things stand right now (in my opinion).  


Can confirm we’ve just run into this exact issue on an RV345p that was to replace an existing router on a fibre connection with a static IP.


Using a number of different routers we’ve always got a connection but the RV 345p will work for about 10sec after each restarts and then all WAN traffic ceases.


Frustrating as I wouldn’t expect this type of issue from Cisco considering they consistently use the phrase “best in breed” to describe themselves in their promotional seminars with resellers.


I've just spent the last four hours troubleshooting what I believe is this exact same issue. I was replacing an RV320 with an RV340 because of issues we were having with the VPN. It's also connecting via static IP address with a subnet mask. I'm using the latest release of the firmware,

Upon replacement, my pings to the public IP address began to respond for maybe 15 seconds and then ceased to respond altogether. Also, pings from the router's GUI (Administration > Diagnostic) were unsuccessful. What's crazy to me is that the VPN tunnel was up and running the whole time, I was able to ping across the tunnel to the router and even to devices on their LAN, despite the router's own inability to ping,, or even the WAN interface's default gateway IP address. Again, I emphasize, that's crazy.

I reverted the router to defaults and then the only configuration I made was of the WAN interface with the subnet mask, and I configured the firewall to allow WAN requests. And the same thing occurred again, it responded to pings for maybe 15 seconds and then stopped, and yet again neither the LAN or the router itself is able to ping out.

I reinstalled the old RV320, with the exact same static IP WAN configuration, and it's connecting just fine, the only problem with it is its VPN function. Going to be sending them another replacement router, this time an RV320.

See my attached configuration (saved as .txt file for upload here) from before I reverted it to factory defaults.


Yes, there is an incompatibility issue between the RV34x and certain modem devices on the WAN side, which Cisco has encountered in other products as well.  In my case, it was between and RV340 another Cisco box (ME-3400 media converter/switch) supplied by the ISP.  Cisco support witnessed the symptom but was unable to reproduce it on the bench; so like you, it simply became unfeasible to troubleshoot any further.  I am an end user, not a beta tester.  Slap in whatever box that works and move on.

I really don't know why Cisco felt they had to supersede the RV32x with the RV34x series, but it seems they're unable to iron out firmware bugs from either, at least not in a timely manner.  Many of the same "instabilities" persist longer than what's reasonable, never allowing these later SMB products to attain a level of "maturity" before being "discontinued". 


Please help as we are also having this issue on RV345 with version Firmware Version:
Using a static IP address provided by ISP. We have tested the line and is working properly but connecting this RV345, can't seem to connect to the internet.

IP: ***.***.***.123
Gateway: ***.***.***.121

Internet WAN1 port shows 1000Mbps and visible as UP.

When we try to ping the gateway, ping failed.

Thank you in advance.

That sounds a bit like an issue that I've had in the past with Network Service Detection on an RV320, but I'm not sure. 

You could try this suggestion that I stole from another post:


You are correct, the RV will be unable to detect that a WAN link is down by default as it is monitoring the link state which will continue to stay up. You can modify this option if you go to WAN -> Multi-WAN -> Select WAN1 -> Adv. Config -> Enable Network Service Detection -> Remote Host and enter something like (Google DNS). 

The default option there is "Default Gateway" so essentially the RV will be pinging the LAN interface on the modem which will almost always be up unless you physically damage the link or turn off the modem.