Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RVL200: Firmware Upgrade Interrupted (And Failed) [SOLVED!]

Hello everyone.

I was updating my RVL200 with the TFTP utility. At about 10% of the process, my PC rebooted itself. So also firmware updating has failed.

RVL200 now seems to work properly. However, some pages of the web interface will not open anymore. The same also help pages.

I tried to repeat the firmware upgrade again but the TFTP utility no longer works.

Does anyone know how I can fix this? With a hard reset is also restored the original firmware?

Thanks in advance who will give me a hand.

Te-Kai Liu
Rising star

I am not sure if this will work, but you might want to give it a try. Unplug the power cable first. Then hold the hardware reset button while plug the power cable back. If the Diag LED is blinking slowly, the device should be in a mode in which the TFTP Utility can work again. Be sure to set your PC with Static IP in the subnet, e.g.

Excellent! :)

Works great! I thank you very much for your explanation.

Now the router is fully functional and menus are back as before.

Thanks again!

I was using the built-in tftp client of Mac OS X, but failed to complete the procedure. But this Firmware Upgrade Utility did it!

This link will redirect to login and then to download-cart. You will be asked to confirm some legal stuff before you can download.

If you see this screen, your on the right track!

This is the utility in action!

Message was edited by: Jonas Oestman, added link and screenshot

Here is the RVL200 firmware URL:

md5:last chars->8d49

And if somehow you would need the 1.1.7 firmware:

(no need for md5, zip will check integrity)

I paste these here, because the Cisco website is making me jump through hoops before I can download. This is faster.

Message was edited by: Jonas Oestman, remove dupe link