cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

4902
Views
0
Helpful
12
Replies
Kalisto99
Beginner

RVL200 - Problem with SSL VPN after Java update

Hi,
I got problem with RVL200, he works good on my botch mac's witch  OSX 10.5,10.6 and Firefox 3.6 but stop working after last java update.  The machine witch 10.5 is working because I don't update Java but the  other computer is up-to-date.

Problem is with lunching the Java applet ,all the rest is working.
- I'm login to SSL VPN Tunnel
- The new window is opening I accept applet to run ...
- He try but nothing happends the window is bank with no connect / disconnect buttons.

All I have is Java error:

Plug-In Java 1.6.0_24
JRE version 1.6.0_24-b07-334-10M3326 Java HotSpot(TM) 64-Bit Server VM

java.lang.SecurityException: Permission denied: file:/vpclient/SignedMacVPClient.jar
at sun.plugin.util.GrayBoxPainter.setProgressFilter(G rayBoxPainter.java:220)
at sun.plugin2.applet.Plugin2Manager.setupGrayBoxPain ter(Plugin2Manager.java:2291)
at sun.plugin2.applet.Plugin2Manager.access$700(Plugi n2Manager.java:104)
at sun.plugin2.applet.Plugin2Manager$AppletExecutionR unnable.run(Plugin2Manager.java:1494)
at java.lang.Thread.run(Thread.java:680)
Exception: java.lang.SecurityException: Permission denied: file:/vpclient/SignedMacVPClient.jar

What can I do to run this ?

PS.
I have all the rights / permission to vpclient catalogue and files in there.
I try this on root to .... the same error

12 REPLIES 12
rmanthey
Enthusiast

This is a known issue with all Cisco Small Business SSL based VPN products. This affects Mac OSX and Linux base OS systems. This is only from Java 6 update 24. Development is working on resolving this problem in the next maintinace release for the devices. There is no ETA yet, this issue was only found about two weeks ago, and development is working hard to get a beta firmware. Once I hear back from development they have a fix, I will let you know. This issue again is for several devices, it was discovered on an SA500 series router, I will let them know about the RVL200 so a firmware can be designed for this device as well. The only sollution we have found is if you have a time machine backup to restore to a pre-update image.

Cisco Small Business Support Center

Randy Manthey

CCNA, CCNA - Security

Thanks for answer so quicly.

I dont have any chose ... must wait for new firmware.

Any informarion about NEW firmware ??

Hello!

Could you please tell my what is the STATUS of this issue! I'm having the same trouble and this sucks because I need to be at the office everytime I want to do a release of our application. We bought this router for it's vpn functionality!!!

// Jakob

Hey Randy.

What about a new status for the update?!?!?

WE desperately need a new firmware where this bug is fixed. We are switched off from several RVL200 and my customers are quite angry. Why should I sell Cisco any further when support is this slow!

WE need HELP!

Best regards

Patrick

Hi Randy,

It's been more than 8 months you were talking about a new firmware.

Is there a solution which works now between RVL 200 - latest Java, and Apple Lion?

That is incredible that Cisco support can't bring a solution, nor AnyConnect can work either for SSL VPN with RVL200.

Do you have feedback of software/ingeneering/development team?

Is there any beta version of firmware to get out of that problem, or can Cisco make "Virtual Passage" sources public if you don't support anymore that Linksys router (but you bought Linksys, you should support that solution)

Thanks for real information and solution !!!

Best regards - Pascal

colindearing
Beginner

Same issue on a RV220W,

Only bought router due to clearly stating SSL VPN functionality on Mac OSX, very dissapointing. Any update / ETA

Thanks

Kalisto99
Beginner

It past 3 month after i post on this forum..., not only I have this  problem its Global ....  and Cisco do nothing in this issue. HOW WE CAN  WORK !!!

I WILL NEVER EVER BUY CISCO TO MY COMPANY AGAIN !!!

What for you even release product for small businesses if you don't care abut us ?

Kalisto99
Beginner

I got the solution tor this problem .... Any one still interested ?

colindearing
Beginner

I think it would be beneficial to share this information for the use of others. I am beta testing firmware on my RV220 but SSL VPN is still not working. Despite Root user workarounds etc ...

It started with a Java Update that is now quite old, I do not know the finer details to know whether a work around should of been made rather than wait for Java to change with a future update.

Just for reference, I can confirm it is not working with OSX 10.6 or 10.7

To think this is affecting Linux users / Mac OSX users is surely of concern to Cisco and the Community as a whole?

Thanks Colin

The main problem is in Java the other issue is that VPN Client works ONLY in FireFox 3.6.

My Solution:

Install the old Java, hire is the old java installer:

http://www.uploadstation.com/file/a44a57U/JavaforMacOSX10.6Update1Downgrade.zip

This installer adds old java to system and you can select in System Preference panel with java will be running.

After that (installing and selecting old java) just run VPN tunnel on old Firefox 3.6 and all will be working !

I test it on my Mac i have right now 10.6.8 with old java .. all working (on old firefox on ff 4 or 5 is nor working)

patrick.koehne
Beginner

Hi All

Is there any new status about a new firmware ahead?

Best regards

Patrick