Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RVS4000 firmware updates don't work with Internet Explorer 8.0

I have 2 RVS4000 VPN routers.  Neither would accept firmware updates via the admin browser interface using Internet Explorer 8.0.  After lots of troubleshooting, I tried Chrome (Google) on 1 router and Mozilla Firefox on the other.  Both updates were successful.  The firmware rescue utility that you can download from the Cisco web site also works.  It does the update without the browser interface, but installs a slightly older version of firmware than is availble for browser-based firmware updates.  I hope this saves you time and frustration when you need to update your routers.

Rene Feitelson



A thousand thanks for taking the time to post your result. You've made my day!

I have spent over 8 hours today trying to implement a firmware upgrade on my RVS4000, with zero success. I initially used Safari 5 (on a Win XP SP3 machine) in order to update IPS to v1.42, with no success. Switching to MS IE8 and the update worked fine - hence I stuck with IE8 for the firmware update. I can confirm your result - IE8 does not initiate a firmware update, nor does it provide any feedback whatsoever on its failure.

Using the Firefox v3.5.9 browser the RVS4000 v1.3.2.0 firmware update worked straight away without a glitch.

So, perhaps a general "Heads Up" to everyone - if you have any issues when trying to configure your Router, then try using another browser as the first step.

Many thanks again, Rene.

Message was edited by: Robert Gough Oh, another issue that might help folks: When the firmware update file "filename.img" is downloaded from the Cisco site Windows interprets it as a .zip file and associates the usual ZIP file icon to it. Cisco's documentation states "unpack the file and ......". This immediately leads one to believe that the firmware update file is contained in the ZIP file. This is not the case! It is NOT a ZIP file at all, but is the binary that the router requires. If one tries to unzip the file WinZip throws up an error "ISO file incomplete" and doesn't unzip it. So, ignore the ZIP file icon and just point the router firmware updater at the .img file, despite its ZIP icon.