Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter


RVS4000 Issues and Questions

Hi all, I manage the internet in a 4-story building, housing about 25 people.

We have a 25Mbit connection comming in through a cable in the basement, going through a modem that is connected to a RVS4000 small buisness router on the first floor, that acts as the single NAT. Connected to that in parallel we have 4 wireless b/g or b/g/n routers of various cisco/linksys models, one for each floor, each with DHCP disabled.

Over the last few months there have been some issues with the router and I'm curious if there is anything that can be done to solve them.

The firmware of the router is the latest at the time of this writing, V2.0.2.7

1. The router will occasionally lock up and completely stop responding to DNS requests.

  • Attempting to open a website will result in browsers giving their standard 'DNS Lookup Failure' messages.
  • The router will also become completely non-responsive when trying to access it via its IP address (standard No username/password dialog appears.
  • However oddly enough IRC and other chats like skype will still work fine.
  • Restoring Factory settings has not helped.

This issue has gotten to the point where this happens about once a day. Restarting the router will fix the issue. While I think the issue may sometimes resolve itself, it could also just be one of the other people in the house restarting it manually.

I'm assuming that the router is to blame here and not the cable modem in the basement or the DNS server of our ISP, mostly due to the fact that the router becomes unresponsive and won't let me log in as admin when this happens. also restarting the router, not the modem, seems to fix the issue.

2. The router's log is always empty

Specifically I have enabled 'Output' and 'Local Log' as you can see here:

(Click for larger)

Then when I click 'View Log' the log is empty:

(Click for larger)

Am I assuming incorrectly that there should be at least something there? Did I miss something in the settings?

3. Issues with some people hogging bandwidth

With 25 people and a 25Mbit connection each person in the house should effectively get about 125KB/s of download speed, especially since not everyone is always using bandwidth. However it can happen where one person is, often without knowing it, hogging a large chunk of bandwidth and slowing the network down for everyone, such as downloading multiple large files from different sites, streaming high-quality video, etc.

I would like to know if any of the following might be possible to do with this router:

  • See the bandwidth usage per individual MAC or IP address on the network over time
  • Limit the amount of bandwidth a specific MAC or IP address can use.
  • Make the distribution of bandwidth more fair when a few people are using far more of it than other people.

Note: I have at times resorted to limiting P2P via IPS in the past, and of-course that does help somewhat, but that's not ideal. I'd much rather just know who is doing it, and specifically by how much they are slowing other people down. While the IPS page will list the IP addresses of those trying to use P2P when it's disabled, there is no way for me to really quantify how much bandwidth they'd be using otherwise, and this doesn't at all include things straight-up HTTP downloads.

In any case, this router should easily be able to handle ~25 simultaneous connections, right? Are there any settings that I should make sure to enable or set to help distribute bandwidth more fairly, given the setup we have?

4. The IPS report chart is not readable.

This is a bit of a nit-pick, but the IPS report chart is basically not readable because the colors used in the key are identical in color. Can you tell the difference between the colors of 'Network Traffic' and 'Attack Counts' in the key at the top? I sure cannot!

They could have used any two colors that are at least somewhat distinguishable, even light grey and dark grey would have been better, not magenta and another magenta.

Any input or feedback would be much appreciated.


~Johannes P.


Over a week later and still no replies. I am somewhat disappointed.


I am having the same issues with my RVS4000 router. It looses connection with the modem and can be accessed using the Admin, Admin login. When I reboot the router without changing the login password I restore the proper password back to use. Very strange. My users can still access the local network resources but can no longer access the internet. The router is using firmware version

Peter, have you received any replies to this problem?


Rising star

Hi Johannes,

Just read through quickly and have some questions and thoughts.

1. (a)Have you ensured there are no ip conflicts? (one of the APs isn't set to or has dhcp/routing enabled?) Do you have IPS enabled? IPS can be a resource hog, perhaps try turning off IPS and see if the router locks up.  How frequently does it lock up?

(b)I've read that these rvs4000s can get really hot and sieze up. In fact, I've heard of people putting these on laptop cooling things with fans or propping them up for increased airflow under the unit and have actually seen improved performance.

(c)Have you always run on it or was it functioning properly on an older firmware?

2. Try setting up a syslog server and see if that catches anything. My initial guess is that the router doesn't have available memory to store any logs based upon the fact that its locking up on you.

3. You can use QoS to set bandwidth maximums by ip address, but you are going to put more strain on the router, and your performance overall may decrease. If there is one culprit, you may want to assign that machine a static dhcp address before configuring qos.

4. While I agree with you based upon the screenshot, seeing as the RVS4000 is end of life (looks like they stopped selling them in 2010), I doubt that its something cisco is going to address.




I upgraded the router to version Did a factory default reset, setup the router with ISP login info and power cycled the router. That was last friday. Today the router lost connectivity with the modem and the factory default login: Admin, Admin was active. When I rebooted the router, the secret login password was restored on reboot. This is very weird. Prviously I could not login with the secret password. But the original defaul password worked.Was this router hacked? I don't know at this point.

The end of life issue I find irksome. I have another Cisco product, NAS3000 which is also in this state. problem is the story is the same. No support and now the product is obsolete. Never worked right out of the box.Never got competent tech support and in the end was abandoned because the product was at end of life. If this router was at end of life in 2010, why was I able to purchase it two months ago from a large retailer.

I a not using the QoS feature.I was considering on using the static IP table for connected PCs.

Are you a Cisco Employee David?





Sorry, I got you and the OP mixed up for a second, but I've edited my post. Disregard my earlier post if you happened to catch it. Sorry about that, though most of the same info still applies..

To address your post Eugene, I am not a Cisco employee, but saw the OP's post that he got no replies for a week and wanted to do my best to help him out. Trust me, I know its no fun when your network gear doesn't want to play nice. Just so you know, you can identify cisco employees by the little cisco icon next to their name.

It sounds like you upgraded the firmware on Friday, which means it has been up and running for 4 days without issue, correct? Then it went down today and appears to have defaulted itself? Is it complete factory defaults or just the password that reset? You've had this for 2 mths - did you see the same behavior with the earlier firmware? Have you tried some of the suggestions I made to Johannes above? You can try going back to the earlier firmware if it was working better, or try reflashing the rvs4000 with the firmware. Stupid question, but I have to ask it, you did hit save after changing the password, and tested it by logging off and back in with the new password? Same question about the temperature as I posed to Johannes. Also, do you see anything in your log from today? If you have anything, please post it as it may indicate what happened before the reset. Are you running IPS?

As far as it being end of life, I don't know what to tell you. Its happened to me as well, the stores just like to get rid of their inventory before putting out new product. I know my local tech shop won't even order the new model gear until the old stuff is gone. I don't know whereabouts you are, but here in NY I've seen both old and new gear on the shelves in Best Buy or Staples and no real way to discern between them unless you are familiar with the  products. A quick google still shows many retailers selling them, including my local Staples, but it looks like the price has come down.

On a positive note, if you did purchase it new 2 months ago you should be entitled to 1 year of support from the Small Business Support Center. Try giving them a call (US: 1 866 606 1866) or chatting with them and see if they can help.




The rvs4400 is one of Cisco's finest. Unfortunately if you administrate the network then you set the rules. P2P sharing uses vast amount of connections per IP. More that your 25 clients. If you feel that p2p clients are killing the bandwidth then use your firewall to block p2p access.

You can do some QoS but its sometimes hard the correct priorities.

How are the WAPs connected to the router? You set each wireless cell to use b or g to limit throughput, or limit the LAN ports on the rv4000 to 10full to lower bandwidth over the network.

At the end of the day you're in charge of administration so implement some policies so your client know you are pro-active

Sent from Cisco Technical Support Android App

Regards Simon

Hello Johannes Peter.

1.) If the device is sporadically locking up, this sounds like a possible hardware issue. But, to give the benefit of doubt to the router's condition, have you swapped DNS servers to something like ?

2.) The logging is functional. When you navigate Adminstration -> Log hit the radio button for the Outgoing and Incoming log. Addtionally choose the Output Blocking Event Log enable and local log enable.

To test this, you can go to Adminstration -> Management and change the password to the admin account. Once you relog the router you will see a log entry "Dec 31 16:06:56 - Configuration changed!"

Once you reboot the router, the log files will be dumped.

3.) The router has an odd implementation of bandwidth rate limiting. If you navigate to QoS -> Bandwidth Management you can specify a rate limit based on IP address.  The reason this is an odd implementation is because this is a garaunteed minimum rate that will be provided. In other words, you can say x.x.x.x will always have at least X amount of bandwidth for the upload and download speed.  The UI is very confusing, suggesting you can actually cap the amount of inbound download speed.

4.) Although I agree, there are how many colors? It is an aesthetics thing.

-Tom Please mark answered for helpful posts

Hello having the same issue with no inbound logs being reported tried resetting back to factory default but still no logs on incoming. anyone know how to fix this ?

Make sure that your system date and time is set correctly. I had some issues with this and found that every time the router rebooted, the system time was changed to a generic time.