Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


RVS4000 issues downloading large files

I have an RVS4000, and have been unable to update my iPad with the new iOS verison because the download of the update file keeps timing out.  The file actually gets to the end of the download, but then times out before completion.

My RVS4000 is being used in gateway mode and is connected to another cable modem.  When I connect my computer directly to the cable modem, the download completes without issue.

I've turned the IPS off.

My patience is running out, as I've tried just about everything (firmware update, reboot, signature update, etc.).  When I contact support, they want me to pay $79 to open a ticket.  The router costs $120.


Rising star

Hi Patrick,

Thank you for posting. I have not seen an issue like this before with the RVS4000. I have a few questions:

  1. How large is the file that you attempted to download?
  2. Is the file publicly available? (Would like to try from our lab)
  3. What type of internet connection do you have? (Cable, DSL)
  4. What is the MTU set at on the WAN port of the RVS4000?

The file I was trying to download was about 650MB. I also tried

downloading a 1GB file and had the same problem. You can probably try any

large file which is available online. I'm using a DSL connection and my

MTU is set to auto.


On Fri, Oct 14, 2011 at 12:13 AM, mpyhala <

Hello Patrick,

This sounds like an MTU issue. I would change the MTU to 1492 in the router and test. If you still have the issue, complete an MTU test to find the exact MTU that you should use. You can find instructions at the following page: