cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

SIP ATA Behind RV220W

Hello,

I am trying to configure a Cisco SPA8000 to function as a SIP ATA behind a RV220W router.   I cannot seem to get port forwarding working or otherwise allow the SIP traffic to the SPA8000.    When I replace the RV220W with another router / firewall everything works fine, but when I put in the RV220W I am not able to register etc.   I have been over and over the manual and "yes" I have the SIP ALG enabled.   Here is my setup:

Internet  =>  RV220W (public) => SPA8000 (private)

Can anyone suggest anything please?

Thanks

Chris

P.S. on hold for nearly 3 hours waiting for Cisco support!!

CAT

7 REPLIES 7

Tom Watts
Advisor
Advisor

Hi Chris, using the 1.0.4.17 firmware, try to make the port forwarding under the access rules instead of using the port forwarding page.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Tom,

Thanks for the response.   I have done so.   I have created custom services for the UDP SIP and the UDP RTP ports and added them to the access rules without success.   I am in the process of downgrading to the 1.0.3.X firmware.

CAT

Chris,

have you managed to get it working?

i'm thinking about similar configuration RV220W and SPA8000.

Yes, I was able to get this working and it has been doing extremely well for about 4 months.   The key in my case was to make sure the SIP AGL was ENABLED.  The problem was that the service provider's SBC was seeing a non-routable IP address in the SIP header and was requiring a shorter registration interval than the endpoint.   The result was that the SBC would eventually deny the connection when the registrations got out of synch.

I can recommend this configuration now and for high SIP traffic (in excess of 12000 minutes per month on 5 channels).

Chris

P.S.  It was the service provider who insisted that the SIP AGL needed to be disabled in order for our configuration to work with their service!