Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter


Split DNS not working on RV220W

I've currently tried firmwares and and neither of the two work properly with split dns doesn't support Split DNS .

Split DNS was implemented in which was pulled, so I can't even test that.

You can find the release notes here:

But the download itself doesn't exist. I've combed the internet and nothing.

I've set up Split DNS before with two RV042s and it works fine.

So this is my setup:



LAN: 192.168.1.x





LAN: 10.0.0.x


Subnet: (this is intential)

Site to Site VPN:

Using RV220W's default IKE settings.

Split DNS Enabled

Primary DNS Server:

Primary Domain:

(this is set up on the home network)

I'll skip the unnecessary stuff.

VPN connects fine. IKE is all good. Everything pings.


response is good


no response

DNS Proxy enabled and disabled makes no difference.

Changing the RV220W's DHCP domain name to doesn't matter

With Split DNS disabled will respond with the WAN IP (because it's using the ISP). That's expected

With Split DNS enabled never responds (no ip given)

Has anybody ever got Split DNS to work on and higher? Can somebody share their to see if this issue is on and above?


Thanks. None of them worked. I checked my DNS server and it's not getting any requests from the RV220W. I guess I'm sending this thing back


I tried all firmwares, none of them work.

I set up my own linux server.

Installed dnsmasq

added one line to dnsmasq.conf


disabled the dhcp

pointed my dhcp clients to the linux server

and it worked.

Seriously, Cisco? Check your code. It's on your side.


I had encountered more strange issues using very similar structure as mentioned. I have established IPSec gateway to gateway VPN between RV220W (Firmware Version a RV042 (Firmware Version: I use domain server (SBS2011). The Domain server is on side of RV042.

My statement is:

  • •1.       It is not possible to get through VPN all IPs (some PCs are invisible) on side of RV042, I tried set up split DNS, it does not work. I had Router WRVS4400N before and everything worked OK.
  • •2.       If I update RV042 to the latest firmware (, it is impossible register some PCs on side of RV220W to the domain.

I would expect better work from leading company like CISCO thinks.


In search for a solution to this I replaced our internal DNS IP, which is accessible through the VPN tunnel, with a publicly available DNS IP such as After that requests to the Split DNS zone configured in the VPN policy are forwarded to the correct server by the DNS proxy. So the problem seems to be that the proxy is not forwarding the Split DNS request to the correct interface which cause the request to time out.


I know this is an old thread, but the issue reported by OP seems still to exist.  The RV180 appears to have the same problem to according to this link

Our scenarios is that the RV220W is used in a small office with only client machines.  When there is a need to access servers at HQ, I would like the DNS query to be routed to our internal DNS servers based upon our domain name. For all other DNS lookups the DNS of the ISP should be used to avoid unnecessary traffic over the IPSec tunnel.

The configuration is:

  • IPv4 LAN (Local Network):
    • DHCP:Primary DNS Server = RV220W's LAN address
    • DNS Proxy: enabled
    • Split DNS: enabled
  • Advanced VPN Setup:VPN Policy Configuration
    • Domain Name Server 1: IP of our internal DNS server on the other side of the IPSec tunnel
    • Domain Name 1: Our domain name i.e. in our internal DNS server we have all hosts in our domain

Besides tunneling all traffic, does anyone know about a way to direct all DNS queries for our domain through the tunnel to our internal and protected DNS servers, but use the ISP's DNS servers for all other look-ups? Btw, we do not have overlapping sub-nets (bad idea in the first place).