cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Get the latest new and information the November issue of the Cisco Small Business Monthly Newsletter

1010
Views
0
Helpful
1
Replies
Highlighted
Beginner

SR520 NAT Help

Hi,

I have an SR520 with the following NAT config (full config is below this).  Why isn't this working?

interface FastEthernet4

ip address 98.113.43.141 255.255.255.0

ip nat outside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

interface Vlan75

ip address 192.168.75.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache

ip nat inside source list 1 interface FastEthernet4 overload

access-list 1 permit 192.168.75.0 0.0.0.255

----

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SR520

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

aaa session-id common

!

crypto pki trustpoint TP-self-signed-544575191

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-544575191

revocation-check none

rsakeypair TP-self-signed-544575191

!

!

crypto pki certificate chain TP-self-signed-544575191

certificate self-signed 01 nvram:IOS-Self-Sig#1.cer

dot11 syslog

ip source-route

no ip routing

!

!

ip dhcp excluded-address 192.168.75.1 192.168.75.10

!

ip dhcp pool inside

   import all

   network 192.168.75.0 255.255.255.0

   default-router 192.168.75.1

!

!

no ip cef

ip name-server 4.2.2.1

!

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

switchport access vlan 75

!

interface FastEthernet1

switchport access vlan 75

shutdown

!

interface FastEthernet2

switchport access vlan 75

shutdown

!

interface FastEthernet3

switchport access vlan 75

shutdown

!

interface FastEthernet4

ip address 98.113.43.141 255.255.255.0

ip nat outside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

!

no ip address

no ip route-cache

shutdown

!

interface Vlan75

ip address 192.168.75.1 255.255.255.0

ip nat inside

ip virtual-reassembly

no ip route-cache

!

no ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 98.113.43.1

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 permit 192.168.75.0 0.0.0.255

!

!

!

!

control-plane

!

banner login ^CSR520 Base Config - MFG 1.0 ^C

!

line con 0

no modem enable

line aux 0

line vty 0 4

transport input telnet ssh

!

scheduler max-task-time 5000

end

Everyone's tags (2)
1 REPLY 1
Beginner

SR520 NAT Help

Oops. Turned out 'ip routing' was not enabled.