Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


SRP 526W

I have a new SRP 526W but when I plug in the DSL cable it does not see anything.

According to ther manual the DSL CD light should flash when it detects in internet service but I have tried it on two connections and it does not even come on.  I have seen the DSL Data light flash on while rebooting but never stays on. 

So far I have tried it on a PPPoA connection and a 1483 bridged connection but neither work.

Is this a faulty router?

Andrew Hickman
Cisco Employee

Hi Steven,

The SRP526 supports ADSL2+ Annex B (i.e. ADSL over an ISDN line).  Do you have an Annex A line (ADSL over analogue telephone line)?  If so, you need to use the SRP527W.



Sorry to jump in but have the same issue -

my adsl status is :

DSL Status: G.994 Training
DSL Modulation Mode: NOT TRAINED

firmware is 1.01.24 (003) Sep  7 2011

help me obie wan your my last chance

Solved down graded firmware to 1.01.23

Hi Andre,

The 1.1.24 release did add some enhancements to the DSL, so I'm concerned that this might have caused an issue for your particular service. 

Would you mind trying the 1.1.24 release again to verify that this really won't train with your service?  If it doesn't, could you please provide details of the service you are using and the SRP configuration?

Many thanks


yep - confirmed - once it went back to 24 it failed.

Downgraded back to 23 - connects fine and now has a new issue....

it connects and can ping hosts on both the inside and outside but it is not sending traffic from the inside out

it seems to be allowing outbound traffic intermitently and no inbound as best I can tell.

Hi Andre,

Which service provider (and country) are you trying to connect to?

Could you grab a remote support file (from the adminstration menu) for when you are connected with 23 and also when disconnected with 24. 

Please then raise a case with the Small Business Support Center, providing those files.  When you have opened the case, can you let me know the case number please?

Many thanks


Hi Andrew,

the provider is Telkom South Africa -

Every time I try and open a support case it requires that I buy support; an irritating request given that neither of these routers has successfully performed for more than 4 hours.

At this point I have two Cisco routers that the local distributor won't take back and won't/can't support. When I called Cisco South Africa they hung up without answering any questions. I am a long time user of Cisco routers and switches (bought my first one back in the mid '90's in Southern California) and I'm sad to say it has become obvious to me that buying Cisco products in South Africa is a waste of money - so I won't be making this mistake again.

Thank you for the help you provided



Hi Andre,

I am sorry to hear that.

Can you let us know what configuration you are using?  We'd like to know which feature to look in to fixing if something is broken here.

Many thanks,


we are not using any voice and have deleted the associated vlan

we are using:

vlan1 - for ports  1 and 2 - just regular tcp with dhcp (wish we could turn off dhcp)

vlan2 - on ports 3 and 4 -

intervlan routing enabled

we have port forwarding enabled

and the following NATs:

ports udp - 5060, 27051, 1200 -1273

ports tcp - 8000, 161, 162, 21 -23, 1168 - 1174,

both tcp& udp - 10000 - 20000, 1719 -1720,

on version 1.01.23

the problem is this - when we do get a adsl link it works for a short while then outbound tcp traffic fails as does inbound traffic (don't know if this is a firewall issue, lack of voice vlan, adsl jammed)

on version 1.01.24 - no adsl connectivity was possible

we wanted to use the vpn capability in two areas one was an ipsec network to network and the other was a pptp for external users to reach the office network. - config and reliability did not allow us to get this far.

I tried to exchange these routers for 877's ( and pay the diff) howevver the local distributer would not allow this.

hope this helps or send me an address I can email the config backup to, please

Thanks Andre,

I was specifically interested in the DSL configuration that you are using.