Showing results for 
Search instead for 
Did you mean: 

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.


SRP 527W - ZTE MF636 Driver Problem

I recently purchased an SRP 527W router.  The final decision was based upon this router having a 3G Dongle Failover.  After buying the router, I then needed to purchase a compatible dongle here in the UK, not an easy task especially when you don't want to setup a new mobile contract.  Eventually I got my hands on a ZTE MF636.

This dongle is specifically mentioned as supported in the CISCO document titled "3G USB Modem support for Services Ready Platform SRP 500 Series" On page 2 at the bottom of the table.

After swapping SIM cards from my old dongle to the new one I plugged it into my PC installed the drivers, and hey presto it worked.  I then plugged it into the CISCO router, and could not get it to be recognised, although USB light comes on and flashes.  I tried turning on and off (a lot!) , manual setup, automatic setup, updating firmware plugging in when on, when off, leaving an hour etc ad nauseum.  Always the same message "Unable to Detect USB Mobile Modem".

At this point I gave up and contacted support.  My first response told me I couldn't have any support on this item, would you like to buy a service contract...  After breaking some things and snapping at my nearest and dearest I sent a response pointing out I am an end user, just bought this thing and it doesn't do what it says on the tin.  The next response told me to send it back if it was DOA, not exactly useful.

After not throwing the thing straight in the bin I decided to do some digging, I decided it was more likely that the router was not identifying the device, rather than not seeing it at all.

The USB ID of my dongle is 19d2:0033

This does not change in mobile or zerocd mode (I know this as I've had it running under linux).

After much digging I downloaded the debug info from the router and in the file  dump_nvram_cmd.txt I found the line "card_model=19d2:0031"

Yes this modem is available with the same model number but 2 different USB IDs.

To fix this I see there are three options, here is the list in my order of preference.

  1. Release a quicky firmware update that also points this USB ID towards the correct device driver.
  2. Give me the SSH Uname and Pword, and I'll modify the HAL myself.
  3. Change the online documentation so the last line of the supported dongles reads Some ZTE MF636 dongles, but we don't know which ones.

Many Thanks




The router has been in for a couple of months now, and in its normal ADSL life is working very well.  Haven't had to do any restarts or anything like that.

ZTE were uninterested in passing on any support as they do not deal with end users.  They transfered me to someone who fixes mobile phones, not so useful.

The dongle still is not recognised, could a Cisco person at least acknowledge there is something happening as the silence has been deafening.  Again I re-iterate this is a device that is named in product literature as supported.

A. Pearce

Hi Andrew,

A new BETA firmware is released, it fixed some issues with ZTE MF636, please try it.

Best regards

Rogelio V.


Thanks for the reply, just got back after the christmas break.  When I try the link you supplied I get the message.

"It appears you're not allowed to view what you requested. You might contact your administrator if you think this is a mistake."

Please could you send me a different link, update permissions or just email me the firmware so I can try it.

Many Thanks,

Andrew Pearce