cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

669
Views
0
Helpful
2
Replies
sinegar
Beginner

SRP527W doesn't detect Sierra 320u modem

My SRP527W doesn't detect a Sierra 320u modem. The modem is listed as supported however the router can't recognise it.

Both the SRP527W has the latest firmware (1.2.6) and the 320u also (1.4.5). I have tried other firmwares too without luck (SRP527W - 1.1.27, 1.2.5; 320u - 1.4.2).

The following logs might help:

Jan  1 12:03:05 almafa kern.info usb 1-1: new high speed USB device using ehci_marvell and address 4

Jan  1 12:03:05 almafa kern.warning usb 1-1: config 1 has an invalid interface number: 7 but max is 3

Jan  1 12:03:05 almafa kern.warning usb 1-1: config 1 has no interface number 2

Jan  1 12:03:05 almafa kern.info usb 1-1: configuration #1 chosen from 1 choice

Jan  1 12:03:05 almafa kern.warning DEBUG_KERNEL_LED >>> led_action->mode :4 == LED_MODE_3WAY_BLINK_COUNT:6

Jan  1 12:03:05 almafa kern.warning

Jan  1 12:03:05 almafa kern.warning

Jan  1 12:03:05 almafa kern.info sierra 1-1:1.0: Sierra USB modem converter detected

Jan  1 12:03:05 almafa kern.warning DEBUG_KERNEL_LED >>> led_action->mode :4 == LED_MODE_3WAY_BLINK_COUNT:6

Jan  1 12:03:05 almafa kern.warning

Jan  1 12:03:05 almafa kern.warning

Jan  1 12:03:05 almafa kern.info usb 1-1: Sierra USB modem converter now attached to ttyUSB0

Jan  1 12:03:05 almafa kern.info sierra 1-1:1.1: Sierra USB modem converter detected

Jan  1 12:03:05 almafa kern.warning DEBUG_KERNEL_LED >>> led_action->mode :4 == LED_MODE_3WAY_BLINK_COUNT:6

Jan  1 12:03:05 almafa kern.warning

Jan  1 12:03:05 almafa kern.warning

Jan  1 12:03:05 almafa kern.info usb 1-1: Sierra USB modem converter now attached to ttyUSB1

Jan  1 12:03:05 almafa kern.info sierra 1-1:1.3: Sierra USB modem converter detected

Jan  1 12:03:05 almafa kern.warning DEBUG_KERNEL_LED >>> led_action->mode :4 == LED_MODE_3WAY_BLINK_COUNT:6

Jan  1 12:03:05 almafa kern.warning

Jan  1 12:03:05 almafa kern.warning

Jan  1 12:03:06 almafa kern.info usb 1-1: Sierra USB modem converter now attached to ttyUSB2

Jan  1 12:03:06 almafa kern.warning DEBUG_KERNEL_LED >>> led_action->mode :4 == LED_MODE_3WAY_BLINK_COUNT:6

Jan  1 12:03:06 almafa kern.warning

Jan  1 12:03:06 almafa kern.warning

Is there anything that needs to be done on the router or the modem?

2 REPLIES 2
David Harper
Cisco Employee

There shouldn't be anything particular required.  I assume the Interface Setup > WAN > Mobile Network page and the Status > Mobile Network Status pages both show that there is nothing connected at all?

Anyway, I have a 320U here running the same firmware and it is working fine on a 527 running 1.2.6(3).  I'd suggest that you log a support case with the SBSC (http://www.cisco.com/go/sbsc for contact details) and get them to have a look.  There are a few different reasons I can think of that might cause this, including damaged or mis-connected hardware, or indeed that Sierra have changed the modem hardware without changing the model number.  That has happened before, though the Sierra Wireless modems have generally been pretty good in my experience.

Cheers,

Dave.

Dave, thank you for your quick response. I will try the support.

Peter.