cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

1088
Views
0
Helpful
1
Replies
crumpethead
Beginner

SRP527W-U --- No multicasts between wired & WiFi ??

I've just received a new SRP527W-U-E-K9 router to replace an old D-link router. However Apple IOS devices are not discoverable by iTunes on a Windows PC. The PC is connected to SRP527 by wired ethernet. All IOS devices are on the same SSID and the same VLAN as the wired ethernet devices.

I have been reading on several other threads in this site about this exact same problem. The fault was that multicast broadcasts were not being forwarded between wired ethernet and WiFi on the same vlan.  See this thread.

https://supportforums.cisco.com/thread/2059353

The fault in thie above thread was resolved by a firmware update MR3 (v1.1.19) last year however it appears that the SRP527W-U has slightly different firmware to this version.

The configuration of my SRP527 is the same as the original poster's config in the above thread.

Setup:

  • WinXP SR3 running iTunes and Bonjour service - connected by ethernet to SRP
  • MacOSX Mac-mini- connected - connected by ethernet to SRP
  • 4x IOS wireless clients (iPhones and iPads) on same SSID
  • IGMP v.2 enabled with proxy and immediate leave enabled.
  • Intervlan routing enabled
  • RIP disabled
  • ADSL port disabled
  • Ethernet Port 4 = WAN

From each IOS device (iPhone or iPad), I can see all other IP devices on the VLAN, but IOS devices are not discoverable on iTunes via Bonjour.

The version information of my SRP is embedded below. As it is brand new, I  assume that it is the most recent firmware, so I would have assumed that the bug which was resolved in the above thread above would be incorporated in this firmware version.

Model:SRP527W, ADSL2+ AnnexA, 802.11n ETSI, 2FXS/1FXO
Version ID:V01
Hardware Version:4.1.0
Boot Version:1.1.22 (Feb 22 2011 - 09:42:55)
Firmware Version:1.2.4 (003) Jan 11 2012
Recovery Firmware:1.02.02 (009)
Current Time:Mon, 22 Oct 2012 19:50:23
Wireless:1 SSID Enabled

Is Cisco aware of this problem and is there any other firmware that I can load onto my model of SRP to resolve this?

Many thanks,

Paul

1 REPLY 1
crumpethead
Beginner

Update - Problem solved.

I spent a good part of the day testing my network. I installed Wireshark network analyzer on the Win XP box running iTunes, and discovered that mDNS broadcasts WERE in fact being broadcast between WiFi & wired ethernet ports. It was iTunes that was just failing to acknowledge the IOS devices by listing their presence. I even reinstalled the old D-link router and iTunes still failed to detect the presence of the IOS devices.

The problem with iTunes was resolved by stopping, waiting then restarting the services "Bonjour Service" and "Apple Mobile Device". I tried restarting bonjour in isolation but that didn't seem to work.

Sent from Cisco Technical Support iPad App