cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3958
Views
3
Helpful
11
Replies

WRV210 - need to reflash firmware via tftp

toddalmond
Beginner
Beginner

WRV210 has mangled firmware, DHCP not assigning IPs. Tried finding info on linksys and cisco sites regarding the correct tftp process but the documentation either doesn't exist or it is buried somewhere in an inscrutable fashion. There is nothing in the administrator guide regarding tftp usage other then a line saying tftp upgrades are possible.

I also can't find any linksys or cisco site where I can check the warranty of the device.

Any hints, tips, clues, cheats, or even *gasp* _answers_ would be appreciated.

11 REPLIES 11

ktsangel69
Beginner
Beginner

I had a lot of problems with a couple wrv210's. I was told that the wrv210 does not support uploading by tftp. I wanted to give that a try too as part of my troubleshooting. I never could get the firmware to flash successfully via the web interface.

The answer to your question is there: https://supportforums.cisco.com/message/3078578#3078578

toddalmond
Beginner
Beginner

The link to the user guide in the referenced thread is no longer valid. I'll try the snippet that was posted. (the current guide has no such information.)

Hi Todd,

Here is a link to the WRV210 admin guide that may help: http://www.cisco.com/en/US/docs/routers/csbr/wrv210/administration/guide/WRV210_AG_OL-20252.pdf

Thanks,

Cindy Toy

Small Business Support

Community Manager

Regards, Cindy If my response answered your question, please mark the response as answered. Thank you!

Nope - that's the same guide I recently downloaded. The only reference to tftp is on page 104:

"Firmware Upgradeable Through Web Browser and TFTP Utility"

Extrait from the  User guide:

The firmware upgrade failed (the DMZ LED is lit solid
green after the power is turned off and then on again).

---
If the Web-based utility’s firmware upgrade mechanism
should fail, the Router will be non-functional. At this time,
you can use the Router’s TFTP-based firmware upgrade
mechanism to upload the new firmware (.img file) to the
router. However, you first need to assign a static IP address
to the PC that is hosting the TFTP client, in the subnet
192.168.1.0 and with subnet mask 255.255.255.0, e.g.,
192.168.1.100.

---
The following is the command that is entered into a
Windows Command Line to upgrade the firmware using
the Windows built-in TFTP client.
tftp -i 192.168.1.1 put WRV210firmware.img

Hi,

Tried that but it failed. Do you have a link to the user guide? Oddly, the administrator guide has no tftp info.

The link to User guide does NOT exist on cisco.com. I advise you to contact the SBSC to receive support and answers to your questions from here> Cisco SBSC Contacts: http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

---

In my opinion the procedure fails, because the TFTP tool is only to be used when the device is inaccessible, as a last resort to recover the firmware failure and not to reflash the firmware.

toddalmond
Beginner
Beginner

Tried the snippet instructions in the referenced thread. Fails - "Timeout occurred"

Power light and ethernet port light solid, wireless flashes. When attempting to reset via the reset button the power and DMZ lights will be solid and nothing else. After unplugging for a few hours it will go back to - power light and ethernet port light solid, wireless flashes.

Also tried the snippet instructions in the referenced thread while the power and DMZ lights were on. Fails - "Timeout occurred"

toddalmond
Beginner
Beginner

Two weeks Cisco - c'mon!

No user guide. The link to the user guide in the supplied link STILL goes nowhere.

So try on my last question: how can I find out if the unit is still under warranty? Do I have to call support or is there an online warranty checker?

"Lip service" seems to be the only level of service small business router owners can expect from Cisco.

Call the small biz support line. The guys were very helpful to me. They'll be able to answer your questions about the warranty. Have your serial # handy.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: