cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2648
Views
0
Helpful
15
Replies

SA520 optional wan port problems

Hi,

I've got some problems activating my optional wan port...

The error is :

[SA520]pppoeMgmtTblHandler: pppoe enable failed

[SA520]pppoeMgmtDBUpdateHandler: error in executing database update handler

Thanks for your help,

15 REPLIES 15

weilia
Cisco Employee
Cisco Employee

Hi,

what's the version of your firmware ?

Regards,

wei

Hi,

It's 2.1.18 firmware version...

And I tried with old 1.1.42 version...

With the same result,

Thanks,

Hello,

No one can helps me ?

Thanks,

Hi Thierry,

Sorry for the delay. We are looking into the log you provided. At meanwhile

please follow the instruction in the the link below to obtain the latest image

MR4 RC1. Let me know if this solves your issue.

https://supportforums.cisco.com/docs/DOC-16365

I will get back to you on our investigation asap.

Regards,

Wei

Hi Wei,

I sent the mail,

Thanks for all,

Thierry,

The pppoe authenication your setting up on the SA, have you been successful in getting the device to authenicate with that information on wan 1?

I also seen alot of bonjour error messages, are you using bonjour with the SA?  If not, try disabling the feature in the sa and see if that eliminates that portion of error messages.

Hello David,

to Deactivate "Bonjour" I need to disable "Block Multicast Packets" in "Attacks" menu ?

Right ?

For the first question, 1 time, only 1 time, at my first install, SA have been successfully authenticate on this WAN.

I'm using an old but so good Thomson 510 modem/router for this line.

When router mode is on, Thomson 510 works very well, alone...

But I switched it off making it working with SA520.

Thanks,

Thierry,

To disable Bonjour, go to the network management tab and select bonjour.  At this point you can disable it.

With the Thomson 510, is it still in bridge mode, a way to test this: Plug a pc directly into the Thomson 510, if you get an ip address and your able to get online, then it is not in bridge mode.  If you don't get an ip address from the Thomson, then verify your authenication, Username/Password.  You can use your pc and connect via pppoe and put the authenication information on your pc and see if you can connect.

If that works, then make sure the profile has the same information and reapply it on the optional wan.  You can plug into wan1 and test it to see if it is hardware on the optional wan that is not allowing you to connect.

David,

So, my investigation results :

1/ Thomson 510 is in Bridge mode ;

2/ With a PC and PPPOE connection : It works Well with my Thomson 510 ;
3/ I disabled Bonjour on Thomson 510 : It the same problem ;
4/ I tried the new MR4 RC1 : same problem...

Thanks,

David,

I don't know why,

but after connecting with PC,

and linking to Cisco,

optional WAN is UP !!!

I'll try this for next days and then say to you If It's working well,

Thanks,

David,

I've got a lot of DNS errors, after activating LOAD BALANCING...

How can I resolve this ?

My DNS domain server are using free global DNS servers (Google dns, UltraDns etc.)

Thank you...

Hi Thierry,

we have exactly the same issue you are describing, pppoeenable failed for optional WAN. You mentioned that you resolved this, does it work now for you? Also, I did not fully understand what you did.. is this what you did?

  1. Disconnect Cisco SA520 optional WAN port from modem
  2. Connect modem to single PC or laptop
  3. Connect to internet using single PC or laptop through modem, using PPPoE
  4. Disconnect from internet
  5. Connect modem to Cisco SA520 optional WAN port

Sorry to bother you, but I am a bit desparate with this..

Thank you,

Roland

Hi Thierry,

Does the DNS works with only single WAN, the optional WAN ?

Wei

Hello weillia,

Thanks for your response,
but....

I don't understand your question ? i tried protocol bindings to force DNS protocol using first wan port...
Problem is the same...
And I'm using public Google dns for my domain.

But I've got another big problem !!!
I bought a small DLink DSL320B to replace my old Thomson 510 (wich is not ADSL2+ compatible)....
It doesn't works with SA520... I've got kernel errors :

Fri Sep 30 14:45:00 2011(GMT +0200)ERRORKernel ip_conntrack_in: Frag of proto 17 (hook=0)
Component: KERNEL
Fri Sep 30 15:24:01 2011(GMT +0200)ERRORKernel *******The above log repeated 41 times *******
Component: KERNEL
Fri Sep 30 15:24:01 2011(GMT +0200)ERRORKernel ip_conntrack_in: Frag of proto 47 (hook=0)
Component: KERNEL


Configuration is good (bridge mode) and It works well directly on a PC...

Thanks for all.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: