cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

Voice and data vlan problem

738
Views
5
Helpful
3
Comments
Beginner

HI 

Recently I have perched 10 Cisco SG350 28 port gigabit poE switches for my running project . I would like to create my data and voice vlan in the same port where the PC will connect with the phone set.

i configured my Dhcp on mikrotik cloud core router with vlan 10 (192.168.4.0/22) and 40 (192.168.8.0/22) 

my switch port mode is trank and untag with vlan 10.

vlan 40 is my auto voice vlan and all ports are tagged .

while i connect my phone set ( Grand-stream Gxp-1610) to switch port the pc get IP but it loose connectivity when phone completely read or get IP. phone is working well . and pc also working when connect to switch directly. In that situation I log into switch and see my switch ports are automatically untaged to native vlan-1 .When I exclude from vlan-1 and untag to my data vlan that is 10 , it's working fine and the PC is getting ip. but while I reboot my phone or Change switch port or switch rebooting the ports automatically untaged to vlan-1 . so I moved my nateve vlan to vlan-10 . but the same problem is going on . please help me .

I am very nervous ...........

 

3 Comments
Cisco Employee

Hi Sir,

 

My name is Puneet Sandel and I am from Cisco small business technical support center.

 

The issue you are facing is because of Auto smart port enabled by default in the switch. Please follow the below steps via GUI of the switch and it will definitely resolve your issue.

 

  • Create VLANs on the switch. For e.g. If data VLAN is 2 and voice VLAN is 5 then assign VLAN 5 in Auto Voice VLAN tab.
  • Make sure you see the operational Voice VLAN as 5 too.
  • Change Display Mode from Basic to Advanced.
  • After that go to Interface settings under VLAN Management, change the port mode from Access to Trunk.
  • Now under Port to VLAN Membership, allow data VLAN as untagged and voice VLAN as tagged on the port that are connected to IP Phones and desktops/laptops are connected to IP Phones.
  • Go to IP configuration>> IPv4 Interface and assign IP to both VLAN 2 and VLAN 5
  • Create a DHCP pool for both the VLANs in case DHCP server is enabled in switch. (Optional)
  • Go to Smart port tab, Make sure Smart port is enabled .
  • Make sure IP Phone+Desktop is checked under Device Detection.
  • Go to Smartport Type settings and select Macro for IP Phone+Desktop.
  • Click on Edit. Make sure Macro Type is selected as Built-in Macro.
  • Change Macro Parameters.
  • Change the Parameter2 value to the value of Data VLAN ID (in this case 2 as data VLAN is 2).
  • Parameter3 value will automatically show 5 in case you see the operational voice VLAN as 5 under Auto voice vlan settings.
  • Save the running configuration to start up configuration.

Important: Do not disable smart port if it is already enabled as doing so will automatically change the port mode status from trunk to access.

 

Note: Macro Parameter 2 value needs to be changed in case data vlan is different from the default VLAN 1.

 

Please do not forget to mark this post as solution in case it resolves your issue.

 

Regards,

Puneet Sandel

Technical Consulting Engineer-Level 2

Global CX Centers – Small Business Support

Thanks boss 

I did not change macro parameters .now it solved 

Cisco Employee

Hi, Please mark the post as solution so that it can help others too.

 

Good to know your issue got resolved.

 

Thank you for choosing Cisco. Have a great day ahead.