cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

525
Views
5
Helpful
5
Replies

Voice VLAN , Access VLAN, Switchport , SG350 Switch

Hi All! 

I had a problem which is easy to some , i have an SG350 switch topo attached below the switch connect to Panasonic PBX port gi/50 , IP phone to port gi/6 , connected to other switches from gi 1,to 5, but the phone not registering , something wrong in my configuration.

Voice Vlan =20

Data Vlan=10 

 

Configuration of the switch which connected to Panasonic PBX , 


config-file-header
Rack-01
v2.5.0.83 / RTESLA2.5_930_364_091
CLI v1.0
file SSD indicator excluded
@
!
unit-type-control-start
unit-type unit 1 network gi uplink none
unit-type-control-end
!
vlan database
vlan 10,20
exit
voice vlan id 20
voice vlan state auto-enabled
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
hostname Rack-01
username admin password encrypted 004036d73f79edf1df016b146c4cd162dae1a012 privilege 15

!
interface vlan 1 ( for mgmt)
ip address 192.168.1.254 255.255.255.0
no ip address dhcp
!
interface vlan 20
name VOIP
!
interface GigabitEthernet1 (Other switch)
spanning-tree link-type point-to-point
switchport mode trunk
switchport trunk allowed vlan all
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet2 (Other switch)
spanning-tree link-type point-to-point
switchport mode trunk
switchport trunk allowed vlan all
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet3 (Other switch)
spanning-tree link-type point-to-point
switchport mode trunk
switchport trunk allowed vlan all
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet4 (Other switch)
spanning-tree link-type point-to-point
switchport mode trunk
switchport trunk allowed vlan all
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet5 (Other Switch)
spanning-tree link-type point-to-point
switchport mode trunk
switchport trunk allowed vlan all
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet6   (Panasonic IP Phone)
storm-control broadcast level 10
storm-control multicast level 10
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
spanning-tree bpduguard enable
switchport trunk allowed vlan add 20
switchport trunk native vlan 10
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface GigabitEthernet50   ( Panasonic port )
switchport mode access
switch port access vlan 10
!
exit

5 REPLIES 5
balaji.bandi
VIP Expert

Check this thread may help you to resolve the issue : ( remove the macro or smart port information - that will help you)

 

https://community.cisco.com/t5/small-business-switches/sg350-28p-voice-and-data-vlan-config-on-a-single-port/td-p/4008018



BB


*** Rate All Helpful Responses ***

Thanks balaji I saw your reply on the other post before posting mine I did the same but I will turn off macro auto smart port and see what happen , 

Panasonic PBX port should be in

Switch port mode access 

Switch port access vlan (DATA) 

Is that right ??! Plz confirm 

you want voice and Data on that port right . so you need add both the vlan to work.

 



BB


*** Rate All Helpful Responses ***

aha okay so the panasonic port will be considered as IP phone port  in configuration, to carry multiple traffic type , 

 

balaji.bandi
VIP Expert

yes you right, test and advise.



BB


*** Rate All Helpful Responses ***