cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.
Get the latest news in this issue of the Cisco Small Business Monthly Newsletter

SPA50xG IP Phone Recovery Utility (SoS mode recovery)

36955
Views
10
Helpful
39
Comments

In the event that a SPA50xG IP phone experiences an interruption of power during a firmware upgrade, the phone's firmware images could be rendered unusable. If this occurs, the phone will display a message "SOS phone in recovery mode".

The phone will automatically attempt to acquire a valid image from the "last upgrade URL" that it knows about.

You can manually recover a SPA50xG phone from this state using the attached recovery utility. You can use the utility regardless of the firmware version of the phone.

Using the recovery utility

When the phone is trying to access the “last upgrade URL”, it will not be able to handle a recovery request from the PC. Once the phone gives up, you will be able to successfully use the recovery utility:

  1. Make sure the default TFTP port (69) is not occupied on the computer. For example if you have a TFTP server such as Pumpkin or SolarWinds running, shut the TFTP service down.
  2. You might have to disable the firewall or other security measures on the PC to allow TFTP to function properly.
  3. Run the recovery utility and enter the phone’s SN when prompted. You can use “FFFFFFFFFFFF” (12 ‘F’s) instead of the phone's serial number.
  4. The recovery utility should find the phone in recovery mode.
  5. Follow the instructions on screen to start the recovery process.
  6. Once the phone has recovered and rebooted, you can upgrade to the desired version of firmware.

<end>

Comments

Hi Patrick,

Do you have a recovery for latest 7.4.9c firmware please. I got a SPA 504 phone got stuck on SOS recovery mode when it tried to upgrade to 7.4.9(02141644). I had many other 504 phones upgrading with no issues. Not sure what happend on this phone.

Regards

Robert

Cisco Employee

Hi Robert,

It's bundled with the firmware in a zip file on Cisco.com.

Here's a link in case you don't know the location:

http://www.cisco.com/cisco/software/navigator.html?mdfid=282733326&i=rm

Regards,

Patrick

----------

Hi Patrick,

Thats brillaint. Thanks for your help mate. I managed to locate it on my firmware zip file.

Regards

Robert

Hi Patrick,

Actually my phone got stuck in SOS mode when changing the firmware from 7.4.9c to

           7.4.9(02141644). Will i need a recovery tool for this latest firmware (

           7.4.9(02141644)

to fix my phone. PLease advice

Becos I ma getting

Regards

Robert

Hi ,

No Lights are lit when the phone is in SOS mode. The recovery tool is just returning "rECOVERY fAILED: cANNOT FIND THE SPECIFIED DEVICE".

Could you please confirm the Serial number is its MAc Address of the phone. I also tried with FFFFFFFFFFFF. Still the same error message.

I am just stuck now. Please advice. If there is any special recovery file, please provide .

I can email the trace when the tool was running.

Regards

Robert

Beginner

What can I do if my phone is  rebooting continuously.

Power Up -> 3 Led On -> 3 Led Off -> Display backlight on -> Cisco Logo appears -> 3 Led On -> Display Off -> Doing everything again.

PS. Also no packets received from Phone  Ethernet. Just Ethernet Up and Down, Up and Down....

Beginner

I have a spa504g phone that has been unplugged and sitting on a shelf for a long while.  We have been using our uc320 phone system in the meantime which is on the latest firmware.  I tried to plug in the phone and I received the "SOS Phone in Reovery Mode".  I was able to download the latest firmware from the Cisco site at http://software.cisco.com/download/release.html?mdfid=282724650&flowid=5300&softwareid=282463651&release=7.5.4&relind=AVAILABLE&rellifecycle=&reltype=latest.  However, when I tried to run the tool it is asking for an IP number.  I used a network scanner and it wasn't able to find this phone that is in question.  What can I do now?  I would like to get this phone online as soon as possible.

Scott

Beginner

It worked for me but The phone and PC had to be connected to a switch that was also connected to a UC560.  When I just had a switch with only the PC and SPA504 it did not work.

Community Member

I'm having trouble with this part, "When the phone is trying to access the “last upgrade URL”, it will not  be able to handle a recovery request from the PC. Once the phone gives  up, you will be able to successfully use the recovery utility:".  Power dropped on the firmware upgrade the first time I plugged in the phone.  The phone stays at "SOS recovery mode" and does not let me use the recovery tool.

Community Member

When i ran the utility i couldn't find the phone, so I could resolve this problem doing this:

- Using a flat switch (without vlans)

- Using an static ip address

- Enabling a DHCP service in my laptop

- Running the utility

- Follow te steps of the utility

Greetings

Beginner

Hello can you please describe the process how PC founds the phone?

I tried to connect direcly or throught the switch it can not find the phone

Advocate

Read S.O.S Firmware Recovery Protocol Specification

Rate if considered useful.

 

Beginner

Using static ip address, on the phone or where?

Beginner

I tried to use simple switch, blocked firewall, antivirus, software can't find the phone, tried to add router dhcp

software provided says Recovery failed: connot find spesific device

what can i check more?

Can you please provide may be differet software version? 

Advocate

If you:

1. have phone showing S.O.S. Recovery on display

2. connected thru PC via dumb switch or cross-over cable

but the recovery program still can't found the phone, then you should consider the phone is damaged and the lost firmware is not the only problem.

 

Just for sure - the SOS program is asking for phone's serial number not the MAC. Use FFFFFFFFFFFF when in doubt.