cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Welcome to the Cisco Small Business Community

Have a question? Click on a topic board below to get started in the community.

Troubleshooting: SPA525G2 "Upgrade failed: upgrade to less than rev not allowed" or "Upgrade failed: upgrade not allowed, version constraint"

3782
Views
5
Helpful
2
Comments

When upgrading a SPA525G2 from older firmware such as 7.4.4 or 7.5.x [yes, 7.5.x is older than 7.4.6 firmware] to 7.4.6 the upgrade may fail and you may notice messages similar to the following in syslog output [if you enabled debug or syslog]

"SPA525G <MAC address> -- Upgrade failed: upgrade not allowed, version constraint"

"SPA525G <MAC address> -- Upgrade failed: upgrade to less than rev not allowed"



Overcoming this issue is a 3-step process as follows:

  1. upgrade the SPA525G2 to spa525g-P01.bin
    [retrieve file from here:
    https://skydrive.live.com/redir.aspx?cid=d4a0ae1d2799d6ff&resid=D4A0AE1D2799D6FF!268&authkey=DhJHvQC79aI%24 ]
  2. upgrade the SPA525G2 to 7.4.6 or newer, available from Cisco.com

<end>

Comments
ADAM CRISP
Enthusiast

Thanks for this Patrick. I ran into this issue, with our SPA525G2.

We managed to get spa525g-P01.bin onto the unit, however when we tried  spa525g2-P02.bin via the web interface, a "image fails CRC check error" occured. We managed to go straight from spa525g-P01.bin to 7.4.6

Adam

Janus_cisco
Community Member

we got the same