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smallbusiness
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Article ID:5831

Web Interface Not Responding After Firmware Upgrade to Version 1.0.01.18 on RV34x Series Router

Summary

The RV34x series router web interface may not respond after upgrading the firmware to version 1.0.01.18 from 1.0.0.33. This document has been developed to highlight this issue, and to define the steps that needs to be followed in order for the router to be upgraded to the latest firmware in order to resolve this issue.

Version (s) Affected

1.0.01.18

Date Identified

May 30, 2018

Date Resolved

N/A

Products Affected

RV34x Series

Bug ID

CSCvk05937

Issue Description

RV34x series routers, when shipped, are loaded in the factory with firmware version 1.0.0.33. Currently, the latest version of firmware for the platform is 1.0.01.18. When the firmware of a RV34x series router is upgraded from version 1.0.0.33 to version 1.0.01.18, the web interface of the router may stop responding. For more details regarding this issue, click here.

NOTE: Testing has determined that this issue is isolated when firmware is upgraded directly to version 1.0.01.18 from version 1.0.0.33. It is not likely to occur during upgrade of firmware from versions 1.0.01.16 or 1.0.01.17 to version 1.0.01.18.

Cause

It is currently believed that a new feature included in version 1.0.01.18 is causing this issue. The feature allows for enabling or disabling device management per virtual local area network (VLAN) that is defined on the router.

Workaround

For successful firmware upgrade from 1.0.0.33, please perform the following steps.

Step 1: Log in to the web-based utility of the router by entering your Username and Password in the fields provided and then click Log In.

Step 2. Enable remote web access to the router.

NOTE: This step is recommended in case the access to the router from local area network (LAN) fails following firmware upgrade as it has been noticed that VLAN1 "Device Management" is disabled and cannot be edited after successful firmware upgrade from version 1.0.0.33 to 1.0.01.18. Enabling remote web management will provide a temporary option of accessing the router remotely.

To do this, Choose Firewall > Basic Settings

Check the box to enable Remote Web Management

Step 3. Prior to firmware upgrade, it is always best practice to back up the configuration before taking any action.

Choose Administration > Config management

In the Config Management table, save the running configuration file to the startup configuration by choosing Source File Name as Running Configuration and Destination File Name as Startup Configuration. Click Apply.

Copy the startup configuration to your personal computer (PC) by choosing Source File Name as Startup Configuration and Destination File Name as Download to PC.

NOTE: Assuming that the running and startup configuration are the same, you can choose to download either the running configuration or startup configuration to your PC.

In this example, the startup configuration is saved to the PC.

Step 4. Upgrade the firmware of the router to version 1.0.01.17.

NOTE: For more detailed information regarding upgrading firmware on RV34X series routers, click here.

Step 5. Access the router from the graphical user interface (GUI) as in Step 1.

Step 6. Save the Running Configuration to Startup Configuration to save your configuration with the firmware version 1.0.01.17 and click Apply.

Step 7. Upgrade the firmware of the router to version 1.0.01.18.

Step 8. Access the router from the LAN.

 

You should now have upgraded the firmware of the router from version 1.0.0.33 to version 1.0.01.18 and access it successfully.

This Field Notice is to make you aware of this issue and to offer the best possible solution to fix it. If you need any further assistance, please contact Cisco Technical Support.

Comments
joseru
Level 1
Level 1

After selecting the automatic update function available in the RV340 web interface I have lost the possibility to access to it again. After that, I've read this article about jumping from version 1.0.00.33 to versions beyond 1.0.01.18 (too late)

I've tried accessing trough web, SNMP, even to upload original version via TFTP without success. I didn't try serial terminal because I read it's disabled.

I've also tried to revert to previous version rebooting 5 times letting 30 seconds the unit powered on before switching off and on again.

I wouldn't dare to reset it to default because at least at this moment is operative. I'm afraid that after a reset to default the unit becomes a brick.

Any idea to regain web access will be much apreciated...

Thank you in advance

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