Showing results for 
Search instead for 
Did you mean: 


Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.

Beginner firmware issue

I installed the on a couple of SG300-28Ps.  On the Status and Statistics page, the PoE indicators no longer lit. Physically, on the front of the switch, they did still light.  I didn't yet reboot to factory defaults to see if that clears it, because I don't feel like entering the config again this early in the morning. But I am willing to test that, if needbe.

When reverting the image back to (tested) or possibly earlier, the ip default gateway must be re-entered (if it was configured). Even if ip-default gateway x.x.x.x shows up correctly on a 'show run', the switch will not obey it, and on the IPv4 settings page it will report the operational default gateway as blank. This came as a surprise becauset he switch suddenly wouldn't talk to the VPN anymore. Logging onto the switch locally, going to the IPv4 settings, ticking the radio button back on User Defined and typing it back in cleared that up. It appears this cropped up because the syntax for specifying the default gateway changed in 1.3.x but it's still odd that the config shows correctly in console but not in the gui.


I see that Cisco have today released new firmware for the SG300 switches.

So soon after the last release, it’s obviously mainly a bugfix exercise.

Hopefully it will address some of the issues above, and some of my own which include some strange multicast (IGMP snooping) issues which affected UPnP discovery, etc.  Also found that some other configurations got corrupted after upgrading to

Would be good to know if fixes things not mentioned in the release notes

Later edit:

Well - I've tried and despite the claim in the release notes that one of the defects fixed is:

"After the firmware is upgraded from to 1.3.0, the IP default gateway

changes to default route. (CQ146158)"

I am still finding in layer 2 mode that it is still stored as a route:

"ip route /0 metric 1"

When you attempt to reload this config file, you get the error:

Copy failed

Copy: Error in configuration download Line: 102 Command: ip route /0 metric 1"

Strangely, in layer 3 mode, it saves it as a default gateway setting:

"ip default-gateway "  which loads with no errors, despite the fact that the manual states that there is no "default gateway" in the layer 3 mode.

This is the same behaviour as firmware 

Incidentally, I have been told that the performance of the SG300 switches is better if set to layer 3 mode, but only used as layer 2 (i.e. no routing or multiple IP addresses set.)  Anyone got any experience of this?

Certianly it seems that with v1.3 firmware, the only way to avoid an error when reloading a config file is to set the switch to router mode.


Thanks for letting me know about this release, I only checked it out because you mentioned it. I tested the image and can confirm that the PoE status indicators are not fixed (in System Summary area). I'm actually quite suprised that this bug is present on two production releases.  Release was the first good release for these units, and if I remember all was well with the releases after that up until now.  I'm still running out there until the next good one comes out.


No problem Brayton!

I've done a little more testing, and found that the damage done by v1.3.0.59 firmware is not undone by upgrading to v1.3.0.62.  At least as far as the default-gateway error is concerned.

If v1.3.0.59 has been installed you have to revert to an older firmware version (I used v1.2.7.76), then re-upgrade to

Probably the reason that I found switching to layer 3 mode fixed it is that it this effectively sets the switch back to factory default condition. 

Give this a try, and see if it fixes your PoE status issue too.

FIngers crossed


Hi Chris,   I decided to try your procedure, except I used release as my roll back. This was a good release for me. I found the smallest SG300 series switch with the simplest config and did the following. (I took screenshots too just to provide a little proof of this issue to Cisco since I looked through the acknowledged defects list in and there's nothing listed about these indicators).  I do hope the firmware team reads through some of these forums at some point. There's a lot of important "product testing" done here.


Rollback to  (PoE indicators started to work)

Set administrative default gateway (it was erased)

copy run start

Set active image to



Release   (all LEDs correct)  (No PoE indication, also notice extra green LED on the gig uplink ports)

(unplugging PoE device on the FE ports does not cause extra green LED to extinguish)

I've seen this behavior across the board on all SG300 series switches in my environment.




That's disappointing, Braydon.

Looks like Cisco still have some work to do.  I don't use any PoE on Cisco switches so I can't test this one.

One of my concerns was whether Cisco's small business switches were part of the(Linksys) package being handed over to Belkin, in which case the future of firmware development looked very dubious.  I've just found this  which does appear to indicate that we they will remain with Cisco, and hopefully we can expect a proper fix eventually

All the best,



Hi Brayton,

A quick few lines to confirm your diagnosis of the PoE switches' behavior with the latest 2 firmware updates (1.3.x).  I also noticed that the status page no longer displays the PoE amber LEDs and now shows them as green - like it would for a non-PoE variant.  My model is an SG300-10P (used in combination with a couple of regular SG300-10 units).

This worked fine with FW but broke with and is unfortunately not fixed with  I was hoping it would be.

I can't confirm the default admin gateway problem - I'm not sure which setting you are referring to, but I have not experienced any problems accessing the management interface on the correct VLAN.  The switch is set to L3 mode and I use Firefox.

Let me join you in hoping for a timely fix.  The incorrect status page is not a blocking issue as far as I'm concerned, but it's a real shame that it used to work so well and now it doesn't anymore.

Best regards,



Hello Chris,

Cisco has ackowledged this defect and plans to fix it in firmware version(s) 1.5.x.x.   Chances are this will be the next build that comes out.

Kind Regards,



Hello Brayton,

On a bit of a side track... have you also noticed that the Help system is no longer "hosted" in the switch itself, but rather directs you to the relevant information page on the Cisco site?

I find this a regretful evolution: it seems useful to have the information on hand in the switch when you are troubleshooting connection problems - connection problems that would likely prevent you from accessing the Cisco site.

What is your take on this?

Best regards,