cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


1159
Views
0
Helpful
1
Replies
Highlighted
Beginner

6941 phone not on Voice Vlan

I am having a problem with 6941 phones on a SG300.

When connected Smartport assignes the native and tagged voice vlan correctly, however the phone connects to the native vlan.  After running a few tests I have found it only happens when the voice vlan is also the default vlan, though this has only been tested with the default left as VL1.

I can get to the phone on the native vlan, it picks up an address via dhcp, and the Operational VLAN ID is shown as 4095.

Manually configuring the port as a trunk with the native and tagged voice vlans gives the same result.

CDP properties for the ports show the voice vlan as correctly advertised.

This happens on multiple phones/ports.

The 7962 phones on the same switch work as expected.

If I set the voice vlan to be something other than the default vlan 1, a vlan with dhcp available, the phone uses the configured, tagged vlan as expected and the Operational vlan shown on the phone is correct.

The switch is running 1.2.7.76

I have a test setup with a number of 7900 and 6900 series phones running on a SF300 and have tested all phones as working if the voice vlan is not on the default.  I intend to test with the voice vlan as the default shortly to confirm it is not an issue with the specific switch and discover if it occurs on more than just the 6941.

Any ideas?

Everyone's tags (5)
1 REPLY 1
Beginner

6941 phone not on Voice Vlan

Now tested with the voice vlan = default vlan = 1

7931, 7945, 7965, 7975, 9971, 3905, 6921 & 6961 all work

6941 & 6945 have the problem, the latter not unexpected as it is the former with GE intefaces.