cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
730
Views
0
Helpful
12
Replies

Cisco CBS250-8T-D and "In pause frames"

johnKr
Beginner
Beginner

Hi

 

I just got this switch and really like it, but now I see this "In pause frame" on port 1 where my Ruckus Accesspoint is plugged in.

I tried to refresh and it occur every minut or so, see attaced pictures. If I check out the "Trafic error information" there apperently are no packet lost or any error at all, see picture.

 

Last nigt I disabled all trafic on my Accesspoit and confirmed it in the accesspoint GUI, it was flatlining on traffic...but, the error was still occuring, like all the time. It makes no sense that the port is overloading with no traffic on it?? I have tried to enable flow control on the port,  disable it, and set it to auto negotiate, no luck.

 

Any advice from you guys will be appriciated, thanks in advance

 

 

12 Replies 12

Jitendra Kumar
Rising star
Rising star

Hi,

 

This due to the flow control enable.

 

• Frame Check Sequence (FCS) Errors - Received frames that failed the CRC (cyclic redundancy checks).
• Single Collision Frames- Frames that involved in a single collision, but successfully transmitted.
• Late Collisions - Collisions that have been detected after the first 512 bits of data.
• Excessive Collisions - Transmissions rejected due to excessive collisions.
• Oversize Packets - Packets greater than 2000 octets received.
• Internal MAC Receive Errors - Frames rejected because of receiver errors.
• Pause Frames Received - Received flow control pause frames. This field is only supported XG ports. When the port
speed is 1 G, the received pause frames counter is not operational.
• Pause Frames Transmitted - Number of pause frames transmitted.

 

 

Thanks,
Jitendra

Well...that was my guess too, but flow control are disabled on all ports. I have tried to disable both my radios on the AP, 2,4 and 5Ghz, then there is NO traffic from the AP to the switch...but the pause frames still comes in

 flow  control  should be negotiated both TX/RX

 

 this also may reason for not using the manual speed command both devices.

Thanks,
Jitendra

Thanks, but I dont get why the switch gets these pause frames when der are no traffic on the port from the Access point...pause frames are sent to the network if a device cant deliver or recieve data fast enough, but there is no traffic on the port, when it happens...or in other words, they occur with traffic on the port, and no traffic on the port, they just counting up and up

does not matter if you have traffic or not if the device is connected with the port and is powered on then the switch will try to negotiate the RX/TX and speed as well to establish the connection if it's unable to negotiate the pause frames will generate.

 

 

need to check port negotiation RX/TX and speed also.

 

The best practice is that you have to configure speed manually on both the devices

Thanks,
Jitendra

Thanks, but its weird that its only my AP that do this....

Well...I just set the speed manually and disabled auto negotiate, still the same..... 

 ruckus article provided a Solution for that.

Need to disable flow control on the AP not auto-negotiation how ever you switch side should be the same config as on the AP.

 

https://docs.ruckuswireless.com/fastiron/08.0.60/fastiron-08060-commandref/GUID-25AC9BBB-0AAD-4F0E-9101-4F8CFB06755F.html

flow-control

Enables or disables flow control and flow control negotiation, and advertises flow control.

Syntax

flow-control [ both | generate-only | honor-only ]
no flow-control [ both | generate-only | honor-only ]

Command Default

Flow control is enabled.

Parameters

both

Flow control in PAUSE generation and honoring mode.

generate-only

Flow control in PAUSE generation only mode.

honor-only Flow control in PAUSE honoring (Default) mode.

Modes

Global configuration mode

Interface configuration mode

Usage Guidelines

The no form of this command disables flow control.

On ICX 7750 devices the default packet-forwarding method is cut-through, in which port flow control (IEEE 802.3x) is not supported but priority-based flow control (PFC) is supported. You can configure the store-and- forward command in global configuration mode to enable the store-and-forward method for packet-forwarding.

The recommended flow control settings when the ICX 7750 switch is set for store-and-forward, are listed below.

Symmetrical flow control Port-based flow control Configuration commands Cut-through (Jumbo enabled) Store-and-Forward (Jumbo Enabled)
disabledhonor-only# flow-control honor-onlyNot RecommendedOK
no flow-control-both#no flow-control bothOKOK
enabledno flow-control-both

#symmetrical-flow-control enable

# no flow-control both

OKOK
honor-only

# symmetrical-flow-control enable

#flow-control honor-only

Not RecommendedOK
generate-only

# symmetrical-flow-control enable

# flow-control generate-only

OKOK
both

# symmetrical-flow-control enable

#flow-control both

Not RecommendedOK

By default, when flow control is enabled globally and auto-negotiation is on, flow control is enabled and advertised on 10/100/1000M ports. If auto-negotiation is off or if the port speed was configured manually, flow control is neither negotiated with nor advertised to the peer.

NOTE
Enabling only port auto-negotiation does not enable flow control negotiation. You must use the flow-control neg-on command to enable flow-control negotiation.

Examples

The following example disables flow control globally.

device(config)#no flow-control

The following example enables flow control on ethernet ports 0/1/11 to 0/1/15.

device(config)#interface ethernet 0/1/11 to 0/1/15
device(config-mif-0/1/11-0/1/15)#flow-control

The following example disables flow control on ethernet port 1/1/9.

device(config)# interface ethernet 1/1/9
device(config-if-e1000-1/1/9)no flow-control

History

Release version Command history
8.0.20This command was modified. Enabling only auto-negotiation does not enable flow-control negotiation.

 

Thanks,
Jitendra

Thanks for you hard work finding this, but I´m not sure how to do this, its an R310 Accesspoint, this looks like way to advanced for this little AP....its not connected to a controller, it an "Unleashed" accesspoint (Standalone) and I managed it with the web gui

Martin Aleksandrov
Cisco Employee
Cisco Employee

Hi johnKr,

 

Can you pls execute the command show interfaces counters gix/x/x on the CBS250 for that given port and see what's the values on the Received Pause Frames and Transmitted Pause Frames. My assumption in your case is that the Ruckus AP cannot process information as fast as the switch is sending it, then the AP is allowed to send a PAUSE frame to the switch. The switch when receive that PAUSE frame is expected to stop transmitting and should hold (queue) traffic that needs to be sent to the AP for a brief period of time. 

 

Did you experience any traffic loss or connectivity issues with the AP?

 

Thanks

Not that much familiar with the switch to do that, i only use the GUI .  Yeah it makes sense what you write, but shouldnt it stop sending Pause frames when there is low or no data transmittet or recieved?

johnKr
Beginner
Beginner

Well...I gave up, I bought a new AP, I REALLY hope that it solves the problem...but if not, Ill at least get a newer WiFi6 AP

Thanks for all your comments and solutions, I really appreciate them all

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers