cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


678
Views
0
Helpful
3
Replies
nextontext07917
Beginner

Cisco sg-250 inter-vlan. Help please

Hello! I have 2 computers, 2 vlan, and 1 cisco sg-250

I do the initial setup, create vlan 101, interface 192.168.101.1 255.255.255.0
Then I set up two computers


PC1 is connected to GigabitEthernet11

IP 192.168.101.2
MASK 255.255.255.0
Gateway 192.168.101.1

 

//

 

PC2 is connected to GigabitEthernet14
IP 192.168.101.3
MASK 255.255.255.0
Gateway 192.168.101.1

PC1 has a shared folder, and now I can access it from PC2. Everything works!

 

//

 

Next, I create vlan 104, interface 192.168.104.1 255.255.255.0
I assign the GigabitEthernet14 port to this vlan

Changing network settings on PC2
IP 192.168.104.3
MASK 255.255.255.0
Gateway 192.168.104.1

I try to open a shared folder on PC1 and nothing comes out.
Ping 192.168.104.1 - Success
Ping 192.168.101.1 - Success
Ping 192.168.101.2 - Failure

//

 

#show running-config

switchb118c2#show running-config
config-file-header
switchb118c2
v2.5.5.47 / RTESLA2.5.5_930_364_286
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
!
unit-type-control-start
unit-type unit 1 network gi uplink none
unit-type-control-end
!
vlan database
vlan 101,104
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone
voice vlan oui-table add 00036b Cisco_phone
voice vlan oui-table add 00096e Avaya
voice vlan oui-table add 000fe2 H3C_Aolynk
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone
voice vlan oui-table add 00e075 Polycom/Veritel_phone
voice vlan oui-table add 00e0bb 3Com_phone
bonjour interface range vlan 1
hostname switchb118c2
username cisco password encrypted 78143518e5eqwcdd9da79ae58955f96b5f40040d privilege 15
ip ssh server
!
interface vlan 1
 ip address 192.168.1.254 255.255.255.0
 no ip address dhcp
!
interface vlan 101
 name server
 ip address 192.168.101.1 255.255.255.0
!
interface vlan 104
 ip address 192.168.104.1 255.255.255.0
!
interface GigabitEthernet11
 switchport access vlan 101
 switchport general pvid 101
 switchport trunk native vlan 101
!
interface GigabitEthernet14
 switchport access vlan 104
 switchport general pvid 104
 switchport trunk native vlan 104
!
exit

# show ip route

switchb118c2#show ip route
Maximum Parallel Paths: 1 (1 after reset)
IP Forwarding: enabled
Codes: > - best, C - connected, S - static

C   192.168.101.0/24 is directly connected, vlan 101
C   192.168.104.0/24 is directly connected, vlan 104

 

What am I doing wrong??? Why can't I get to the neighboring vlan 101 from vlan 104? Please help me figure it out.

 

 

3 REPLIES 3
Jaderson Pessoa
VIP Collaborator

Hello, i think the problem isn't your network. Its seems to be pc's firewall. Have you checked it?

Jaderson Pessoa
*** Rate All Helpful Responses ***
Martin Aleksandrov
Cisco Employee

Hi there,

 

Double-check if you have enabled Inter-VLAN routing IP Configuration-->IPv4 Interface-->IPv4 Routing -->Enable. The PC's firewall as Pessoa mentioned might be another reason for the inter-VLAN connectivity issues.

 

Regards,

Martin

Martin, hello! Thanks for the answer.
I checked it again. Through the GUI, IP Configuration -> IPv4 Interface -> IPv4 Routing -> Enable, the checkbox is on.

Honestly, i don't understand where Firewall has to do with it. If everything works fine while in the same VLAN? As soon as I put the ports in different VLANs, the shared folder on PC1 becomes inaccessible.