cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


2740
Views
20
Helpful
13
Replies
Beginner

Cisco SG300 trunk with 3com 4800G

Our company currently have a 3com 2816 connected to a 3com 4800G through a trunk.  The 4800G connects to the PBX and to the ip phones/computers. We are currently using vlan1 (192.168.100.n) for data and vlan 3 (192.168.101.n) for voice , Ip addresses are being issued by a DHCP server. Each user has an assigned IP phone and it has an ethernet port that connects to each computer. This setup has been working properly until I purchased an SG300 and replaced the 3com 2816.

The ip phone is showing a bad gateway and the PC are getting an ip address of 192.168.101 (which is for voice). Theoretically it should work, but what is weird is, it seems the SG300 trunking with the 3com 4800G is not working. Is it possible that it is on ISL mode rather than dot1q?

I also saw its running RSTP, should I changed it to classic STP?

How do I fix this or what troubleshooting should i do?

The SG300 is configured as a layer 2 switch. Configuration for the trunk below:

interface gigabitethernet27

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 3-4

macro description switch

macro auto smartport type switch $native_vlan 1

Thanks,

Joe

Everyone's tags (3)
13 REPLIES 13
Advocate

Cisco SG300 trunk with 3com 4800G

Hi Jo, the SX300 supports only 802.1q, it does not support any Cisco proprietary protocol except CDP.

The gi27 has a macro negotiated. What I don't see is your vlan configuration. From this output, I know vlan 1 is your native and you have a vlan 3 and 4 for something.

Can you give any indication of what your LAN consists of in terms of native vlan and additional vlans and any indication of how this 4800G switch port is configured?

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Beginner

Cisco SG300 trunk with 3com 4800G

Hi Tom,

Thank you for your reply. Here is the vlan information from the SG300: vlan 4 is for the guest network used by our wireless AP.

vlan database

vlan 3-4

exit

voice vlan id 3

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

Below is the 4800G config and the port that connects to the 2816 right now since its having problems connecting to the cisco SG300

#

vlan 1

description datavlan

ip-subnet-vlan 0 ip 192.168.100.205 255.255.255.0

igmp-snooping enable

#

vlan 2

#

vlan 3

description voicevlan

#

vlan 4 to 4094

#

radius scheme system

server-type extended

primary authentication 127.0.0.1 1645

primary accounting 127.0.0.1 1646

user-name-format without-domain

#

#

interface GigabitEthernet1/0/46

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

Actually all of the ports of the 4800G has this configuration.

Thanks,

-Joe

Advocate

Cisco SG300 trunk with 3com 4800G

Jojo, I don't understand the 4800G switch config so well, but what I see is bolded below. If permitting a vlan, it looks like your vlan 1 is tagged. So it would appear to me the SX300 is 1u, 3t,4t while the 4800G is 1t,3t. Does VLAN 4 exist on the 4800G? If so, is it the native vlan? What is the native vlan for the 4800G?

interface GigabitEthernet1/0/46

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Beginner

Cisco SG300 trunk with 3com 4800G

Hi Tom,

I also dont understand the 4800G configuration and I can't pull out the 2816 configuration. Anyway, the 4800G does permit the vlan 4, it's not on this config but the newer one has it. Native vlan for the 4800G is vlan 1

Thanks,

Jojo

Highlighted
Beginner

Cisco SG300 trunk with 3com 4800G

Does this device support CLI?

Beginner

Cisco SG300 trunk with 3com 4800G

Hi Isaac,

I think the 4800G support CLI , however I dont have access to it since its being serviced by an external IT vendor. I'll check with them if they will grant me temporary access.

Participant

Cisco SG300 trunk with 3com 4800G

it looks like your vlan1 and 3 are tagged on the 3c switch, and vlan1 is untagged on the sg300.  set the uplink port on the sg300 to General or Trunk, and make vlan 1 and 3 tagged.

Or set the 3com switch to trunk / 1 untagged, and 3 and 4 tagged.

Basically both sides of the uplink (sg300 and 3com) need to match.

You can test by setting one port on the sg300 access/untagged vlan1, and another access/untagged vlan3.  plug a pc into each access port, and verify you get the correct IP address on each vlan.

if that doesn't work, you can set 2 access ports on the 3com switch to vlan1 and 3 untagged.  use seperate uplinks for each vlan.  if that still doesn't work, there may be an issue with the dhcp server, or dhcp relay.

The sg300 has a full function CLI with the later firmwares, the first version 1.0.0.27  did not.

You need to go into Security > TCP/UDP Services page to enable telnet/ssh, or use a console cable.

admin guide has all the features and commands for the gui. 

http://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/78-19308-01.pdf

CLI admin guide:

http://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/CLI_300_1_2_5.pdf

tag this post if it helps.

Dan

Beginner

Cisco SG300 trunk with 3com 4800G

Hi Daniel,

I'll forward your suggestion to our external vendor.

Thanks,

Jojo

Beginner

Cisco SG300 trunk with 3com 4800G

Hi Dan,

I just verified this morning that, 3com 4800 vlan 1 / data is untagged, vlan 3 /voice and vlan 4/ guest network is tagged.Cisco SG300 vlan 1 / data is untagged, vlan 3/voice and vlan 4/guest network is tagged. Their vlan is then the same.

Complete configuration below for the SG300

config-file-header

DGC-CoreSW

v1.2.7.76 / R750_NIK_1_2_584_002

CLI v1.0

file SSD indicator encrypted

@

ssd-control-start

ssd config

ssd file passphrase control unrestricted

no ssd file integrity control

ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0

!

vlan database

vlan 3-4

exit

voice vlan id 3

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

hostname DGC-CoreSW

no passwords complexity enable

username admin password encrypted d033e22ae348aeb5660fc2140aec35850c4da997 privilege 15

username cisco password encrypted e8996464ca23106d9008f97d60c3892e0e133f01 privilege 15

snmp-server location "DGC Corp MDF"

snmp-server contact "Southwest Networks"

!

interface vlan 1

ip address 192.168.100.207 255.255.255.0

no ip address dhcp

!

interface vlan 3

name Voice

!

interface vlan 4

name Guest

!

interface gigabitethernet1

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet2

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 3

switchport trunk native vlan 4

macro description ap

switchport default-vlan tagged

macro auto smartport type ap $native_vlan 4

!

interface gigabitethernet3

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet4

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 4

switchport trunk native vlan 3

macro description switch

switchport default-vlan tagged

macro auto smartport type switch $native_vlan 3

!

interface gigabitethernet5

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet6

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet7

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet8

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet9

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet10

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet11

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet12

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet13

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet14

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet15

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet16

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 4

switchport trunk native vlan 3

macro description switch

switchport default-vlan tagged

macro auto smartport type switch $native_vlan 3

!

interface gigabitethernet17

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet18

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet19

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet20

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet21

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet22

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet23

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet24

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet25

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet26

storm-control broadcast enable

storm-control broadcast level 10

port security max 10

port security mode max-addresses

port security discard trap 60

spanning-tree portfast

macro description server

macro auto smartport type server $max_hosts 10 $native_vlan 1

!

interface gigabitethernet27

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 3-4

macro description switch

macro auto smartport type switch $native_vlan 1

!

interface gigabitethernet28

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 3-4

macro description switch

macro auto smartport type switch $native_vlan 1

!

ip default-gateway 192.168.100.254

Complete configuration for 3com 4800 below:

[4800G]display current-configuration

#

version 5.20 Release 2202P15, Release 2202P15

#

sysname 4800G

#

irf mac-address persistent timer

irf auto-update enable

undo irf link-delay

#

domain default enable system

#

telnet server enable

#

undo cluster enable

#

igmp-snooping

#

vlan 1

description datavlan

ip-subnet-vlan 0 ip 192.168.100.205 255.255.255.0

igmp-snooping enable

#

vlan 2

#

vlan 3

description voicevlan

#

vlan 4 to 4094

#

radius scheme system

server-type extended

primary authentication 127.0.0.1 1645

primary accounting 127.0.0.1 1646

user-name-format without-domain

#

domain system

access-limit disable

state active

idle-cut disable

self-service-url disable

#

user-group system

#

local-user admin

authorization-attribute level 3

service-type telnet terminal

local-user manager

password simple manager

authorization-attribute level 2

service-type telnet terminal

local-user monitor

password simple monitor

authorization-attribute level 1

service-type telnet terminal

local-user swnet

authorization-attribute level 3

service-type telnet

#

interface NULL0

#

interface Vlan-interface1

ip address 192.168.100.205 255.255.255.0

#

interface Vlan-interface3

ip address 192.168.101.205 255.255.255.0

#

interface GigabitEthernet1/0/1

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/2

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/3

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/4

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/5

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/6

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/7

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/8

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/9

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/10

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/11

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/12

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/13

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/14

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/15

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/16

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/17

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/18

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/19

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/20

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/21

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/22

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/23

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/24

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/25

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/26

port link-type trunk

port trunk permit vlan 1 3

port trunk pvid vlan 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/27

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/28

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/29

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/30

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/31

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/32

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/33

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/34

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/35

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/36

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/37

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/38

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/39

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/40

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/41

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/42

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/43

port link-type trunk

port trunk permit vlan 1 3

undo voice vlan mode auto

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/44

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/45

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/46

port link-type trunk

port trunk permit vlan 1 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/47

port access vlan 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/48

port access vlan 3

broadcast-suppression pps 3000

undo jumboframe enable

poe enable

stp edged-port enable

#

interface GigabitEthernet1/0/49

shutdown

broadcast-suppression pps 3000

undo jumboframe enable

stp edged-port enable

#

interface GigabitEthernet1/0/50

shutdown

broadcast-suppression pps 3000

undo jumboframe enable

stp edged-port enable

#

interface GigabitEthernet1/0/51

shutdown

broadcast-suppression pps 3000

undo jumboframe enable

stp edged-port enable

#

interface GigabitEthernet1/0/52

shutdown

broadcast-suppression pps 3000

undo jumboframe enable

stp edged-port enable

#

ip route-static 0.0.0.0 0.0.0.0 192.168.100.254

#

snmp-agent

snmp-agent local-engineid 8000002B034001C689AC41

snmp-agent community read public

snmp-agent community write private

snmp-agent sys-info version all

#

user-interface aux 0

authentication-mode scheme

user-interface aux 1 8

user-interface vty 0 4

authentication-mode scheme

Port 46 is the uplink port on the 4800 and port 27 is on the Cisco SG300.

Right now

Thanks,

Jojo

Advocate

Re: Cisco SG300 trunk with 3com 4800G

!

interface gigabitethernet16

spanning-tree link-type point-to-point   <- point to point should be a STP link negotiation to a switch

switchport trunk allowed vlan add 4  <- VLAN 4 is tagged

switchport trunk native vlan 3  <- vlan 3 is untagged

macro description switch

switchport default-vlan tagged <- Vlan 1 is tagged

macro auto smartport type switch $native_vlan 3

Your other point to point ports look like this- which is accurate to your description.

interface gigabitethernet27

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 3-4

macro description switch

macro auto smartport type switch $native_vlan 1

!

interface gigabitethernet28

spanning-tree link-type point-to-point

switchport trunk allowed vlan add 3-4

macro description switch

macro auto smartport type switch $native_vlan 1

This can be your problem

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Beginner

Cisco SG300 trunk with 3com 4800G

Hi Tom,

The Sg300 port 16 connects to our ASA Firewal port 3:

!

interface Ethernet0/3

nameif SWNET

security-level 100

ip address 192.168.101.254 255.255.255.0

!

How do i fix the issue?

Advocate

Cisco SG300 trunk with 3com 4800G

The macro of the SX300 configure those settings on the switch port 16 based off the advertisements from the ASA. Can you verify the ASA native vlan is 1 and the additional vlans are tagged?

It looks like the native vlan of the ASA is vlan 3, hence the switch macro configured the port this way.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Beginner

Cisco SG300 trunk with 3com 4800G

Hi Tom,

I'm not familiar with the Cisco ASA yet, but when I made a search for the word "vlan" on the config file nothing comes up.

Thanks,

Jojo