cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


856
Views
0
Helpful
1
Replies
Highlighted
Beginner

Cisco Switch - Unify VoIP - LLDP - VLAN

Shortly we introduced a new Unify VoIP PBX. We generated a Voice Vlan on our SG300 and SG500 Switches (Vlan 100 tagged).

Now if we put a VoIP system telephone in an unconfigured port on our switch the port configures itself to vlan 1 untagged and vlan 100 tagged which is right at this moment. Telephone and switch communicate via LLDP-MED and so the configuration is very easy for us. This is the constellation in which we have no problems.

No we have to put some computers behind the telephone (integrated switch) because there aren't enough sockets in the room. Now we have to configure the switchports to be Vlan 4 untagged and Vlan 100 tagged. After the first initialization of the telephone we configure the switchports by hand. Everything is working fine now. But after some time the telephone and the switch communicate again and the port is resetted to vlan 1 untagged and vlan 100 tagged. I think this is because the default vlan on the switch is 1. How do I configure this right to solve my problem? Default Vlan can't be changed and the Untagged Vlan on the workstations differ. It is not every time 4. What stays every time is the Voice Vlan 100.

Some lines from the config what we have done so far:

[code]
port jumbo-frame
vlan database
vlan 2-7,100
exit
voice vlan id 100
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________

interface gigabitethernet1/1
 switchport trunk native vlan 4
!
interface gigabitethernet1/2
 storm-control broadcast enable
 storm-control broadcast level 10
 storm-control include-multicast
 port security max 10
 port security mode max-addresses
 port security discard trap 60
 spanning-tree portfast
 switchport trunk allowed vlan add 100
 switchport trunk native vlan 4
 macro description ip_phone
 !next command is internal.
 macro auto smartport dynamic_type ip_phone
!
interface gigabitethernet1/3
 storm-control broadcast enable
 storm-control broadcast level 10
 storm-control include-multicast
 port security max 10
 port security mode max-addresses
 port security discard trap 60
 spanning-tree portfast
 switchport trunk allowed vlan add 100
 switchport trunk native vlan 4
 macro description ip_phone
 !next command is internal.
 macro auto smartport dynamic_type ip_phone
[/code]

Is the only possibility to solve this to configure the Vlan by hand on the telephone and to switch off LLDP-MED? Or did I miss something?

1 REPLY 1
Highlighted
Beginner

It looks like you are using the smartport macros.  You should check the macros to see what is defined as the native vlan in the macro settings.