cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


371
Views
5
Helpful
3
Replies
o0oinsomniao0o
Beginner

configure Port settings

Hello, i use SG300-10. I need OID to change 1000M in 100M (Configure Port settings)

2 ACCEPTED SOLUTIONS

Accepted Solutions
Aleksandra Dargiel
Cisco Employee

Hi,

Please try .1.3.6.1.4.1.9.6.1.101.43.1.1.15

Regards,

Aleksandra

View solution in original post

Hello Aleksandra

yes, that's the correct interface speed table, for SG300-10 switch, it could look like this by default:

CISCOSB-rlInterfaces::swIfSpeedAdminMode.49 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.50 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.51 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.52 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.53 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.54 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.55 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.56 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.57 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.58 = INTEGER: 1000000000

But to set speed for example on port GigabitEthernet 5 to 100M, you have to perform two commands:

snmpset -v 2c -c RWCommunitySecret X.X.X.X CISCOSB-rlInterfaces::swIfSpeedAdminMode.53 i '100000000'
snmpset -v 2c -c RWCommunitySecret X.X.X.X CISCOSB-rlInterfaces::swIfSpeedDuplexAutoNegotiation.53 i '2'

The first one sets the speed to 100M, in reality option "speed 100" will be appended to running config for interface GigabitEthernet 5, but nothing happen in reality - port will still operate at negotiated speed 1000M.

In order to force 100M speed, you have to disable negotiation for that port - that's the second command - option "no negotiation" will be appended to to running config for interface GigabitEthernet 5. Value '2' means "Disable". To enable negotiation back on, perform same command with '1' at the end ('1' means "Enable").

View solution in original post

3 REPLIES 3
Aleksandra Dargiel
Cisco Employee

Hi,

Please try .1.3.6.1.4.1.9.6.1.101.43.1.1.15

Regards,

Aleksandra

View solution in original post

Hello Aleksandra

yes, that's the correct interface speed table, for SG300-10 switch, it could look like this by default:

CISCOSB-rlInterfaces::swIfSpeedAdminMode.49 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.50 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.51 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.52 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.53 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.54 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.55 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.56 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.57 = INTEGER: 1000000000
CISCOSB-rlInterfaces::swIfSpeedAdminMode.58 = INTEGER: 1000000000

But to set speed for example on port GigabitEthernet 5 to 100M, you have to perform two commands:

snmpset -v 2c -c RWCommunitySecret X.X.X.X CISCOSB-rlInterfaces::swIfSpeedAdminMode.53 i '100000000'
snmpset -v 2c -c RWCommunitySecret X.X.X.X CISCOSB-rlInterfaces::swIfSpeedDuplexAutoNegotiation.53 i '2'

The first one sets the speed to 100M, in reality option "speed 100" will be appended to running config for interface GigabitEthernet 5, but nothing happen in reality - port will still operate at negotiated speed 1000M.

In order to force 100M speed, you have to disable negotiation for that port - that's the second command - option "no negotiation" will be appended to to running config for interface GigabitEthernet 5. Value '2' means "Disable". To enable negotiation back on, perform same command with '1' at the end ('1' means "Enable").

View solution in original post

Hi,

Thank you verry much.