Showing results for 
Search instead for 
Did you mean: 

Configure trunk port between 2 SG500 switches


Hi all,

I'm trying to do what seems to be a simple task but cannot get it to work.  I've very familiar with the Cisco commands on 2900 all the way up to 6500 series switches.  The SG500 has me stumped.  I have 3 switches, sw1, sw2, sw3.  sw1 and sw2 are stacked.  sw3 is standalone and in a different part of the building, maybe 25ft away.  All I want to do is set up a trunk port between the stack and the standalone.  In going by past experience, I would set the port as :

- switchport mode trunk

- switchport trunk allowed vlan 2,3,4

The SG makes me specify tagged or untagged - which is fine.  So any vlan I want to move across the trunk i tag, obviously.  I do everything as I've done for years and it doesn't work.  VLAN1 is untagged, all VLANs I want to flow are allowed and tagged. 

I'm quickly realizing I should have bucked up and just bought what I'm used to but I didn't have a choice in the matter.

Any help would be great!


2 Replies 2

Tom Watts

Hi Shawn, something is the matter if the switch is asking you for tagged or untagged. The only reason it should be requesting a tag or untag statement is from a general port mode.

The command syntax for the function is exactly the same as an IOS switch

switchport mode trunk

switchport trunk allowed vlan add 2,3,4

Just like a Catalyst, if you use switchport trunk allowed vlan x,x,x it won't take the command as insufficient privilege or whatever the error it gives, suffice it say it doesn't really do anything without the add(or remove).

Please mark answered for helpful posts

-Tom Please mark answered for helpful posts


I also noticed a difference between the language and needs of my SG500 vs my Catalyst switches.  I agree...what used to work doesn't with these. 

I was replacing an older 100mb switch with a gigabit/PoE switch.  I thought I just needed to trunk my uplink port and add "access vlan xxx".  That's what I had on the old switch and it worked like a charm.  No go on my SG500.  I fought with the web-gui and the language used there as well.

Toms post was helpful and worked like a charm.

Sorry to resurrect an old post, but I wanted to confirm what sclarkson79 was experiencing and thank Tom Watts as well.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: