cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


4562
Views
0
Helpful
6
Replies
netguyz08
Beginner

Configuring an ESW-520-48P for VoIP/RingCentral

I am looking for a Best Practices or a few places to pay attention to in the Cisco ESW-520-48P switch I have. My VoIP solution is RingCentral, and while they are Cisco phones, I've been hestitant to setup VLANs etc. the way I am used to. Plus setting up Auto QoS seems different than what I am used to with a 3750 switch.

Right now I've left the Smartports Wizard alone, and none of the ports are configured. There are no VLANs or QoS on the LAN currently.

What I was running into were calls cutting out where one side wouldn't hear the other anymore, but the call would remain connected. However, this has happened in this small 15 person office, when there is only one employee here after hours, talking on the phone. There isn't any heavy network traffic, because I have network monitoring showing me low usage (no streaming music, videos, or anything else).

This switch has a Gb connection to a Linksys SR2024 (the server switch), which is also set at Factory Defaults. I mention that because I recently bypassed the ESW-520-48P, and plugged one phone into that switch and the RingCentral phone worked fine for outside calls.

Is there something besides QoS that I should look at in the ESW-520 switch that might be causing a checkpoint of some sort, or interrupting VoIP traffic that I need to configure or disable?

And are there any Best Practices or scenario guides for this switch? I found the Admin Guide, but it really just explains every option in the GUI for the switch. And it seems all of my CCNA training isn't helping with going in and quickly troubleshooting this switch besides knowing that something in it could be hanging it up.. let me know.

6 REPLIES 6
netguyz08
Beginner

Here is a copy of the running-config:

no spanning-tree
vlan database
vlan 100
exit
interface vlan 100
name Cisco-Voice
exit
interface vlan 1
ip address 192.168.1.246 255.255.255.0
exit
ip default-gateway 192.168.1.2
qos advanced
wrr-queue cos-map 4 0
wrr-queue cos-map 4 1
wrr-queue cos-map 3 2
wrr-queue cos-map 1 5
wrr-queue cos-map 2 6
wrr-queue cos-map 2 7
qos map dscp-queue 0 to 4
qos map dscp-queue 1 to 4
qos map dscp-queue 2 to 4
qos map dscp-queue 4 to 4
qos map dscp-queue 5 to 4
qos map dscp-queue 6 to 4
qos map dscp-queue 7 to 4
qos map dscp-queue 8 to 4
qos map dscp-queue 9 to 4
qos map dscp-queue 10 to 4
qos map dscp-queue 12 to 4
qos map dscp-queue 13 to 4
qos map dscp-queue 14 to 4
qos map dscp-queue 15 to 4
qos map dscp-queue 16 to 3
qos map dscp-queue 17 to 3
qos map dscp-queue 18 to 3
qos map dscp-queue 20 to 3
qos map dscp-queue 21 to 3
qos map dscp-queue 22 to 3
qos map dscp-queue 23 to 3
qos map dscp-queue 40 to 1
qos map dscp-queue 41 to 1
qos map dscp-queue 42 to 1
qos map dscp-queue 44 to 1
qos map dscp-queue 45 to 1
qos map dscp-queue 46 to 1
qos map dscp-queue 47 to 1
qos map dscp-queue 48 to 2
qos map dscp-queue 49 to 2
qos map dscp-queue 50 to 2
qos map dscp-queue 52 to 2
qos map dscp-queue 53 to 2
qos map dscp-queue 54 to 2
qos map dscp-queue 55 to 2
qos map dscp-queue 56 to 2
qos map dscp-queue 57 to 2
qos map dscp-queue 58 to 2
qos map dscp-queue 60 to 2
qos map dscp-queue 61 to 2
qos map dscp-queue 62 to 2
qos map dscp-queue 63 to 2
qos map policed-dscp 18 to 0
qos map policed-dscp 24 to 0
qos map policed-dscp 26 to 0
qos map policed-dscp 34 to 0
qos map policed-dscp 40 to 0
qos map policed-dscp 46 to 0
ip access-list 2140
permit any any any
exit
ip access-list 2141
permit any any any dscp 46
permit any any any dscp 40
exit
ip access-list 2142
permit any any any dscp 24
permit any any any dscp 26
exit
ip access-list 2146
permit any any any
exit
mac access-list nonip
permit any any ethtype 806
permit any any ethtype 836
exit
class-map general-class match-any
match access-group 2140
exit
class-map general-switch
match access-group 2140
exit
class-map general-router
match access-group 2140
exit
class-map VoIP-data-class
match access-group 2141
exit
class-map VoIP-Control-class
match access-group 2142
exit
class-map general-VoIP
match access-group 2140
exit
class-map general-nonip
match access-group 2140
exit
class-map video-surveillance-class
match access-group 2146
exit
class-map nonip-class
match access-group nonip
exit
policy-map general-map
class general-class
set dscp 7
police 30000 80000 exceed-action policed-dscp-transmit
exit
exit
policy-map switch-map
class general-switch
exit
exit
policy-map router-map
class general-router
exit
exit
policy-map voice-map
class VoIP-data-class
set dscp 46
police 3200 8000 exceed-action policed-dscp-transmit
exit
class VoIP-Control-class
set dscp 26
police 640 8000 exceed-action policed-dscp-transmit
exit
class general-VoIP
set dscp 7
police 30000 800000 exceed-action policed-dscp-transmit
exit
exit
policy-map video-surveillance-map
class video-surveillance-class
set dscp 40
police 50000 800000 exceed-action policed-dscp-transmit
exit
exit
policy-map guest-map
class general-nonip
set dscp 8
police 30000 800000 exceed-action drop
exit
class nonip-class
exit
exit
priority-queue out num-of-queues fastethernet 0
priority-queue out num-of-queues gigabitethernet 0
username ciscoadmin password 6ab8ca97f6317ec75418819e0fe94b48 level 15 encrypted
snmp-server set rlSmartPortsTable ifIndex 1 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 2 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 3 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 4 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 5 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 6 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 7 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 8 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 9 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 10 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 11 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 12 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 13 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 14 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 15 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 16 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 17 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 18 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 19 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 20 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 21 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 22 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 23 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 24 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 25 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 26 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 27 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 28 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 29 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 30 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 31 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 32 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 33 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 34 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 35 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 36 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 37 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 38 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 39 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 40 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 41 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 42 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 43 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 44 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 45 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 46 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 47 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 48 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 49 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 50 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 51 rlSmartPortsMacro Other
snmp-server set rlSmartPortsTable ifIndex 52 rlSmartPortsMacro Other

David Carr
Frequent Contributor

Netguyz,


The esw 500 series switch was designed especially for voip deployment and combining the switches smart port capabilities with the uc 500 series.


If your using CDP to provision your phones, I would go into the smartports and make sure the ports your plugging into are setup to pc/phone mode.


This will apply qos, port security, and the vlan tag to the phone automatically.  Much like yourself, I like doing things manually to verify exactly what is being setup, but the esw smartports work marvelously.

Well that is where I hesitate.. because there is no UC500 series device controlling these phones on the LAN with the switch. RingCentral does hosted VoIP, so I imagine it is some Cisco device on their end managing the phones. I can just apply the config anyway and see what happens, but I wanted to see what other options I had.

Hi netguyz

Yep David is correct , basically the ESWon a UC500 is setup to control  advanced QOS when a UC500 call control appliance is in place.

In your case , i'm thinking;

1.  RingCentral may have modified the phones DSCP settings, but by default I am having trouble thinking of a phone that doesn't use Layer 3 QOS in some way.

2.  PC's in general don't mark at layer 3 DSCP, so by default the switch should be honoring the DSCP settings .

You can't do much about removing VLAN 100 from the switch, it wont be doing much anyway, since you are probably mixing phones and PC's in the default VLAN.

Persoanlly the easiest thing to do is maybe hust disable advanced QOS and go back to BASIC QOS settings and just trust DSCP.

Interesting what my colleagues will say.

As a best practice, I would get a recommendation from Ring central, as I have no idea how they provisioned your phones .

Any more information would be interesting.

regards Dave

The only recommendation from RingCentral has been to open port ranges 5060 to 5090 and 16384 to 16482, and 8000 to 8200 for their Call Controller with a softphone. Turn on port triggering in a router for them and turn on QoS in the router.

I do have the PCs and phones mixed on the network, and they are just separate networks (the phones are public IPs and the computers private IPs).

netguyz08
Beginner

I know it had been a year, but just wanted to note the solution was leave the Cisco switch with the default config, and separate wiring was done just for the VOIP phones. So just the phones went through the switch - none of the computers and servers. This handled the issues for voice quality.

Sent from Cisco Technical Support iPhone App

Create
Recognize Your Peers
Polls
How would you describe your level of technical expertise?