cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


7996
Views
0
Helpful
5
Replies
Beginner

devices in VLAN can't get DHCP address from router

Hi

I'm trying to set up a new Cisco SF500-24P switch for our new Polycom IP phones but I'm having some trouble configuring them. It seems a fairly basic setup - We have a Cisco 2800 series router which is configured in a router-on-a-stick scenario to give DHCP addresses to two vlans, '1' for data and '20' for voice...

ip dhcp pool DHCPROUTER

   network 10.10.0.0 255.255.255.0

   default-router 10.10.0.1

   dns-server 10.20.124.200 10.20.124.201

!

ip dhcp pool DHCPVOICE

   network 172.16.0.0 255.255.255.0

   default-router 172.16.0.1

   dns-server 10.20.124.200 10.20.124.201

interface FastEthernet0/1

description Local Ethernet Interface

no ip address

duplex full

speed auto

!        

interface FastEthernet0/1.1

description DATA

encapsulation dot1Q 1 native

ip address 10.10.0.1 255.255.255.0

!

interface FastEthernet0/1.20

description VOICE

encapsulation dot1Q 20

ip address 172.16.0.1 255.255.255.0

service-policy input LABEL

The switch worked practically straight out of the box- when I connected a PC or a phone into it they both got addresses in the 10.10.0.0 range and both worked fine. In the web interface I then set the Voice VLAN ID as 20 and as soon as I did this the phones can no longer get addresses from DHCP (although PCs can). The switch and the phone display both show that the phone is in VLAN 20. All ports are members of VLAN1(native, untagged) and VLAN 20 (tagged) and the port connecting to the router is trunked, as are the others.Also, I can ping 172.16.0.1 from the switch so there is no routing problem, although I did try using the switch as a DHCP relay to 172.16.0.1 but still no luck.

I'm not sure how relevant this is but one thing I noticed is that data going to the router untagged (and therefore in VLAN 1) gets through but if I tag it with VLAN 1 then it doesn't.

The rest is pretty much default, I havent't spent too much time with QoS yet as I'd like to get the connectivity sorted out first.

Any thoughts on what I'm doing wrong?

thanks in advance

Carter

Everyone's tags (6)
5 REPLIES 5
Highlighted
Advocate

devices in VLAN can't get DHCP address from router

Hi Carter, send me an email with a phone number. I would like to call you at 4pm eastern time if that is okay.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/
Highlighted
Beginner

devices in VLAN can't get DHCP address from router

Should my router need the ip-helper comand under the subinterfaces?

Highlighted
Rising star

devices in VLAN can't get DHCP address from router

Good morning

Thanks for using our forum

Hi Ian Carter, The command ip helper  is used to propagate a broadcast on a router. The broadcast is propagated as unicast to the IP address set in the command. By default propagate only 8 protocols:

* TIME, port 37

* TACACS, port 49

* DNS, port 53

* BOOTP / DHCP server, port 67

* BOOTP / DHCP Client, port 68

* TFTP, port 69

* NetBIOS name service, port 137

* NetBIOS datagram service, port 138

This command is configured on the interface receiving the broadcast

I hope you find this answer useful, if it was satisfactory  for you, please mark the question as Answered.

Please rate helpful posts.

Greetings,

Johnnatan Rodriguez Miranda.

Cisco network support engineer.

“Please rate useful posts so other users can benefit from it” Greetings, Johnnatan Rodriguez Miranda. Cisco Network Support Engineer.
Highlighted
Beginner

devices in VLAN can't get DHCP address from router

I still haven't been able to get this working but it does seem to be a VLAN issue - When I assign a port on the switch to have PVID = 20 and plug a phone (or laptop) into it, then it will correctly get an address on the 172.16.0.0 subnet. However, setting the port to use tags results in the phone getting an address in the 10.10.0.0 (data) VLAN so it must be something to do with how the VLAN information is set on the phone. (This makes me think it may be something to do with LLDP or CDP)

I decided to restore the switch to factory settings and start again, so...I have native VLAN1 for data and created VLAN 20 for voice. I have switch port 1 connected to the router; it is a trunk port with VLAN1 and VLAN 20 allowed. I have another trunk port with the same setting, VLAN1 and VLAN 20 allowed which I plug a phone into. When the phone boots it shows VLAN 20 and an address in the 10.10.0.0 range, which is obviously incorrect.

Both LLDP and CDP are enabled on the phone so when i check the LLDP neighbours on the switch config, the phone shows up but its vlan info is blank - surely this should be pushed to the phone by the switch?

When I check the CDP neighbours table the phone doesn't showi at all, only the router does, which is strange as the phone does support it and it is enabled.

Also, when I check the auto-smartport settings, it doesn't recognise that a phone is connected, instead it just says 'unknown'.

ICan you see where I'm going wrong? Should the phone show up in both CDP and LLDP neighbour tables on the switch if both are enabled on the phone ? (I know the phone prioritises LLDP over CDP)

thanks

Highlighted
Advocate

devices in VLAN can't get DHCP address from router

Hi Ian, I do not feel the forum is the best place to look at the whole configuration or to identify any or all problems. If you'd like, please take me up on the original offer, I will give you a call and see if we can sort it out. Also, IP helper likely won't help you, as this is fundamental layer 2 networking.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/