cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


1731
Views
0
Helpful
4
Replies
Highlighted
Beginner

How to configure qinq on SG350?

In the network with SG300 switches I have a new SG350 switch.
How to configure qinq on it?

How should the Customer port be set to SG350? How to trunk between SG300 and SG350? Which Ethertype Tagging should be set?

 

On SG300 qinq works without problems.

4 REPLIES 4
Highlighted
VIP Mentor

have you tried below example :

 

interface FastEthernet x/x

switchport access vlan XXX

switchport mode dot1q-tunnel

duplex full

speed 100

no mdix auto

l2protocol-tunnel cdp

l2protocol-tunnel stp

l2protocol-tunnel vtp

 

or post your current config to suggest.

 

BB
*** Rate All Helpful Responses ***
Highlighted

Unfortunately, these are Small Business Switches. I have some other commands.

 

On the old switch SF300 (worked)

interface fastethernet1
 description "Cust GR1 QinQ"
 switchport mode customer
 switchport customer vlan 1050
!

 

On SF350 port configuration:

interface FastEthernet1
 gvrp vlan-creation-forbid
 gvrp registration-forbid
 spanning-tree disable
 switchport mode customer
 switchport access vlan none
 switchport trunk native vlan none
 switchport customer vlan 1050
!

 

 

SW-GR1(config-if)#switchport mode
  general              generic port mode
  access               vlan unaware port
  trunk                vlan aware port
  customer             customer equipment port
  vlan-mapping         VLAN mapping modes
  private-vlan         private VLAN modes

I don't know what to do with it

 

SW-GR1(config-if)#switchport nni ethtype
  dot1q                TPID 0x8100
  dot1ad               TPID 0x88a8
  9100                 TPID 0x9100
  9200                 TPID 0x9200

Should I change something?

 

Highlighted

The mode customer and customer vlan work just fine on all our sg350.

 

Highlighted

Look at this thread may help you :

 

https://community.cisco.com/t5/small-business-switches/sg300-q-in-q/td-p/2887948

 

BB
*** Rate All Helpful Responses ***