cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


477
Views
0
Helpful
3
Replies
Highlighted
Beginner

Impossibility of device access to each other on switches

Hi Guys

I have one switch 3750 and two switches 2960. I started VTP and DHCP. But when I connect the computers to the switches after they get a proper IP from DHCP, they can not ping each other. Whether they are in the same VLan or devices have different VLans. In Packet Tracer, everything is correct and the devices ping each other. But this choice does not fall on the physical switch. I put the switches config file. Please tell if there is a mistake and if there is a way to improve. And what can I do to make VLans have access to each other and fix this problem?

3750 : 

 

enable
configure terminal
hostname SW-Core
ip default-gateway 10.10.10.1
ip domain-name F13
vtp mode server
vtp domain F13
vtp version 2
vtp pruning
enable secret Hadi@123
line vty 0 15
password Hadi@123
login
exit
line console 0
password Hadi@123
login
exit
VLan 10
name Core
exit
VLan 31
name F3N
exit
VLan 32
name F3S
exit
interface vlan 10
ip address 10.10.10.1 255.255.255.0
no shutdown
exit
interface vlan 31
ip address 10.10.31.1 255.255.255.0
no shutdown
exit
interface vlan 32
ip address 10.10.32.1 255.255.255.0
no shutdown
exit
ip routing
interface range gigabitEthernet 1/0/1-6
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 1-99
no shutdown
exit
interface range gigabitEthernet 1/0/7-12
switchport mode access
switchport access vlan 10
no shutdown
exit
interface range gigabitEthernet 1/0/13-24
shutdown
exit
ip dhcp pool Core
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 10.10.10.2
lease 21
exit
ip dhcp pool F3N
network 10.10.31.0 255.255.255.0
default-router 10.10.31.1
dns-server 10.10.10.2
lease 21
exit
ip dhcp pool F3S
network 10.10.32.0 255.255.255.0
default-router 10.10.32.1
dns-server 10.10.10.2
lease 21
exit
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 10.10.31.1 10.10.31.10
ip dhcp excluded-address 10.10.32.1 10.10.32.10
exit
exit
write

 

One of the 2960 switches :

 

enable
configure terminal
hostname SW-F3N
vtp mode client
vtp domain F13
enable secret Hadi@123
line vty 0 15
password Hadi@123
login
exit
line console 0
password Hadi@123
login
exit
interface gigabitEthernet 0/24
switchport mode trunk
no shutdown
exit
interface range gigabitEthernet 0/21-23
shutdown
exit
interface range gigabitEthernet 0/1-20
switchport mode access
switchport access vlan 31
no shutdown
exit
exit
write

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Can you post both the devices below information :

 

show vtp status

show vlan

 

other observation based on your input.

 

- But even in VLAN 10, which is on the 3750 switch, when two devices receive IP from DHCP, they still can not ping each other.

 

BB - if the Device to device has communication (i am guessing based on above statement) - Windows FW is the issue, disable Windows FW and test.


Gateway of last resort is not set

 

BB - is this Device no outgoing internet or is this just inside the office network.

 

high level my understand is - you have Core switch which has no connection anywhere to go to the internet, all the SVI VLAN configured and they able to communicate each other ?  and you have added Layer 2 switch - but end device not able to communicate with the devices connected in the Core switch.

 



BB


*** Rate All Helpful Responses ***

View solution in original post

3 REPLIES 3
Highlighted
VIP Expert

If you end Access switch device connected to VLAN 31, they should be able to get access other vlan since you already enabled in Trunk

 

worth look at 2960 switch - is the VLAN populated and spanning tree available  - make sure always use VTP v2

 

Are you able to ping other Gateways ? from the device ?

 

can you post show ip route from the main switch ?



BB


*** Rate All Helpful Responses ***

Highlighted
Beginner

Thank you for your response

- VTP version 2 is enabled

VTP Version                     : 2

Configuration Revision          : 12

Maximum VLANs supported locally : 1005

Number of existing VLANs        : 12

VTP Operating Mode              : Server

VTP Domain Name                 : F13

VTP Pruning Mode                : Enabled

VTP V2 Mode                     : Enabled

VTP Traps Generation            : Disabled

MD5 digest                      : 0x52 0xDD 0x64 0x03 0x7F 0x97 0x90 0x1E

Configuration last modified by 10.10.10.1 at 3-1-93 00:07:20

Local updater ID is 0.0.0.0 (no valid interface found)


- Gateway and even other VLANs can be pinged.

- But even in VLAN 10, which is on the 3750 switch, when two devices receive IP from DHCP, they still can not ping each other.


SW-Core# show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     10.0.0.0/24 is subnetted, 7 subnets

C       10.10.10.0 is directly connected, Vlan10

C       10.10.31.0 is directly connected, Vlan31

C       10.10.32.0 is directly connected, Vlan32

C       10.10.41.0 is directly connected, Vlan41

C       10.10.42.0 is directly connected, Vlan42

C       10.10.51.0 is directly connected, Vlan51

C       10.10.52.0 is directly connected, Vlan52

Highlighted

Can you post both the devices below information :

 

show vtp status

show vlan

 

other observation based on your input.

 

- But even in VLAN 10, which is on the 3750 switch, when two devices receive IP from DHCP, they still can not ping each other.

 

BB - if the Device to device has communication (i am guessing based on above statement) - Windows FW is the issue, disable Windows FW and test.


Gateway of last resort is not set

 

BB - is this Device no outgoing internet or is this just inside the office network.

 

high level my understand is - you have Core switch which has no connection anywhere to go to the internet, all the SVI VLAN configured and they able to communicate each other ?  and you have added Layer 2 switch - but end device not able to communicate with the devices connected in the Core switch.

 



BB


*** Rate All Helpful Responses ***

View solution in original post