cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


4137
Views
5
Helpful
8
Replies
Profitgeier
Beginner

Login to SNA failed

I bought an SG350-10 switch and updated the firmware version to 2.3.5.63.

 

After setting up the switch including setting a new password for the default user "cisco"i noticed that i can't login to the "Smart Network Application" (SNA).

 

Logging in to the Application "Switch Management" or directly to "Network Management" works, but when i want to switch over to SNA in the Switch Management menu or after a direct login via "Network Management" a query window pops up asking me for a username and PW again to login to SNA.

 

After i enter "cisco" as username and my password i get the following error message

 

The password i entered is the same as the one i use to login to the switch management menu.

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

I think i now have narrowed it down to the problem.

After some trials with creating new usernames with and without a disabled password strength meter and using other for testing much simpler passwords i noticed that the only user the SNA login did not accept was my old cisco user account with the old password.

 

It seems to be, that the login function of the SNA login doesn't work with passwords that contain a '+' char in the password string.

After exchanging the '+' char in the password with another char the login to SNA worked like a charm.

Now i can login to SNA.

 

Thanks a lot for helping me out.

 

View solution in original post

8 REPLIES 8
Aleksandra Dargiel
Cisco Employee

Hello Profitgeier,

 

 It is normal to prompt for login again.

Have you tried to use different browser or perhaps clear all cookies and restart browser again and try again. 

 

Regards,

Aleksandra

Aleksandra Dargiel
Cisco Employee

Hello Profitgeier,
 
 It is normal to prompt for login again.
Have you tried to use different browser or perhaps clear all cookies and restart browser again and try again. 
 
Regards,
Aleksandra

Hello Aleksandra,

 

yes, i tried Chrome instead of Firefox but i got the same error.

Also reloading the page in Firefox with CTRL+F5 didn't help.

 

 

 

I wonder if you can try other with brand new username and password for switch (the username never used before) or perhaps with the default username/pass after factory reset, and disabled password strength meter.

I think i now have narrowed it down to the problem.

After some trials with creating new usernames with and without a disabled password strength meter and using other for testing much simpler passwords i noticed that the only user the SNA login did not accept was my old cisco user account with the old password.

 

It seems to be, that the login function of the SNA login doesn't work with passwords that contain a '+' char in the password string.

After exchanging the '+' char in the password with another char the login to SNA worked like a charm.

Now i can login to SNA.

 

Thanks a lot for helping me out.

 

View solution in original post

great tests! thank you for sharing

by '+' do you mean special characters or just that particular one? 

Special characters like '#' and '-' do work, but '+' does definitely not work.

 

If you have a '+' char in your password string, the login to SNA (Network Management) will fail.

 

Sadly, this bug is still not fixed.

I am running Firmware Version 2.5.7.85 at the moment on my switch here.