cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


1827
Views
0
Helpful
1
Replies
Highlighted

Multiple VLANs between 2 SG300-10

Hi all,

I have 2 SG300-10 switches, and I need two VLANs, one for internal network and one for WiFi APs.

I need ports 1->4 on both switches to be part of 1st VLAN  and ports 5->8 on 2nd VLAN; and port 10 uplink to 2nd switch.

How I set up the VLANs and interface VLAN mode?

Port 1->4 vlan 10, port 5->8 vlan 20 and port 10 vlan 10, 20 and 1 ? (assuming I have VLAN 10 and 20 and default 1)

Ports 1->8 mode general and port 10 mode trunk?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

Multiple VLANs between 2 SG300-10

Hi Adrian, the first question is, what is your router?

To answer your question. The ports connecting single host can be configured as any port mode, but access port is preferential. The links connecting between switches may be trunk or general with vlan 1 untag, vlan 10 tag, vlan 20 tag.

The cli command would look as such

config t

vlan database

vlan 10,20

interface range gi1-4

switchport mode access

switchport access vlan 10

interface range gi5-8

switchport mode access

switchport access vlan 20

interface gi10

switchport mode trunk

switchport trunk allowed vlan add all

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

View solution in original post

1 REPLY 1
Advocate

Multiple VLANs between 2 SG300-10

Hi Adrian, the first question is, what is your router?

To answer your question. The ports connecting single host can be configured as any port mode, but access port is preferential. The links connecting between switches may be trunk or general with vlan 1 untag, vlan 10 tag, vlan 20 tag.

The cli command would look as such

config t

vlan database

vlan 10,20

interface range gi1-4

switchport mode access

switchport access vlan 10

interface range gi5-8

switchport mode access

switchport access vlan 20

interface gi10

switchport mode trunk

switchport trunk allowed vlan add all

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

View solution in original post