cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

CISCO SWITCHES FOR SMALL and MEDIUM BUSINESS

Introducing the next generation of Cisco Small and Medium Business Switches. Cisco is refreshing its SMB Switch portfolio. Click here  to learn more.


8438
Views
0
Helpful
5
Replies
Highlighted
Beginner

My Small Business Switch SF 302-08 won't let me apply "routing" command

Hi everyone, my switch cisco small business SF 302-08 has the latest firmware and i want to enable the routing command but it won't let me do that.

I already read the reference guide for commands, i do all this procedure: IP Routing Protocol-Independent Commands starting at 629 page, but nothing happens. I need this because i want a routing between Vlan's

Regards.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Rising star

Re: My Small Business Switch SF 302-08 won't let me apply "routi

Hi Felipe,


Excuse this post if you have already done the following, but I think you should initially check two things;

( sorry I like the GUI so I am using the GUI in my suggestion not CLI);

1.the  firmware version you have on the switch.

2. Check the system summary in the GUI, to see if  if the switch is in layer 3 mode and firmware version.

The switch is in layer 2 mode by default.

See from my screen capture below,  i am using the current version of code that i found on the cisco website.

The firmware  as of Sep 2012 is called sx300_fw-12776.ros

Upgrade if you wish, it's worth the time but not essential,  there are some really good features added with the current software release.

Then set the switch to layer 3 mode.  See Step 3 in the screen capture below.

When you type 'menu' from the console or the telnet screen,  a menu will come up.  Goto the system mode menu option and set the switch to layer 3 mode.

When you take the action to set the switch to Layer 3 mode,  the switch will reset the configuration to factory defaults, there is a good reason for that.  But wont go into the reasoning, just to say it wipes the 'slate', registers etc  clean..

regards Dave

rate this post if it answers your question.

View solution in original post

Rising star

Re: My Small Business Switch SF 302-08 won't let me apply "routi

Hi Felipe

Keen to hear how you are going.

If  you reset the switch to factory defaults and the switch is NOT connected to a DHCP server, the switch reboots  with a default IP address of 192.168.1.245 as per the quick start guide .  If your PC has a static address of say, 192.168.1.2, you should be able to access the GUI of the switch.

http://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/quick_start/78-19252-01.pdf

If the switch is connected to a DHCP server, the switch will get  an IP address via DHCP.

I  have had issues using hyperterminal on my Windows 7 box, which i have overcome by rebooting my PC to free up the coms port.  Console settings are;

  • 115200 bits per second
  • 8 data bits
  • no parity
  • 1 stop bit
  • no flow control

If you are really having trouble, and you suspect the switch is faulty,  you have the option of using the services of the Small business Support Center (SBSC) to identify if the switch is good or bad.

The URL that shows contact phone numbers is below;

www.cisco.com/go/sbsc

regards Dave

View solution in original post

5 REPLIES 5
Rising star

Re: My Small Business Switch SF 302-08 won't let me apply "routi

Hi Felipe,


Excuse this post if you have already done the following, but I think you should initially check two things;

( sorry I like the GUI so I am using the GUI in my suggestion not CLI);

1.the  firmware version you have on the switch.

2. Check the system summary in the GUI, to see if  if the switch is in layer 3 mode and firmware version.

The switch is in layer 2 mode by default.

See from my screen capture below,  i am using the current version of code that i found on the cisco website.

The firmware  as of Sep 2012 is called sx300_fw-12776.ros

Upgrade if you wish, it's worth the time but not essential,  there are some really good features added with the current software release.

Then set the switch to layer 3 mode.  See Step 3 in the screen capture below.

When you type 'menu' from the console or the telnet screen,  a menu will come up.  Goto the system mode menu option and set the switch to layer 3 mode.

When you take the action to set the switch to Layer 3 mode,  the switch will reset the configuration to factory defaults, there is a good reason for that.  But wont go into the reasoning, just to say it wipes the 'slate', registers etc  clean..

regards Dave

rate this post if it answers your question.

View solution in original post

Beginner

My Small Business Switch SF 302-08 won't let me apply "routing"

Well...now i am unable to access to the switch. I forgot the ip address, i pressed the reset button more than 10 seconds like says the "user's guide" :

  • To restore the managed switch configuration to the factory default settings:

     1. Disconnect the managed switch from the network or disable all

         DHCP servers on your network.

     2. With the power on, press-and-hold the Reset button for more than

         10 seconds.

I am on the right subnet and mask and also i can't access to the console with the cisco cable console !

I think the switch is "halfdead" if that word exists in english.

I have ethernet connection but i have no access to the switch...If theres a way to make an "hyper" hard factory reset ?

Thank you again...

Beginner

My Small Business Switch SF 302-08 won't let me apply "routing"

Adding some information, if i type at command line interface "IP ?" for a command within IP (ethernet, ROUTING, etc) ROUTING didn't shows there...i know that i have to enable routing, please someone help !

Rising star

Re: My Small Business Switch SF 302-08 won't let me apply "routi

Hi Felipe

Keen to hear how you are going.

If  you reset the switch to factory defaults and the switch is NOT connected to a DHCP server, the switch reboots  with a default IP address of 192.168.1.245 as per the quick start guide .  If your PC has a static address of say, 192.168.1.2, you should be able to access the GUI of the switch.

http://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/quick_start/78-19252-01.pdf

If the switch is connected to a DHCP server, the switch will get  an IP address via DHCP.

I  have had issues using hyperterminal on my Windows 7 box, which i have overcome by rebooting my PC to free up the coms port.  Console settings are;

  • 115200 bits per second
  • 8 data bits
  • no parity
  • 1 stop bit
  • no flow control

If you are really having trouble, and you suspect the switch is faulty,  you have the option of using the services of the Small business Support Center (SBSC) to identify if the switch is good or bad.

The URL that shows contact phone numbers is below;

www.cisco.com/go/sbsc

regards Dave

View solution in original post

Beginner

Re: My Small Business Switch SF 302-08 won't let me apply "routi

My Switch it's already as Router, this post can be closed.

Thank you so much